Stuck at splash screen

This topic contains 8 replies, has 2 voices, and was last updated by Profile photo of petrockblog petrockblog 4 years ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1886
    Profile photo of Brian Higgins
    Brian Higgins
    Participant

    Hi all, I have installed the RetroPie image, copied over my NES roms and configured my NES controller. My controller is an origional NES controller that is connected using a RetroPort USB plug. However, when I boot up the Pi, I just see the ‘RetroPie’ splash screen. The controller doesn’t do anything, aside from shut down the Pi if I hit ‘Start’ 5 times.

    Is there some step I’m missing in getting everything set up ?

    Thanks,

    Brian

    #1888
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Just to be sure: You used the SD-card image?

    Also, does everything boot and start fine, when you do not have the RetroPort USB connected to the RPi?

    Maybe it works, if you use an active (i.e., a self-powered) USB hub to connect the RetroPort USB. This is just a guess, though.

    #1890
    Profile photo of Brian Higgins
    Brian Higgins
    Participant

    Hi, thanks for the quick reply!

    I’m using the SD-card image. Even without the RetroPort USB, the Pi still just boots to the ‘RetroPie’ splash screen and sits there.

    Are there any log files that might provide a clue to what is wrong ?

    Brian

    #1891
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Did you expand the root filesystem via sudo raspi-config? Maybe there is no space left after you have copied the ROMs.

    I have tested the image with HDMI video output. You should be able to SSH into the RPi.

    #1892
    Profile photo of Brian Higgins
    Brian Higgins
    Participant

    Hi, I have not expanded the root filesystem. I will try next.
    I am able to connect via SSH or TightVNC and everything works fine in that regard.

    Brian

    #1906
    Profile photo of Brian Higgins
    Brian Higgins
    Participant

    Hi, I’ve expanded the file system to now use the entire 8 GB and deleted all but 3 NES games.
    I’ve also set the memory split to 128 MB. I don’t know if it’s important or not, but I am using composite video.

    Thanks,

    Brian

    #1908
    Profile photo of petrockblog
    petrockblog
    Keymaster

    A possible next step would be to SSH into the pi and disable the splash screen with the Setup Script.
    You could also try to start a NES rom directly from command line. The commands that Emulation Station uses can be found in /home/pi/.emulationstation/es_systems.cfg.

    #1967
    Profile photo of Brian Higgins
    Brian Higgins
    Participant

    Hi, finally figured out the problem. I had installed TightVNC, which was preventing EmulationStation from starting.

    Thanks for your help,

    Brian

    #1970
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Really glad to hear!

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar