Struggling with xbox 360 Controller

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Struggling with xbox 360 Controller

This topic contains 3 replies, has 2 voices, and was last updated by  KazooZoo 2 years, 10 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #85196

    pcarcade
    Participant

    I’m struggling to get the xbox360 controller to work, It works fine in the menus of EmulationStation, but when I go out to the SNES emulator, all the buttons are screwy (d-pad down for start and no movement at all for example) This is with Zelda a link to the past BTW!

    This is the content of my retroarch.cfg file:

    
    input_enable_hotkey = nul
    input_player1_joypad_index = "0"
    input_player1_b_btn = "1"
    input_player1_y_btn = "3z
    input_player1_select_btn = "6"
    input_player1_start_btn = "7"
    input_player1_up_btn = "h0up"
    input_player1_down_btn = "h0down"
    input_player1_left_btn = "h0left"
    input_player1_right_btn = "h0right"
    input_player1_a_btn = "0"
    input_player1_x_btn = "2"
    input_player1_l_btn = "4"
    input_player1_r_btn = "5"
    input_player1_l2_axis = "+2"
    input_player1_r2_axis = "+5"
    input_player1_l3_btn = "9"
    input_player1_r3_btn = "10"
    input_player1_l_x_plus_axis = "+0"
    input_player1_l_x_minus_axis = "-0"
    input_player1_l_y_plus_axis = "+1"
    input_player1_l_y_minus_axis = "-1"
    input_player1_r_x_plus_axis = "+3"
    input_player1_r_x_minus_axis = "-3"
    input_player1_r_y_plus_axis = "+4"
    input_player1_r_y_minus_axis = "-4"
    input_player1_joypad_index = "0"
    input_player1_b_btn = "5"
    input_player1_y_btn = "7"
    input_player1_select_btn = "12"
    input_player1_start_btn = "13"
    input_player1_up_btn = "0"
    input_player1_down_btn = "1"
    input_player1_left_btn = "2"
    input_player1_right_btn = "3"
    input_player1_a_btn = "4"
    input_player1_x_btn = "6"
    input_player1_l_btn = "8"
    input_player1_r_btn = "9"
    input_player1_l2_btn = "10"
    input_player1_r2_btn = "11"
    input_player1_l3_btn = "15"
    input_player1_r3_btn = "16"
    input_player1_l_x_plus_axis = "+0"
    input_player1_l_x_minus_axis = "-0"
    input_player1_l_x_minus_axis = "-0"
    input_player1_l_y_plus_axis = "+1"
    input_player1_l_y_minus_axis = "-1"
    input_player1_r_x_plus_axis = "+2"
    input_player1_r_x_minus_axis = "-2"
    input_player1_r_y_plus_axis = "+3"
    input_player1_r_y_minus_axis = "-3"
    

    Also ES isn’t filling the entirety of my screen, although this is a minor problem, is there a way to force 1080p res?

    Thanks in advance for any help!

    #85197

    KazooZoo
    Participant

    Ye for some you need to change each emulator’s config file. I have not yet done it myself, I just adjusted myself. But here is a link to a video that deals with this:

    https://www.youtube.com/watch?v=ELNMysmF4bI. Hope it helps.

    #85198

    pcarcade
    Participant

    copied the over into the .cfg in the snes config directory and it made no difference 🙁

    Thanks for the help though

    #85202

    KazooZoo
    Participant

    sorry to hear that, I also found this on your screen size, hope it helps.:http://blog.petrockblock.com/forums/topic/change-screen-size-to-fit/

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/