Startx no longer works?

This topic contains 12 replies, has 8 voices, and was last updated by Profile photo of davidpearl davidpearl 2 years, 3 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #88285
    Profile photo of mazza
    mazza
    Participant

    Installed the latest version on a RPi 1, and when I try to get to the startx GUI, I just get a small window in the top right showing some info, uptime, memory etc and a command line.

    It won’t let me do anything here, and I need to recycle the power to get anything

    Any ideas on why this is? Not had an issue on v2.3 with 3 different installs

    #88299
    Profile photo of Roo
    Roo
    Participant

    The desktop GUI is not included in newer builds of RetroPie. You can add it back in with sudo apt-get install lxde but it uses a lot of space and resources.

    What are you trying to do that you need the Desktop?

    #88304
    Profile photo of lawbag
    lawbag
    Participant

    One of the reasons I use StartX is to access the Network settings as I use a wireless USB dongle to connect my Pi to the internet rather than rely on cables.

    #88310
    Profile photo of Roo
    Roo
    Participant

    If it were me, I would get used to doing things without startx – adding lxde back in is going to cause you more problems than it solves.

    sudo nano /etc/network/interfaces

    your interfaces file should look like this

    auto lo
    iface lo inet loopback
    iface eth0 inet dhcp
    
    allow-hotplug wlan0
    auto wlan0
    
    iface wlan0 inet dhcp
       wpa-ssid "Your Network SSID"
       wpa-psk "Your Password"
    

    How-To: Add WiFi to the Raspberry Pi

    #88312
    Profile photo of herbfargus
    herbfargus
    Member

    [redacted- what ROO said]

    once you have configured your wifi adapter like roo outlined-

    sudo /etc/init.d/networking restart

    or

    sudo /etc/init.d/networking stop
     sudo /etc/init.d/networking start

    or
    sudo reboot

    Now your wifi should be running- no gui needed.

    #88433
    Profile photo of mazza
    mazza
    Participant

    I still find using a GUI easier than command prompt, so it was to setup WiFi.

    Ended up using command line instructions from the RPi website (wpa_supplicant) and got it working.

    Thanks for the responses, not having the GUI will force me to learn more through command prompt, so all good 🙂

    #88455
    Profile photo of Chosen
    Chosen
    Participant

    I’m on my 4th clean install of the latest image for the RPi2, and I have to say its been all due to installing lxde or xfce. I enjoyed be able to utilize the gui desktop for the sole purpose of clicking and seeing some things such as bluetooth manager and wifi manager. But after this most recent clean install I’ve decided to forego the GUI and keep my pi strictly a gaming console and working on it with the command line.
    There is a plethora of info on setting up the wifi adapter and bluetooth adapter. I’m a big fan of text editors, but in the long run if all you’re going to do is make a few minor changes to a file then the command line is really all you need.
    Goals for tomorrow: configure pi basic settings, get bluetooth up and running and have it ALWAYS searchable, try relentlessly to get my ps4 controller to work with games wirelessly (i can get emulationstation to recognize it and allow me use it to move between selecting games wired, I was even able to get it to do this wirelessly. But for some reason games will not recognize my controller wired or wireless), and maybe even find someone who has had success in getting the Edimax EW-7811UTC wifi adapter working on the RPi2(then I’ll finally be able to move to the big screen and cut the cord from the ethernet)
    Good luck to you, with all of the resources available and the wonderful support of fellow users in these forums getting your project running is only a matter of time and patience!

    #88469
    Profile photo of lawbag
    lawbag
    Participant

    thanks for that, Ive used startx very little, and feel more comfortable at the line prompts.

    When my Pi2 comes Ill try the startline interface.

    #88490
    Profile photo of man3l3t
    man3l3t
    Participant

    What is the problem if I install lxde?
    If I don’t start lxde, it take resources from the Raspberry and make emulation slower? The space isn’t a problem for me.

    #88492
    Profile photo of petrockblog
    petrockblog
    Keymaster

    there is no problem if you want to install lxde.

    #88507
    Profile photo of Roo
    Roo
    Participant

    there is no problem if you want to install lxde.

    Have you actually done it on the latest builds? It breaks some other stuff, like ES autoloading

    #88508
    Profile photo of petrockblog
    petrockblog
    Keymaster

    yes.

    you can not install a display manager if you don’t want it to start up on boot.

    people that really want a desktop gui, should probably just install retropie-setup over raspbian though – the retropie image is meant to be compact.

    #89367
    Profile photo of davidpearl
    davidpearl
    Participant

    Without StartX I am stuck with setting up wifi.

    Dongle plugged in:

    pi@retropie ~ $ lsusb
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
    Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
    Bus 001 Device 005: ID 1997:2433
    Bus 001 Device 006: ID 045e:028e Microsoft Corp. Xbox360 Controller

    And then, Interfaces screen:

    auto wlan0

    iface lo inet loopback
    iface eth0 inet dhcp

    allow-hotplug wlan0
    iface wlan0 inet manual
    wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
    iface default inet dhcp

    Next Config file:

    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1

    network={
    ssid=”SKYC****”
    psk=”********”
    proto=RSN
    key_mgmt=WPA-PSK
    pairwise=CCMP
    auth_alg=OPEN
    }

    It seems from the instructions I have done it all right but its still not working:

    wlan0 Link encap:Ethernet HWaddr 80:1f:02:b3:2a:4e
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:2 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1758 (1.7 KiB) TX bytes:940 (940.0 B)

    Any suggestions of where I have gone wrong?

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar