starting vic-20 games directly frome ES – got it working :)

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project starting vic-20 games directly frome ES – got it working :)

This topic contains 18 replies, has 5 voices, and was last updated by  labelwhore 1 year, 11 months ago.

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
  • #115102


    This morning, I saw that newpie was trying to figure out how to launch vic 20 games. He got it figured out, but the process looked pretty convoluted. Early on, I had wanted to get vic 20 games working and separated from the c64 section, which I had actually forgotten to do since then. Since I’ve done this same thing for several other systems by now, I thought I’d help anyone else who wanted the same thing. So here goes…

    First, create a vic20 folder in the roms folder.

    sudo mkdir /home/pi/RetroPie/roms/vic20

    and change it’s permissions

    sudo chown pi:pi /home/pi/RetroPie/roms/vic20

    Now copy the roms to the new folder.

    We also need a vic20 section in /etc/emulationstation/es_systems.cfg. So edit that file and place this wherever it makes sense to you.

    sudo nano /etc/emulationstation/es_systems.cfg

        <fullname>Commodore Vic20</fullname>
        <extension>.crt .d64 .g64 .prg .t64 .tap .x64 .zip .CRT .D64 .G64 .PRG .T64 .TAP .X64 .ZIP</extension>
        <command>/opt/retropie/supplementary/runcommand/ 0 _SYS_ vic20 %ROM%</command>

    Ctrl+X to save

    Now we need a folder for the config file:

    sudo mkdir /opt/retropie/configs/vic20

    and change it’s permissions

    sudo chown pi:pi /opt/retropie/configs/vic20

    Within that folder create a file called emulators.cfg.

    touch /opt/retropie/configs/vic20/emulators.cfg

    Edit the file

    sudo nano /opt/retropie/configs/vic20/emulators.cfg

    and copy this code into it:

    vice-xvic-carta="/opt/retropie/emulators/vice/bin/xvic -cartA %ROM%"
    vice-xvic-cartb="/opt/retropie/emulators/vice/bin/xvic -cartB %ROM%"
    vice-xvic-cart2="/opt/retropie/emulators/vice/bin/xvic -cart2 %ROM%"
    vice-xvic-cart4="/opt/retropie/emulators/vice/bin/xvic -cart4 %ROM%"
    vice-xvic-cart6="/opt/retropie/emulators/vice/bin/xvic -cart6 %ROM%"

    Ctrl+X to save

    I also copied over the file named “sdl-vicerc” from the c64 folder to the vic20 folder just in case it was needed here as well. I don’t know if this is truly needed.

    cp /opt/retropie/configs/c64/sdl-vicerc /opt/retropie/configs/vic20/

    …at this point I’ve got myself stuck. It seems like there is a defect in VICE, where it’s not attaching vic-20 images. It should, according to the manual.

    Whenever I launch a rom, I have to go into the emulator menu, attach the game I just tried to launch, then select autostart. But we shouldn’t have to do that, they should just autostart. Has anyone run into this and fixed it?

    Edit: I got it working! The change was to add “-cartA” to emulators.cfg. It all works now, so I’m off to find some more vic-20 roms and make a theme. I’ve tried .crt and .prg images as well as .zip files. The .d64 files that are zipped in some rom collections do not work with this method. (Those look like mis-categorized c64 roms to me anyway.)
    ^^ my other hobby



    The above only works with $A000 images, apparent haven’t found a more generic way to do this. One would think that the -cartgeneric flag would do it, but nope! That doesn’t seem to work at all. Right now, the only way I can see getting all vic-20 games to work like this is to make a section for each type; $2000, $4000, $6000, $A000, and $B000.
    ^^ my other hobby



    Thanks for this! I have a full set of Vic20 roms that I will get to tinkering with now.

    You also gave me a good starting point to get thw CoolCV (Colecovision) emu working. Should be easy now.

    Out of curiosity, what other systems did you get up and running?



    As an aside I’ll likely be adding CoolCV to the setup script sometime in the future (perhaps after my exams)



    That would be great, Herb. Good luck!



    Thanks for all the work you are putting into this and I really tried to follow your steps but it seems Retropie is denying me access:

    – via network, all I can do is copy my CRT-Rom to the direcectory I created

    And as Retropie does not grant me the right to view/edit all the files, I am not able to grant myself access to them as I am not allowed to edit the config file that would allow that.



    I’ll see if I can get some time today to fill in the commands so that of this can be done via command line.

    Tbh, I don’t know them myself yet.

    As far as what systems I’ve separated; I separated CPS from Neo Geo and the rest of FBA roms. I also took PRBoom out of the ports section and with some .wad files and some MP3s, and now I have about 40 of doom mods on my pi. I separate MSX 1 and 2 roms. And finally, I created a section with help files, explaining my controller setups as well as some other things, which I display using the less command.

    sorry about my grammer, the text editor on these forums seems to eat my letters when I post from home.
    ^^ my other hobby



    I’m gonna try the same sort of thing with Commodore 128. The thing with that one looks like we may need shell scripts to launch most of those games, because I believe the majority of them are multi-disk (or at least double-sided).

    That will most likely need to wait until this weekend. I’m gonna want to figure out how to create the shell scripts automagically. lol Maybe via python script, which will be entirely new territory for me.
    ^^ my other hobby



    You do your magic ^^ All I can do is watch your progress ,,, too bad.



    I added the commands you need to do all of this from the command line, no viewing files from a PC needed. If you hit F4 to kill ES you can follow what I posted.
    ^^ my other hobby



    I just use a single entry in my c64 menu.
    I then launch a image of the megacart.

    It has 99.9% of anything you want to run on the vic from a joystick driven menu.
    And it works for either pal or ntsc emulation.

    The command to launch is.

    xvic -cartmega mega-cart.rom -mcnvramwriteback -mcnvramfile mega-cart.nv

    If you don’t have the nv file, I just created a blank file and let the emulator fill it in.




    First of all: The F-Keys are working in FileManager … I was using a new keyboard which I was not used to and I had to activate those to be usable! I edited all of my postings saying the FileManager was just a viewer … I’m sorry 🙁

    Now I could type away everything you suggested and it’s working! Yay! 🙂

    The only thing that I now have to do every time I want to actually play, is to configure the gamepad as the emulator is not using the ES settings … but this is way faster than my complicated way until I even got to that part!

    Thanks a lot for your help! And maybe this new section is in a new build of Retropie soon, too.



    First, I’m glad to hear you got past that issue!

    I think in the emulator menu there is an option to save the controller config. I haven’t actually tested if it’s working in 3.3, but I assume it is.

    for the issue you were having logging in as root, I just read in another thread that there may be an SSH_enable setting or something like that in config.txt. Maybe try enabling that then try connecting again with filezilla. For me it makes the whole process much smoother.
    ^^ my other hobby



    There is an option to save but it didn’t save my controller config last time I tried. Only the memoryexpension settings.

    I still have no full access to my Pi via network. In the sshd_config the Permit-thingy is enabled, also I set a password and in raspi-config the SSH is also enabled.

    I installed an SFTP plugin for Total Commander and tried to connect via “Secure FTP” but I get an error message that the login failed. The IP is correct. I have no idea where the problem is now.



    huh, ok. What controller are you using? I may be able to help with that as well, if you’ve got an xbox 360 controller. I’ve got a workaround via an alternate controller config that I made for retropie 2.6. I haven’t done much testing with it on 3.3 so far though.
    ^^ my other hobby



    For now I am using an SNES-Retro-Controller for USB.

    I updated my earlier posting as I still can’t root-connect to my Pi via my PC.

    Ok, scratch that .. I now tried pi / raspberry and it worked though I set a new password earlier, no idea why that is.



    When logged in via filezilla as the pi user, you’ll run into some issues editing files not owned by that user. It used to be that you only had to set a password for the root user to be able to login with it, but now there’s another setting that needs to be changed first.

    I had forgotten about this piece last time. From the wiki:

    before setting a root password, the following must be edited

    sudo nano /etc/ssh/sshd_config

    look for

    PermitRootLogin without-password

    change it to

    PermitRootLogin yes

    then ctrl+x to save, next set your root password & restart your Pi

    sudo passwd root

    sudo reboot
    ^^ my other hobby



    Had that in my last posting but edited it out again as I was able to connect via the default password.

    A mod linked the wiki entry you are quoting in my other thread and I did all that .. didn’t help, as the setting was already YES, when I checked, there was nothing to change in that file.

    Thanks for quoting, I appreciate your help.



    I’m working on breaking out C-128 tonight using the method I posted above. If anyone’s interested, here’s the emulators.cfg file that I’m playing with. I’m just toggling the various command line options for each image type. You have to play around with the emulator setting for each rom individually. There weren’t many games for the 128, so it’s not that big of a deal. There are some homebrews out there though.

    vice-x128-stndrd="/opt/retropie/emulators/vice/bin/x128 %ROM%"
    vice-x128-prgmode="/opt/retropie/emulators/vice/bin/x128 -autostartprgmode %ROM%"
    vice-x128-autoload="/opt/retropie/emulators/vice/bin/x128 -autoload %ROM%"
    vice-x128-cartcrt="/opt/retropie/emulators/vice/bin/x128 -cartcrt %ROM%"
    vice-x128-cartap="/opt/retropie/emulators/vice/bin/x128 -cartap %ROM%"
    vice-x128-auto="/opt/retropie/emulators/vice/bin/x128 -autostart %ROM%"

    Edit: The attached is messed up. Use the code above.
    ^^ my other hobby

Viewing 19 posts - 1 through 19 (of 19 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss