SSH not working

This topic contains 8 replies, has 4 voices, and was last updated by Profile photo of InsecureSpike InsecureSpike 1 year, 5 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #115243
    Profile photo of lilbud
    lilbud
    Participant

    I tried to login to the pi via WinSCP, No matter what user I try to use, nothing works, I went into /etc/ssh/sshd_config and changed permitrootlogin to yes, but that does not work either. Nor will user PI work

    #115252
    Profile photo of labelwhore
    labelwhore
    Participant

    once you change the permitrootlogin setting, you need to set a password for the root user. Try sudo passwd root

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #115277
    Profile photo of lilbud
    lilbud
    Participant

    I did that, and nothing will work. I even tried to change the password for user PI. Still nothing

    #115279
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    have you tried enabling ssh via the raspi-config?

    #115282
    Profile photo of labelwhore
    labelwhore
    Participant

    is that something new? I don’t remember having to do that.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #115285
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    no, its always been there, i just always enable it, when expanding the filesystem, setting the memory split & changing default password, not sure if it’s really needed to be done tho? but i do just incase

    #115312
    Profile photo of petrockblog
    petrockblog
    Keymaster

    ssh is enabled by default for the “pi” user on the retropie images. unless it’s been disabled should be no need to enable it

    #115314
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Make sure you are logging in with user “pi” lowercase. the password is also lowercase.

    #115315
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    ssh is enabled by default for the “pi” user on the retropie images. unless it’s been disabled should be no need to enable it

    thanks for clearing that up buzz

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar