Splash Screen not showing up

This topic contains 20 replies, has 4 voices, and was last updated by Profile photo of Dinofly Dinofly 1 year, 6 months ago.

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #111220
    Profile photo of rdhanded2
    rdhanded2
    Participant

    I have a newly imaged sd card with 3.2.1 installed. I had done nothing to it, but when I turned it on there was no splash screen. I expanded the files system and updated the image and still no splash. I went into splash screen configuration and made sure custom splash screen was enabled and still no splash. I chose default and nothing and I loaded a custom one and chose it and still nothing. Any ideas as how it could be tuned off outside the splash menu?

    #111504
    Profile photo of Dinofly
    Dinofly
    Participant

    I have the same issue… did you manage to find a solution ?
    My display is a 19″ LCD with 1280×1024 resolution, maybe it has something to do with that ? Do i have to choose a splashscreen image that has the exact same dimensions ?

    #111507
    Profile photo of petrockblog
    petrockblog
    Keymaster

    it was a bug that was fixed a few days ago. update retropie-setup script, and then go to splashscreens configuration, and update splashscreens

    #111509
    Profile photo of Dinofly
    Dinofly
    Participant

    Well i do that almost every day hoping that it would solve my issue but i’ll try that again tonight, thanks.

    #111574
    Profile photo of Dinofly
    Dinofly
    Participant

    It still doesn’t show the splashscreen after updating the setup script and the list of splashscreens… i don’t know what to do next :-/

    #111582
    Profile photo of petrockblog
    petrockblog
    Keymaster

    which splashscreen ? post the contents of /etc/splashscreen.list (can see it via option 6 of splashscreen configuration – manually edit splashscreen list)

    #111583
    Profile photo of petrockblog
    petrockblog
    Keymaster

    also from a terminal please post the output of

    
    md5sum /etc/init.d/asplashscreen
    
    #111584
    Profile photo of Dinofly
    Dinofly
    Participant
    pi@retropie ~ $ cat /etc/splashscreen.list
    /opt/retropie/supplementary/splashscreen/retropie2015-blue-4to3/splashscreen.png

    I checked that the file exists:

    pi@retropie ~ $ file /opt/retropie/supplementary/splashscreen/retropie2015-blue-4to3/splashscreen.png
    /opt/retropie/supplementary/splashscreen/retropie2015-blue-4to3/splashscreen.png: PNG image data, 1350 x 1080, 8-bit/color RGBA, non-interlaced
    pi@retropie ~ $ md5sum /etc/init.d/asplashscreen
    7f6e46c67a78c8ee260a51ada28e8e90  /etc/init.d/asplashscreen
    #111585
    Profile photo of petrockblog
    petrockblog
    Keymaster

    everything looks in order.

    from a terminal (directly on the rpi rather than via ssh) does the following work ?

    
    fbi -l /etc/splashscreen.list
    
    #111587
    Profile photo of Dinofly
    Dinofly
    Participant

    It shows the image properly, in fullscreen.

    #111589
    Profile photo of petrockblog
    petrockblog
    Keymaster

    do you get any errors logged at startup? have you adjusted any kernel or boot parameters ?

    You have raspi-config set to boot to terminal not into X?

    also try

    
    insserv -r asplashscreen
    insserv asplashscreen
    
    #111590
    Profile photo of Dinofly
    Dinofly
    Participant

    I don’t see any error at boot, but the text is really fast so maybe i’m missing something.
    Here is my full /boot/config.txt with not so much changes from the default: http://pastebin.com/6j0enptY
    The only line i edited myself is the avoid_safe_mode one, for the GPIO adapter.

    I tried typing the commands you gave me, it didn’t solve the issue :-/

    Thanks for helping me !

    #111592
    Profile photo of petrockblog
    petrockblog
    Keymaster

    avoid_safe_mode is not needed and is removed from current firmwares.

    you’ve not changed anything else ? no changes to /boot/cmdline.txt ? No other changes that could affect it ? can’t think why it isn’t working I’m afraid, you might need to try a fresh image and copy your configs over.

    #111593
    Profile photo of petrockblog
    petrockblog
    Keymaster

    and disabling overclock just to make sure it’s not causing fbi to crash when booting or something (if it’s not a stable overclock for example).

    #111594
    Profile photo of Dinofly
    Dinofly
    Participant

    I didn’t change anything to /boot/cmdline.txt.
    Removing the overclock doesn’t fix the issue either…

    OK i think i’ll reinstall everything, since i’m having issues with the GPIO Adapter / SNESDev too. I’ll start on a fresh Raspbian Jessie and use the setup script, instead of upgrading to Jessie after installing from the SD image.

    #111595
    Profile photo of herbfargus
    herbfargus
    Member

    Jessie is not fully supported so you will likely run into issues.

    #111596
    Profile photo of petrockblog
    petrockblog
    Keymaster

    You had upgraded to Jessie ? You should have mentioned that. Please don’t use Jessie just yet – especially if you will have any difficulties debugging issues.

    Splashscreen does work on Jessie, but boot settings in raspi-config need changing. Also if you upgrade to Jessie there are other things that could change that need sorting.

    #111597
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Just to re-iterate – when reporting problems please give all information. Especially if doing major changes like upgrading a distribution. I need this information to advise – if not it is a massive waste of my time 🙁

    #111602
    Profile photo of Dinofly
    Dinofly
    Participant

    Oh i didn’t realize that Jessie wasn’t officially supported, i’m sorry. I upgraded to get the Wii U Pro Controller support, as shown on the wiki. This page recommends upgrading to Jessie without putting any warning on the lack of support for this operation: https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-up-Wii-U-Pro-controller

    Even now that i know Jessie is not officially supported, i can’t find this information on the wiki. So i thought that everyone was using the latest Raspbian with the setup script, just like me.

    Sorry again for not mentioning this. I’ll reinstall the official image.

    #111611
    Profile photo of petrockblog
    petrockblog
    Keymaster

    The wiki is user editable, and the Wii U Pro page is a user contributed page – I guess Jessie is working ok for them currently. Jessie is mentioned in the main README.md https://github.com/RetroPie/RetroPie-Setup/blob/master/README.md

    #111613
    Profile photo of Dinofly
    Dinofly
    Participant

    I was so focused on the wiki that i missed the main README file, my bad 🙂

Viewing 21 posts - 1 through 21 (of 21 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar