Sound volume (especially in NES) fluctuates

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Sound volume (especially in NES) fluctuates

This topic contains 4 replies, has 4 voices, and was last updated by Profile photo of georgefeeney123 georgefeeney123 2 years, 5 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #82712
    Profile photo of RetroMarine
    RetroMarine
    Participant

    I haven’t been able to find a good solution for this yet, and most of the forum topics on sound issues seem to only deal with people who have no sound at all. The volume during almost all nes games will go from soft to loud and back again quite frequently. Anyone have a fix for this?

    #83174
    Profile photo of mooklepticon
    mooklepticon
    Participant

    I’m having the same problem. I have it in both nes and snes. Nes is way worse though. On original Super Mario Brothers, it goes up in volume if I get coins or I’m in a dungeon level. Snes, playing Link to the Past, and I don’t see a pattern, it just changes chaotically.

    #83179
    Profile photo of mooklepticon
    mooklepticon
    Participant

    To add, played The Legend of Zelda on NES this morning. There were 3 volume levels. 1) Overworld which was very quiet. 2) Dungeon, which was medium. 3) Game Over, which was piercingly loud.

    Also, the transitions between these are not instantaneous, but gradual. It’s easier to notice in NES Super Mario. Get one coin and the volume won’t change much. Get about 10 coins and it’ll go up a medium amount. Get 20 coins and the volume is very loud.

    Is there some sort of difference in how the sound is handled based on whether it’s a background music or a sound effect? I assume that those labels are mostly for us, not the machine. A sound is a sound to the speakers.

    #83412
    Profile photo of woodsy
    woodsy
    Participant

    I’ve come across this volume issue as well for NES and SNES.

    Problem was present for me with Raspian + binary script and Retropie V2.3 image. Also, changing some of the available audio configuration didn’t make any difference.

    Running Turbo overclock. Everything other than audio volume consistency is great.

    #85556
    Profile photo of georgefeeney123
    georgefeeney123
    Participant

    Just figured it out for myself. It actually didn’t have anything to do with my Pi settings. It was the settings on my TV. Some newer TV’s have a truAudio or something similar. Basically what it does is monitor the audio output and adjusts accordingly if it gets too loud. It’s used for regular television programming to deal with loud commercials and the such. I have a Vizio and just turned this setting off in the audio options. Now, I get perfect sound from both NES and SNES. Hope this helps.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar