Sound sync and quality issues in MAME, even on old games

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Sound sync and quality issues in MAME, even on old games

This topic contains 9 replies, has 5 voices, and was last updated by Profile photo of Floob Floob 2 years, 6 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #82495
    Profile photo of wayoutwest
    wayoutwest
    Participant

    Hey everyone!

    New here, but have been around emulation since the mid 90s, so I would like to think I am a bit ahead of the curve. Have spent the past 2-3 weeks getting my Pi set up, and have done one build of PiPlay, and 2 builds of RetroPie just trying to get my feet wet again with Linux and all that and it has been great. RetroPie also seems to be a bit further along and have a bigger support base. I have a B+ with copper heatsinks, 5A AC adapter, a WiFi dongle that works fine, and a WIRED XBOX controller for control. I am using HDMI for the audio out to my TV. I have everything up and running, but am having some trouble, specifically with sound. I’ll try to give as much detail as possible:

    1. Sound on the NES and SNES emulators seems to work fine, and is in sync with no skips. I am having controller issues on the SNES, but i just need to keep figuring out how RETROARCH.CFG works, and I’ll get around to that. NES controls work perfect for some reason. I am just using the DEFAULT emulators right now. FBA also seems to work fine – i just tested it with the D&D game – tower of doom i think.

    2. Sound on MAME seems to be the biggest issue so far that I can recognize, though I can’t say that I have tried all of the emulators. For example, if I play Galaga or 1942 (both of which are obviously old games that should require little horsepower), when i press the fire button, there is probably a half second lag until the sound is played, and it is a little choppy as well. I am using the ROMS from the .37b5 set as recommended. I have read all of the blog posts, set changed the rate from 48000 to 44100 and even 22050, tried ALSA and SDL for sound (all of this in the RETROARCH.CFG under the /all folder). I have also tried overclocking all the way to turbo, and it didn’t make a difference.

    Any clues what I am missing? Thanks in advance for the help! Also, any general tips/tricks that haven’t been extensively covered by existing posts (i’ve read them all) would be appreciated.

    cheers!
    dave

    #82507
    Profile photo of bugman2112
    bugman2112
    Participant

    Today I posted a similar “sound lag” issue when using mame4all-pi. The speed of my older games are all 100%, so I am not sure if i have the same issue as you do. But the sound slowly de-syncs over time to be very noticeable after a couple minutes of play. I fixed my issue by setting the sample rate in the mame.cfg file to 40000. No idea exactly why this worked, but it did. No more noticeable sound lag.

    EDIT: I just noticed you make reference to RETROARCH.cfg. So you must be using imame4all, not mame4all-pi. My issue was with mame4all-pi just to clarify

    #82513
    Profile photo of wayoutwest
    wayoutwest
    Participant

    What is the path of the MAME.CFG file that you edited? I will try that. I have only edited the RETROARCH.CFG, so maybe i am editing the wrong one. I don’t think it is related to overclocking, and the NES/SNES emulators work fine, so I don’t think it is an issue with the processing power of the Pi itself. I will dig around a bit and report back if i have anything useful to add. Thanks for your reply!

    dave

    #82516
    Profile photo of bugman2112
    bugman2112
    Participant

    The location of the MAME.CFG which relates to mame4all-pi is in
    /opt/retropie/emulators/mame4all-pi
    I am using version 2.3 of the retropie SD image

    #82518
    Profile photo of wayoutwest
    wayoutwest
    Participant

    I am using 2.3 as well. I will try to edit that file tomorrow and let you know if i have any success!

    #82537
    Profile photo of thex
    thex
    Participant

    I had this same issue.
    I “installed” mame4all.
    I worked with a friend of mine who helped in creating a script to install mame4all.

    once installed (new directory) I changed emulationstation to the new install. Sound works perfect!

    I attached the script we used to install the necessary libraries (just in case) and mame4all.

    #82538
    Profile photo of thex
    thex
    Participant

    zipped file.

    Attachments:
    1. installm4all.zip
    #82541
    Profile photo of wayoutwest
    wayoutwest
    Participant

    Thanks – i will give that install script a shot. I did some poking around and I am indeed using whatever MAME build is controlled by the mame.cfg file that bugman referenced. (i.e. I changed anti-aliasing, scanlines, etc.. and verified that the changes took effect. I also changed the audio output to 22050 and 44100, and it MIGHT have made it better? I’m not sure. I need to try the same game on my laptop which is obviously much more powerful and see if it is any better the the responsiveness of the controller and audio. I’ll report back when i get time to work on it.

    dave

    #83868
    Profile photo of allroy1975
    allroy1975
    Participant

    why are you installing an http server and ftp server in your script?

    #83877
    Profile photo of Floob
    Floob
    Member

    For what its worth there are a couple of sound related comments here for MAME
    https://code.google.com/p/mame4all-pi/

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 10 posts - 1 through 10 (of 10 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar