Sound issues within RetroPie

Tagged: , ,

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of asiainorama asiainorama 3 years, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1728
    Profile photo of Jonathan Lundström
    Jonathan Lundström
    Participant

    Hello!

    I’ve had some issues with the sound in games and recently did some changes such as overclocking (Medium: 900Mhz), changing audio resampling rate and switching from ALSA to SDL. Now all the sounds and music work perfectly fine inside games, excerpt for static noises. When I run my Raspberry Pi in the terminal without RetroPie the speakers are completely silent.

    Although, the second I turn on emulationstation and/or a game the static noises begin. Do you have any idea what this could be? I’m using the 3.5mm audio jack. My system is completely updated and I’m running the latest rpi-update with the latest kernel.

    Thanks in advance,
    Jonathan

    #1731
    Profile photo of karloss
    karloss
    Participant

    Hi Jonathan,

    Can you please point me in the places and things that you did to improve the sound on your pie? ie changing the resampling rate and switching to SDL?

    Thanks

    Karl

    #1737
    Profile photo of Jonathan Lundström
    Jonathan Lundström
    Participant

    Hello!

    It seems the static sounds are caused by incorrect grounding. My speakers and Raspberry Pi runs of the same power adapter and whenever I change that so that they run of two separate adapters everything works good.

    The settings I made to /home/pi/RetroPie/configs/all/retroarch.cfg are the following:
    audio_enable = true
    audio_out_rate = 44100
    audio_driver = sdl
    audio_sync = true

    After these changes were made and after a reboot everything worked good. Now I get perfect and clear sound/music in all my games.

    Also make sure to overclock your Raspberry Pi. I’m running mine on 900Mhz (Medium) and everything works great. You can try without, but people recommend overclocking on order for the audio to work good.

    I also followed this guide (http://raspberrypi.stackexchange.com/a/5611) in order to update the kernel to the latest version with updated audio drivers.

    Let me know if my suggestions worked!

    Best regards,
    Jonathan

    #4412
    Profile photo of asiainorama
    asiainorama
    Participant

    Hello!

    It seems the static sounds are caused by incorrect grounding. My speakers and Raspberry Pi runs of the same power adapter and whenever I change that so that they run of two separate adapters everything works good.

    The settings I made to /home/pi/RetroPie/configs/all/retroarch.cfg are the following:<br>
    audio_enable = true<br>
    audio_out_rate = 44100<br>
    audio_driver = sdl<br>
    audio_sync = true

    After these changes were made and after a reboot everything worked good. Now I get perfect and clear sound/music in all my games.

    Also make sure to overclock your Raspberry Pi. I’m running mine on 900Mhz (Medium) and everything works great. You can try without, but people recommend overclocking on order for the audio to work good.

    I also followed this guide (http://raspberrypi.stackexchange.com/a/5611) in order to update the kernel to the latest version with updated audio drivers.

    Let me know if my suggestions worked!

    Best regards,<br>
    Jonathan

    Hi Jonathan,
    I’ve a question.
    In my RetroPie SD (last 1.9.1), the sounds and music work fine on emulationstaion and NES games, but don’t work on Amiga Games and GameGear games.
    Do you know how to solve it? My games without sound are not the same.
    Thanks.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar