Sound delay with Mupen64Plus-Testing

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Sound delay with Mupen64Plus-Testing

This topic contains 2 replies, has 1 voice, and was last updated by Profile photo of dankcushions dankcushions 2 years ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #99298
    Profile photo of dankcushions
    dankcushions
    Participant

    Pi Model: pi 2
    RetroPie Version Used: 3.0.0 (not actually sure which beta – anyway to check?)
    Built From: sd image
    USB Devices connected: 2 controllers, 1 usb stick (game running from sd card though), 1 keboard
    Controller used: buffalo usb snes clone
    How to replicate the problem:

    hi all! after getting mixed results with the default lr-mupen64plus n64 emulator, i installed the mupen64plus-testing one via the setup-script. i also updated everything from the binaries.

    it seems that with any of the mupen64plus emulaters (testing OR the regular, and either glesrice or n64 plug), and any rom (eg mario 64) i’m getting a small delay between the actions on screen and the sound. performance otherwise seems good, but it’s really annoying and makes most games unplayable, in a way.

    it’s not my TV as all other emulators work fine – in fact the default lr-mupen64plus doesn’t do anything like this, nor do the other types of emulator.

    my pi 2 has a small overclock, and i changed the vram split to ~384MB (i think that’s right?). it seems all n64 games are running at my HDTV’s resolution of 1080p when using mupen64plus, which i wasn’t expecting, but the performance is good so i’m happy leaving it at that if it’s normal? lr-mupenplus seems to run at a lower resolution by default, and doesn’t have these sound glitches.

    #99302
    Profile photo of dankcushions
    dankcushions
    Participant

    interestingly, in the config files, the mupen64plus.cfg file has a ‘latency’ setting in the audio section at the top. this is set to 300(ms), which seemed like it might explain it. i had a look in the retroarch.cfg file in the same directory (assume this is for lr-mupen64plus, which has no audio latency issue for me) has an ‘audio_latency’ setting that was at 64

    i tried setting mupen64plus.cfg to 64 also and no changes, which is a bit baffling! i’ve set it back to 300.

    #99303
    Profile photo of dankcushions
    dankcushions
    Participant

    i also noticed that in the video-general section of mupen64plus.cfg, the ScreenWidth was set to 640, and ScreenHeight to 480, whereas my games are definitely full hd, so i’m a bit lost. does rebuilding the emulators cause them to look somewhere else for the cfg files?

    EDIT: i’ve just setup my quit emulator button with mupen in that same .cfg and it worked, so scrub that last idea!

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar