Some Roms and Emulators wont load up?! Noob need help!

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Some Roms and Emulators wont load up?! Noob need help!

This topic contains 5 replies, has 3 voices, and was last updated by Profile photo of mklax26 mklax26 2 years, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #90072
    Profile photo of mklax26
    mklax26
    Participant

    I am very new to working with raspberry pi and retropie. I recently downloaded the retropi image onto my 16gb sd card. Loaded it up onto my raspberry and things started up fine. I then did some research about expanding the drive before adding in my roms. So I configured that and rebooted. Then I plugged in the thumb drive I wanted to use for holding my roms. retropie, like it should, created all the necessary folders within the thumb drive for my roms to be placed in. I shut down the pi, removed the drive added the roms to the corresponding folders.

    Then I placed the drive back in the pi and booted it up. Emulation Station showed most, but not all of my emulators and roms. I have tried this a few times by reformatting the SD card back to the original image and restarting the process over again. Each time it seems to not show a different set of emulators and roms.

    Is this because my SD card does not have enough room? I expanded its capacity and I do not have that many roms that should fill the drive. Could there be another factor affecting this? I find it strange that one time my NES roms work and not the Sega roms and then next time all my sega roms are detected but NES is non existent. Any insight would be helpful. Thank you.

    #90076
    Profile photo of labelwhore
    labelwhore
    Participant

    Firstly, you need to make sure your es_systems.cfg file has the correct file extensions for each emulator, and points to the correct path for your roms.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #90078
    Profile photo of herbfargus
    herbfargus
    Member

    This video shows you how to view your es_systems.cfg file. It may help.

    #90143
    Profile photo of mklax26
    mklax26
    Participant

    Thank you for the help! I will try this out tonight and let you know how I goes.

    #90837
    Profile photo of mklax26
    mklax26
    Participant

    Hi guys,

    Ok so I got everything up and running but I am still having problems with these roms. To me this makes no sense at all. I have the correct file types in the right rom folders. I have had certain roms able to be read one time and then if I make any changes even if it is to a different rom folder it seems to just not work at all. For example. I had a few NES roms working right off the bat. Then I get a few Sega roms working. Then I try to add some SNES roms and now NES and Sega are no longer coming up when I plug in the usb with everything on. Am I going about this wrong? Is the USB upload just a one time thing or can I constantly add to roms within a USB and they should just update into the system once its rebooted?

    Thank you in advance for any assistance!

    #90849
    Profile photo of mklax26
    mklax26
    Participant

    I believe I figured it all out! For some reason after fixing my SD to fit the proper amount it still would not fit games properly. So i went in and made separate folders on the USB drive for each Emulator and put the Roms in there and designated the retropie to grab them from those USB specific folders instead of the ones it created. Not sure why this made the difference because I had over 5gbs of space available on the SD card and the USB i have is only a 4gb but it worked!

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar