[Solved] SNESDev issues with reset/shutdown button in Retropie 2.6

Welcome Page Forums RetroPie Project GPIO Adapter, ControlBlock etc. [Solved] SNESDev issues with reset/shutdown button in Retropie 2.6

This topic contains 6 replies, has 4 voices, and was last updated by Profile photo of matthewjosephcordova matthewjosephcordova 2 years ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #89746
    Profile photo of Jara
    Jara
    Participant

    Hi
    First I want to thank everyone who posts here. I’ve been reading this forum for a few weeks now and finding solutions to most of my problems with RetroPie and the RPi.

    The issue I’m having is with SNESDev (apparently) in which I set up a reset/shutdown button. Pressing it 5 times shuts down the Pi, but nothing happens when I press it 3 times. Followed this setup since I’m not using a GPIO adapter http://blog.petrockblock.com/forums/topic/snes-console-using-raspberry-pi/

    I first used the RetroPie v2.3 image file and that button worked perfectly. 3 times to go back to ES and 5 to shutdown. The problem was when I installed Retropie v2.6 (on another SD card) and not doing anything different in terms of configuration compared to the previous install (2.3) I can’t get the button to send me back to ES. It quits with 5 presses, but nothing happens with 3.

    I have SNESDev configured with button polling only and adapter v1 (tried v2 just in case and issue persists).

    As I’m writing this I wonder if the new version of SNESDev changed the pin used for this (pin 11/GPIO17).
    Edit: I checked the code (link)and confirmed pin 11 is still the correct one.

    I have a RPi model B.
    Connection goes like this (taken from link above) http://blog.petrockblock.com/wp-content/uploads/2013/08/diagram-button.png

    Thanks in advance for any help/advice/suggestion.

    #90795
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Hi Jara,

    did you make any progress on this? There has been an update to the newest version of the BCM2835 library to support the Raspberry Pi 2 …

    #90798
    Profile photo of Jara
    Jara
    Participant

    Hi

    Thanks for your reply.
    Haven’t had time to go back to the problem in the past week.
    I’m not using a Pi2, so I don’t know if the update you mention should make any difference (on my Pi B).

    I’ll try a fresh “installation” of the retropie image and only configure snesdev to see if it works fine. If it does, I’ll start configuring things one by one and checking if the button works each time. This in case somehow something I configured is what caused the issues with snesdev (seems unlikely, but I’ll try anyways).

    I’ll keep you guys posted.

    Edit:
    Ok. With a clean image installation it works fine.
    I’ll still check if it keeps working after every different configuration I do in case the issue arises again.

    #90829
    Profile photo of Jara
    Jara
    Participant

    I was too lazy to do it before, but solved the problem rather quickly.

    The issue presents itself when adding these two lines to retroarch.cfg (/opt/retropie/configs/all/)

    input_enable_hotkey_btn = "X"
    input_exit_emulator_btn = "Y"

    With X and Y buttons on the controller. It’s a button combination to exit the emulator. Taken from this guide https://supernintendopi.wordpress.com/

    I guess that adding that option to exit emulators with a controller button combination somehow prevents SNESDev from using it’s button (in pin 11) to do the same thing.

    But like I said before, in RetroPie 2.3 that problem doesn’t happen. I can exit with both the controller button combination and the SNESDev button in Pin 11 (with the same configuration).

    It would be good to know if someone who is using the GPIO adapter has this same problem when adding those lines to retroarch.cfg.

    I’ll contact the person that wrote that guide in case he wants to add a warning about this issue.

    #90970
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Glad you figured it out and thanks for sharing it here!

    SNESDev simulates the press of the ESC key when pressing the button three times in a row. The hotkey behavior of RetroArch must have changed between RetroPie 2.3 and 2.6.

    #96456
    Profile photo of sarsons
    sarsons
    Participant

    I managed to work around this issue by writing a python script to send a sigterm to retroarch or mame on the button press. Retroarch exits cleanly and emulationstation restarts as if pressing esc, works fine and I can still use the hotkeys on the controller to do the same thing.

    #100699

    Are you sure it’s a clean and exit? Are you issuing a sigterm to the mame4all process? I’m using a ‘kill -TERM’ and it’s not working.

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar