SNES srm (save files) not writing on crash

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! SNES srm (save files) not writing on crash

This topic contains 0 replies, has 1 voice, and was last updated by Profile photo of fr8o fr8o 2 years, 1 month ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #97492
    Profile photo of fr8o
    fr8o
    Participant

    I will start by saying all settings are out of box for the SD-card image.
    I had my Pi2 lock up when I tried to exit my game and as such it did not write the cached save info lost 5 hours 🙁 So I did some research and found mentions of an autosave_interval function, but after enabling it opt/retropie/emulators/RetroArch/configs/retroarch.cfg it did not seem to have any effect on the game. After saving, waiting for the stipulated interval, and unplugging the Pi to simulate a crash the saved games had reverted. Then I tried in /opt/retropie/configs/all/retroarch.cfg this time the safe file actually ended up corrupt O_o so I had to start over 🙁 Any suggestions on how to get this to work correctly? Mind you my knowledge is just enough to hurt myself I had to work hard to remember how chmod and vi worked to edit those cfg files.

    Happened again today when I exited the SNES emulator it crashed
    Terminate called after throwing an instance of ‘std::out_of_range’
    what(): map::at
    /usr/bin/emulationstation: line 20: 2239 aborted

Viewing 1 post (of 1 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar