SNES GPIO adapter not working.

This topic contains 2 replies, has 2 voices, and was last updated by  petrockblog 3 years, 10 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #5480


    Using the exact schematic on the site where it is explained how to set the thing up, I built my own (mostly for practice but also because i had the parts laying around).

    However, the schematic isn’t that easy to understand. I was hoping that someone could help me, I made everything in accordance with what I could understand form the thing, but the JP1 and the button block didn’t make much sense as to why they were there at all.

    Attached is the schematic and also a picture of my circuit.
    I plugged it in and tried to test it out after making sure I had made the advocated changes in the config files. But no response from the pi.

    I refereanced VCC on the GPIO ports as the pin by the P1 indicator (the one with square solder on the back, with the SD card facing me while i hold it upright, the bottom right pin)

    I made sure that the controller worked with a SNES and games, whenever I try to run jstest on the controller, it isn’t even detected.



    The pin numbering of the 2×13 header is not correct in the schematics. It has to be changed to the opposite direction.



    The button is used by SNESDev to simulate virtual key presses, e.g., ESC, r(ewind), or even the shutdown command.

    The JP1 header on the adapter PCB is “only” a break out of GND, 3.3V, 5V, and some GPIO pins for arbitrary use.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss