SNES games not loading

This topic contains 13 replies, has 4 voices, and was last updated by Profile photo of linkz linkz 1 year, 7 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #110130
    Profile photo of linkz
    linkz
    Participant

    Hi all first let me fill this out:

    Pi Model: B I think, I have the first one made
    RetroPie Version Used: 3.0.0, just downloaded yesterday
    Built From: SD Image
    USB Devices connected: Keyboard or USB SNES Controller
    Controller used: 2 USB SNES Controller
    Error messages received: None
    Guide used: A basic setup guide
    File:
    Attachment of config files:
    How to replicate the problem:

    Basically I have all my NES roms working which is awesome! But all of my SNES roms don’t, I start the rom, I see the “press any key to load options” then the screen fades black and I’m back at my select a SNES rom screen. No errors or anything and I don’t see anything in that .log file. Ideas?

    #110132
    Profile photo of herbfargus
    herbfargus
    Member

    what format are you roms in? have you unzipped them? also which emulator are you using? have you tried other emulators from the runcommand menu?

    https://github.com/RetroPie/RetroPie-Setup/wiki/runcommand

    #110139
    Profile photo of linkz
    linkz
    Participant

    I’ve tryied all the emulators. Pocksnes, snes9x and all the others in the list. I did upzip them. They are .sfc files.

    #110140
    Profile photo of linkz
    linkz
    Participant

    Just for testing I redownloaded all my roms in .smc and tried in all emulators. Same thing. NES games work just fine.

    #110143
    Profile photo of herbfargus
    herbfargus
    Member

    The only two things I could think of are to check permissions on your roms or reinstall the emulators from binary

    #110182
    Profile photo of Floob
    Floob
    Member

    Yes, if it really is version 3 you are using, it had an issue with the default snes emulator.
    I’d try 3.2.1 which shouldnt have that issue, or update the binary as herbfargus says.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #110197
    Profile photo of linkz
    linkz
    Participant

    I apologize, I do have the latest 3.2.1 and I’m getting this issue.

    #110201
    Profile photo of petrockblog
    petrockblog
    Keymaster

    there should be at least something in /tmp/runcommand.log after failing to launch – you sure you checked the correct file ? Switch to pocketsnes and then check the log.

    you can also drop to a terminal and try

    
    /opt/retropie/emulators/retroarch/bin/retroarch --verbose -L /opt/retropie/libretrocores/lr-pocketsnes/libretro.so --config /opt/retropie/configs/snes/retroarch.cfg ~/RetroPie/roms/snes/SNESROMFILE
    
    #110203
    Profile photo of linkz
    linkz
    Participant

    After chmod 777 on all snes roms, I switched to pocketnes and I get same as beofre in the log.

    [libretro]: Rom loading failed…

    #110206
    Profile photo of linkz
    linkz
    Participant

    #110214
    Profile photo of petrockblog
    petrockblog
    Keymaster

    please can you paste me the output of ls -la ~/RetroPie/roms/snes

    also have you tried some alternative roms ?

    Please run it via ssh, and so you can c&p the output rather then taking a photo 🙂

    the CRC32 would suggest the files are empty, or they were unable to be read or something.

    #110251
    Profile photo of linkz
    linkz
    Participant

    Final update solved! I only tried the chmod 777 on the roms that were .smc For kicks I put the .sfc roms back on, deleted the .smc roms and gave the .sfc roms chmod 777. Changed the emu back to pocketnes and perfect!

    So at least for me the forumla is
    1. pocketsnes
    2. .sfc roms
    3. make sure all roms have chmod 777

    #110255
    Profile photo of petrockblog
    petrockblog
    Keymaster

    you shouldn’t need to chmod them at all if you copied them over with the pi user. 777 is actually wrong for these files, since they are not executables. better would be “644” for user rw, and r for group / all

    That’s why I asked for the output of ls -la so I can check the files/permissions as maybe they are owned by root or something.

    #110256
    Profile photo of linkz
    linkz
    Participant

    Yeah the 777 was lazyness. Normally I would freak if people just gave full access to files on my linux server at work, but since this is a private “machine” I wasn’t worried about it. I don’t think they were owned by root since root password is disabled since 3.0. I got the roms onto the pi via usb but for some reason they wouldn’t auto sync so I just
    cp /media/usb/retropie/roms/snes/* ~/RetroPie/roms/snes

Viewing 14 posts - 1 through 14 (of 14 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar