SNES controllers input lag

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of kaiju kaiju 2 years, 8 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #81559
    Profile photo of kaiju
    kaiju
    Participant

    Just installed retropie and am really enjoying in thus far. Truly appreciate all the work put into it.

    I’ve come here in hopes of answer. As the title states I have input lag from the controller. I haven’t been able to find much on the subject other than it’s the TV causing the issue.

    http://emulation-general.wikia.com/wiki/Input_lag

    I am playing this through a newer 60in TV. I don’t know the complete settings of the television as it’s a work TV.

    These are the controllers I have.

    http://www.amazon.com/gp/product/B0034ZOAO0/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1

    Basically I guess I am asking if anyone else has the same experience and if so is there a fix or is it truly the tv.

    #81562
    Profile photo of Jason Whiteman
    Jason Whiteman
    Participant

    Not sure what you are experiencing – CPU sluggishness, video-stage “lag”, controller lag – or exactly what part of the experience time-chain is/are giving you the problem(s).

    Regarding KMS/DRM – as far as I can tell, there is an emerging driver is in development by Broadcom to enhance the performance as they, Broadcom, have a new asset in the form of an Intel former employee Eric Anholt. ETA for the driver is first half of 2015 as of today (source: article). Eric may quote something different.

    His blog is here:

    http://anholt.livejournal.com/

    And I originally found out about his contribution potential by reading this article:

    http://www.phoronix.com/scan.php?page=news_item&px=MTc0Nzc

    Using a CRT is something that you can try using the composite out instead of HDMI while not at work. Although I have my doubts any differences will be seen.

    … not to say there isn’t existing KMS work. I would suggest you focus on Raspberry Pi sources as the link you provided focuses on Windows primarily. Presumably why you asked here – but there are existing Raspberry Pi discussions on the topic (insert search engine address here).

    Regards,
    Jason

    #81565
    Profile photo of spot
    spot
    Participant

    I would open your settings on the TV itself and look for a setting named “Game Mode” I have to turn this on both of my LED HD TV’s in order to get rid of my input lag. I use this setting on all consoles hooked up to my TV, not just the Pi.

    Here is an article that explains what the setting does:

    http://www.cnet.com/news/what-is-game-mode/

    Most TV’s built within the past five years have a game mode setting.

    Good Luck!

    #81566
    Profile photo of kaiju
    kaiju
    Participant

    Appreciate both responses. I will try the game mode first as it’s pretty darn easy to push a button. 🙂

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar