SNES controller via USB hub not recognized by RetroArch

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project SNES controller via USB hub not recognized by RetroArch

This topic contains 3 replies, has 2 voices, and was last updated by  jjmiller1980 3 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #82989

    jjmiller1980
    Participant

    Hi all, forgive me if this is a basic question, but I’m brand new to this. I just set up my Raspberry Pi using the RetroPie image. I got everything set up, got some ROMs copied over, and everything was working. I set it up initially using an iBuffalo branded USB SNES controller. I set up Emulation Station and RetroArch using this and it worked no problem. I had already ordered an adapter to be able to use my actual SNES controllers with the Raspberry Pi (this is the one I have).

    When I plug that in and boot up my pi, Emulation Station recognizes that controller. However, when I exit Emulation Station and go into the RetroPie setup and try to configure the RetroArch, it does not. I go through all the prompts, and no matter what I press it doesn’t do anything except eventually time out.

    It does “see” my controller. On the top during the registration it says

    Found joypad driver: udev
    Using joypad: HuiJia USB GamePad (this is the same name that Emulation Station came up with also, so I know it recognizes it)

    Any idea what’s going on? I’m new to Linux and Raspberry Pi, so perhaps there’s an easy fix that I’m just not aware of.

    #83010

    jjmiller1980
    Participant

    As more information, I did some looking and found JSTEST. I installed and ran it, and it also does not recognize any of the button presses for the SNES controller using an adapter.

    I’m not sure where to go from here.

    #83011

    trimmtrabb
    Participant

    With the pad plugged in what does the command ls /dev/input show?

    If you have found the solution to your problem please mark the topic as resolved.

    #83019

    jjmiller1980
    Participant

    OK, I figured this out. Shockingly, it was user error. When I did another ls /dev/input, I noticed that it shows js1 as well as js0. I just automatically did js0 before, because that’s what the USB SNES controller was. Turns out, on my adapter, the port on the right is player 1, or js0. I set it up that way and it works now.

    Sorry about that. Learning.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss