SNES and IPAC

This topic contains 5 replies, has 3 voices, and was last updated by Profile photo of carlux3 carlux3 1 year, 11 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #102571
    Profile photo of carlux3
    carlux3
    Participant

    Hello,

    I have a Rpi 2 running with retropie, I configured an IPAC which is now working quite well but when I launch an SNES game, I have a Button (the 3 or 6 I think) which activate a kind of “turbo” in the game. I think I have the same issue with the megadrive emulator.

    Any idea of what it could be, and how I can change that ?

    #102574
    Profile photo of retrovortex
    retrovortex
    Participant

    It sounds like you have a button set up on your IPAC which triggers some sort of emulator function.

    My suggestion would be to look in the controller configurations of the RetroArch.cfg file, (located in /opt/retropie/configs/all/ if you are using the latest RetroPie image) and to see what is already mapped to your keyboard (make sure to check any hotkeys too since they may be mapped to the keyboard). It helps a ton to initially setup your 1p keys with emulation station (remembering to hold a button to skip through stuff you can’t map), then go back and edit this config file specifically with your keyboard configuration. Saves a ton of headache. (esepcecially when most emulators run via RetroArch)

    Don’t forget, you can also reprogram your IPAC using the Windows software. (A good thing to do since the default setting misses out a ton of shift keys you could set to random keys. You could map stuff like R2 and L2 and analogue sticks via button press combos)

    Here is what I set my main IPAC keys to:

    P1:
    Up: UP ARROW
    DOWN: DOWN ARROW
    LEFT: LEFT ARROW
    RIGHT: RIGHT ARROW
    1:a
    2:s
    3:d
    4:z
    5:x
    6:c
    7:5
    8:6
    1p Start: 1

    P2:
    Up: I
    Down: K
    Left: J
    Right: L
    1: t
    2: y
    3: u
    4: f
    5: g
    6: h
    7: 5
    8: 6
    2p start:2

    Also if you are using pisnes or pifba, you will need to find a patched binary (I made a thread yesterday about it that might help), since the emulators have P2 keyboard controls disabled by default.

    I always use Street Fighter 2 to test my key setups since it uses all 6 main buttons. (Snes, MAME, and FBA versions I’d recommend)

    #102597
    Profile photo of petrockblog
    petrockblog
    Keymaster

    if you get the latest retropie rc1 – it should set up the hotkeys for controllers that output keypresses in the same way as gamepads meaning the “select” button is needed to activate a hotkey. This way hotkeys are not triggered by accident because of mapping overlaps.

    #102856
    Profile photo of carlux3
    carlux3
    Participant

    Hello !

    It seems the default buttons of the IPAC countains some active buttons of the retropie configuration …
    I mean that “space” and “K” are used to put a kind of TURBO or a STOP during the games in SNES, NES and at least MEGADRIVE.
    So I reconfigure those buttons on the IPAC in R and T and reconfigure retroarch.cfg, and now it seems it works !
    Last point on the SNES games at like to switch the buttons 3 and 6 (but only for SNES) do you know how can I do that ?

    Thank you !

    #103294
    Profile photo of carlux3
    carlux3
    Participant

    Hello !

    I did reconfigure the IPAC and I switched the space by R and the K buy T… I updated the retroarch.cfg, it works for the the SNES emulators, but now for Mame and Neogeo these two buttons don’t work anymore… :'(

    #103318
    Profile photo of carlux3
    carlux3
    Participant

    Hello !

    It sounds like you have a button set up on your IPAC which triggers some sort of emulator function.

    My suggestion would be to look in the controller configurations of the RetroArch.cfg file, (located in /opt/retropie/configs/all/ if you are using the latest RetroPie image) and to see what is already mapped to your keyboard (make sure to check any hotkeys too since they may be mapped to the keyboard). It helps a ton to initially setup your 1p keys with emulation station (remembering to hold a button to skip through stuff you can’t map), then go back and edit this config file specifically with your keyboard configuration. Saves a ton of headache. (esepcecially when most emulators run via RetroArch)

    Don’t forget, you can also reprogram your IPAC using the Windows software. (A good thing to do since the default setting misses out a ton of shift keys you could set to random keys. You could map stuff like R2 and L2 and analogue sticks via button press combos)

    Here is what I set my main IPAC keys to:

    P1:
    Up: UP ARROW
    DOWN: DOWN ARROW
    LEFT: LEFT ARROW
    RIGHT: RIGHT ARROW
    1:a
    2:s
    3:d
    4:z
    5:x
    6:c
    7:5
    8:6
    1p Start: 1

    P2:
    Up: I
    Down: K
    Left: J
    Right: L
    1: t
    2: y
    3: u
    4: f
    5: g
    6: h
    7: 5
    8: 6
    2p start:2

    Also if you are using pisnes or pifba, you will need to find a patched binary (I made a thread yesterday about it that might help), since the emulators have P2 keyboard controls disabled by default.

    I always use Street Fighter 2 to test my key setups since it uses all 6 main buttons. (Snes, MAME, and FBA versions I’d recommend)

    Can you share your retroarch.cfg please ?

    After reconfiguring the IPAC and the retroarch.cfg… the buttons don’t work…

    If I put again “space” and “k” on the IPAC and on retroarch.cfg. it works again on MAME FBA, but not anymore on SNES… :'(

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar