Slowdown every 5 seconds when playing ROMs

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! Slowdown every 5 seconds when playing ROMs

Tagged: , ,

This topic contains 10 replies, has 6 voices, and was last updated by Profile photo of petrockblog petrockblog 1 year, 8 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #107149
    Profile photo of wateron
    wateron
    Participant

    Pi Model: Pi B+
    RetroPie Version Used: 3.0 beta 4
    Built From: (SD Image, Binary, Source)
    USB Devices connected: WiFi Adapter, SNES Controller, Keyboard
    Controller used: SNES USB Controller from China. (Also installed drivers for xbox 360 controller at one point)
    Error messages received: None
    Guide used: Lifehacker article
    How to replicate the problem: play any SNES game

    Hi everyone, I have been trying to get my RetroPie working right, but running into a problem:

    The problem is every SNES rom I play has a small “hitch” or skip happen every 5 seconds where everything slows down (including music) for maybe 1/4 of a second. It happens in every SNES game I try (I don’t have any other roms at the moment). It happens at steady intervals and never ever stops or changes, it seems to be exactly every 5 seconds–I sat and timed the intervals. For example even when I paused the game and was doing nothing the hitching continued on its steady interval.

    Any help? If more info is needed to troubleshoot I will provide it. Thanks!

    edit: Okay, I tested NES and Genesis games and the same slowdown happens in all games there too.

    #107156
    Profile photo of lilbud
    lilbud
    Participant

    Overclock the pi

    #107157
    Profile photo of wateron
    wateron
    Participant

    Thanks for the reply lilbud. I will try that next chance I get. However, I did already try setting it to “modest” overclocking setting and that made no difference compared to “normal” setting.

    I will try the max setting a little later today, although I’m a little doubtful it will help since the problem is happening even in basic NES games and the hitching interval is so steady at 5 seconds no matter what.

    #107160
    Profile photo of dankcushions
    dankcushions
    Participant

    a couple of settings that might help –

    go into opt/retropie/configs/snes/retroarch.cfg and make sure
    rewind_enable = false
    video_threaded = true

    #107164
    Profile photo of auswear
    auswear
    Participant

    a couple of settings that might help –

    go into opt/retropie/configs/snes/retroarch.cfg and make sure
    rewind_enable = false
    video_threaded = true

    Thanks for this – What do these settings actually do?

    #107166
    Profile photo of wateron
    wateron
    Participant

    auswear thanks for the reply, though that did not help (those were already my settings)

    However, for the overclocking that lilbud recommended does seem to have done it. I tested modest then medium and it didn’t help, but then went to Turbo and the problem disappeared! So thanks, its nice to have that fixed.

    I am curious if this is normal for raspberry pi b+ to have to overclock to turbo to play these emulators without hitching? And also how safe is it to always leave it overclocked to turbo all the time?

    #107185
    Profile photo of petrockblog
    petrockblog
    Keymaster

    A medium overclock should be enough – How are you powering the pi ?

    #107195
    Profile photo of wateron
    wateron
    Participant

    It is powered from a wall outlet microusb adapter, which is rated as 5volt / 2000mA

    At medium overclock setting I still saw the hitching in nes, mega drive, and snes emulators (those were all the ones I tested)

    #107203
    Profile photo of petrockblog
    petrockblog
    Keymaster

    It’s worth trying another PSU or switch to a thicker cable if possible – just to rule it out. I have heard of performance problems due to lack of power.

    please post a copy of your configs/all/retroarch.cfg and retroarch.cfg for the systems you are testing – and let me know which emulators you are using (And give me an example game name to test here).

    #108006
    Profile photo of oscar-caballero
    oscar-caballero
    Participant

    Hey buzz I’m experimenting slowdown on every snes emulator and almost on every rom.

    Can you send me your config file please??????

    I’m powering the pi with the sub plugged at the tv

    #108016
    Profile photo of petrockblog
    petrockblog
    Keymaster

    sub=usb ?

    Your pi is probably not getting enough power. Did you read the posts above ?

    Which Pi?

    Do you have a small rainbow box at the top right of the screen ?

    Which snes emulator? (as an example).

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar