sixaxis and bluetooth

Tagged: 

This topic contains 15 replies, has 3 voices, and was last updated by Profile photo of trimmtrabb trimmtrabb 3 years, 2 months ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #5891
    Profile photo of vrilya
    vrilya
    Participant

    How do you hook up your sixaxis controller to your Retropie via bluetooth?
    I am not really a linux enthusiast (I know the basics though) so if you can guide me through it I would be most appreciated.
    wkr
    Vrilya

    #5893
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Hi, there’s a guide in the wiki: https://github.com/retropie/RetroPie-Setup/wiki/Setting-up-a-PS3-controller

    If you have found the solution to your problem please mark the topic as resolved.

    #5896
    Profile photo of gizmo98
    gizmo98
    Participant

    Easiest way:
    -You need an PC/MAC and the current IP-address of your pi
    -connect your usb-bluetooth dongle with your pi
    -connect your ps3 controller over usb with your pi
    –>no usb port is left 😉
    -connect over SSH (use putty: http://www.putty.org)
    ip: ip of your pi
    user: pi
    pw: raspberry
    -when you are connected:

    cd RetroPie-Setup
    sudo ./retropie_setup.sh
    Select "SETUP"
    Select "17 "Install driver and tools for PS3 controllers""
    

    -disconnect your controller
    -you can pair your controller now with the PS button

    SSH is not necessary if you have an usb hub.

    #5906
    Profile photo of vrilya
    vrilya
    Participant

    I tried both solutions and it seems that trimmtrabb’s solution to it worked… the other one just would’ve for some reason if I unhooked the USB-cable after reboot.
    Now to the other problem.
    as soo as the screen pops up for when to assign your buttons it seems as it is far too responsive.
    When I press up on my sixaxis controller it assigns it as down immediatly and the same goes for any other key on my gamepad I press.
    Is there a solution to this perhaps aswell?
    and thanks for the help by the way with the bluetooth thingy.
    wkr
    Vrilya

    #5907
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    you can configure the ES controls manually if you edit es_input.cfg:

    nano home/pi/RetroPie/.emulationstation/es_input.cfg

    If you have found the solution to your problem please mark the topic as resolved.

    #5915
    Profile photo of vrilya
    vrilya
    Participant

    Now every time I am done with my key setup (in that input editor) and try to save it, it says “script error”… I have no idea to why it does this so please once again help out.

    #5916
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    try exiting Emulation Station with F4 key and then edit and sudo reboot

    If you have found the solution to your problem please mark the topic as resolved.

    #5919
    Profile photo of vrilya
    vrilya
    Participant

    I’ll try…. I’m reflashing retropie 1.9.1 once again cause it’s gone apeshit on me.
    I usually SSH into the terminal or however you say it and do all the settings done there.
    But now when I press F4 on my keyboard hooked up to my raspberry pi it does’nt do a thing… and by Edit to you mean edit es_input.cfg cause I dont even have anything by that name anywhere.

    #5921
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    I got the command wrong, apologies. Try this via SSH:

    nano /home/pi/.emulationstation/es_input.cfg

    If you have found the solution to your problem please mark the topic as resolved.

    #5922
    Profile photo of vrilya
    vrilya
    Participant

    thank you I’ll make yet another attempt then 🙂

    #5923
    Profile photo of vrilya
    vrilya
    Participant

    es_input.cfg currently look like this… but how do I find out what the device name of my sixaxis is called and how do I change the keys manually?

    <?xml version=”1.0″?>
    <inputList>
    <inputConfig type=”keyboard”>
    <input name=”a” type=”key” id=”119″ value=”1″ />
    <input name=”b” type=”key” id=”46″ value=”1″ />
    <input name=”down” type=”key” id=”274″ value=”1″ />
    <input name=”left” type=”key” id=”276″ value=”1″ />
    <input name=”menu” type=”key” id=”99″ value=”1″ />
    <input name=”pageup” type=”key” id=”109″ value=”1″ />
    <input name=”right” type=”key” id=”275″ value=”1″ />
    <input name=”select” type=”key” id=”111″ value=”1″ />
    <input name=”up” type=”key” id=”273″ value=”1″ />
    </inputConfig>
    <inputConfig type=”joystick” deviceName=”Microsoft Microsoft® Nano Transceiver $
    </inputList>

    #5927
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Run: rm /home/pi/.emulationstation/es_input.cfg and reboot then press some buttons on your PS3 pad to finish the ES config. Es_input should then list your pad which you can edit to the correct values.

    Here’s mine for example:

    <?xml version=”1.0″?>
    <inputList>
    <inputConfig type=”keyboard” />
    <inputConfig type=”joystick” deviceName=”Xbox Gamepad (userspace driver$
    <input name=”a” type=”button” id=”0″ value=”1″ />
    <input name=”b” type=”button” id=”1″ value=”1″ />
    <input name=”down” type=”hat” id=”0″ value=”4″ />
    <input name=”left” type=”hat” id=”0″ value=”8″ />
    <input name=”menu” type=”button” id=”9″ value=”1″ />
    <input name=”right” type=”hat” id=”0″ value=”2″ />
    <input name=”up” type=”hat” id=”0″ value=”1″ />
    </inputConfig>
    </inputList>

    Use jtest to determine buttons:

    sudo apt-get install joystick

    then:

    jstest /dev/input/js0

    If you have found the solution to your problem please mark the topic as resolved.

    #5945
    Profile photo of vrilya
    vrilya
    Participant

    I am very thankful for all the help I have gotten so far.
    Still I cant get it to work.
    Everytime I do rm /home/pi/.emulationstation/es_input.cfg and reboot, and do the ES config once again as it shows up the sixaxis works fine.
    That is until I reboot retropi… there the controller just stops responding (cant scroll in the menus etc).
    And also when I go into the input configuration menu and try to edit the controlls there, once I save I get the message “script error”… this occurs both on my sixaxis controller and if I try to do a condfiguration on my keyboard.
    I’d also like to ask what file you configure (and if I can configure it manually through ssh) when you go into input configuration, as I guess es_input.cfg is only for controlling the interface for selecting emulator and games.

    #5950
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Ok, so now you can successfully configure the pad for Emulation Station and navigate the menus but it fails after reboot, correct? You are not having problems with over-responsive buttons anymore?
    I have no idea why the pad is not responding after reboot, could be power issues. Try unplugging any other usb devices.

    Can you confirm the pad functions correctly with jtest:
    jstest /dev/input/js0

    Regarding the input config menu (configures controls for the Retroarch emulators), the script does not work, to manually configure controls see here:

    Input configuration script fails, bindings are off

    If you have found the solution to your problem please mark the topic as resolved.

    #5951
    Profile photo of vrilya
    vrilya
    Participant

    I am not sure why it did’nt work after reboot earlier…. now it seems to connect so it must’ve been a fault from my part.
    The pad works as it should in jstest… I can see the numbers corresponding to the buttons being pressed etc.
    I would’nt believe it was a power issue as I am using a USB hub with it’s own power source.

    Now the controller seem to work in at least some emulators… for example it works as good as can be in the megadrive emulator but for some reason the A/B/X/Y (circle, square etc as it is a ps3 controller) buttons does’nt work in the snes emulator.

    #5952
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Ok, can you copy and paste the contents of your retroarch.cfg and es_systems.cfg

    If you have found the solution to your problem please mark the topic as resolved.

Viewing 16 posts - 1 through 16 (of 16 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar