Sixad breaking bluetooth pscan

This topic contains 5 replies, has 6 voices, and was last updated by Profile photo of PeanutButterBoy PeanutButterBoy 2 years, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #88928
    Profile photo of pjamp
    pjamp
    Participant

    Recently, after having my sixaxis time out I am not able to reconnect it by pressing the PS button. Earlier (few months back) this was possible..

    When doing hciconfig I get bluetooth “UP RUNNING” but no pscan. After a reboot “UP RUNNING PSCAN” and my sixaxis will pair no problem.

    After “breaking” I can manually do hciconfig hci0 pscan via ssh and the controller will pair again. But this is obviously more involved than I would like.. I prefer to keep the pi on 24/7 so turning off after every game isnt viable.. Anyone know how to make this work?

    #89744
    Profile photo of vis81
    vis81
    Participant

    Same probem on my setup. After PS3 controller has been connected first time after boot – PSCAN is suddenly disabled.
    Once I run “hciconfig hci0 pscan” – it starts to work again (PS3 controller is able to reconnect after being disconnected) until next reboot.

    I made a hack to workaround this problem by adding the same command to the end of sixad-sixaxis.cpp main function
    system(“hciconfig hci0 pscan”);

    But would be good to find the good solution.

    #89769
    Profile photo of justinbeaird
    justinbeaird
    Participant

    Same here I wanted to use ps3 controller s because I hate the big bulky Xbox receiver

    I beleve it worked well with retropie 2.5 beta img. But I didn’t use 2.5 very long

    #89810
    Profile photo of barbudreadmon
    barbudreadmon
    Participant

    I noticed this behavior with recent builds of blueZ. you probably should think about removing qtsixa and use native support of ps3 controller in recent blueZ (i don’t have a tutorial for raspbian, but this tutorial for gentoo probably can help you)

    #89817
    Profile photo of killer101
    killer101
    Participant

    I had issues with Bluetooth too. Try adding these 2 lines before the line “exit 0″ to the file etc/rc.local

    hciconfig hci0 up
    hciconfig hci0 piscan

    Fixed it for me!

    #89893
    Profile photo of PeanutButterBoy
    PeanutButterBoy
    Participant

    I was having the same issue, and similar to killer101, I did the following:

    sudo nano /etc/rc.local

    add the following 2 lines right before the “exit 0” line:

    hciconfig device up
    hciconfig enable pscan

    This is a slightly better method in case your device isn’t hci0.

    http://store.peanutbutterboy.com

    - We grind up the best peanut butter in the galaxy!

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar