Simple Theme System: Supegrafx

Home Forums RetroPie Project Emulation Station Themes Simple Theme System: Supegrafx

This topic contains 31 replies, has 3 voices, and was last updated by Profile photo of charco charco 2 years ago.

Viewing 32 posts - 1 through 32 (of 32 total)
  • Author
    Posts
  • #90268
    Profile photo of chimaera
    chimaera
    Participant

    Here is my simple system theme for Supergrafx

    #99073
    Profile photo of charco
    charco
    Participant

    Hi, I am new to this, so apologies for my noobishness.

    I would like to add this to my RetroPie menu and I can’t seem to find any tutorial thread on how do so.

    Am I right in thinking I can simply backup my current es_systems config, add the contents from the theme text file to it, save it as my new config and add it back to my Pi 2 along with the SuperGrafx svg file and background image to the relevant folder for the config to find the correct assets and it will work?

    EDIT: I think I understand, I add this theme to where the themes are kept but I will have to add the system to my es config file to add the system and then it will point to the right theme.

    #99078
    Profile photo of charco
    charco
    Participant

    The permissions on the /etc/emulationstation/themes/simple folder do not allow me to add the pcenginesupergrafx folder to it.

    #99231
    Profile photo of charco
    charco
    Participant

    I guess this one and PC Engine CD will be included in the next release anyway.

    #99233
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    charco, did you get my PM with my es_systems.cfg?
    i can help you out with this you just need to contact me, so i can help

    #99238
    Profile photo of charco
    charco
    Participant

    Yeah I got that, thanks. I am unable to move the SuperGrafx folder to the simple folder though as it says there is an issue with permissions. I am using Filezilla.

    #99257
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    ok, quit emulation station, next via ssh make a root account on you pi with sudo passwd

    then you can make a new connection via filezilla with your root login details, now navigate to the themes folder and drop the new folder in there, then close filezilla and reboot

    #99258
    Profile photo of charco
    charco
    Participant

    Thanks, I’ll try that tomorrow after work πŸ™‚

    #99371
    Profile photo of charco
    charco
    Participant

    No joy. I use that command on my pi, enter a new password, retype the new password and get confirmation that it has been updated successfully. When I try Filezilla it does not connect with the new password but only connects with the old details User: pi Password: raspberry

    #99399
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    ok so your using..

    username: root
    password: (whatever you chose)

    #99401
    Profile photo of charco
    charco
    Participant

    It seems to just let me change the password with that command, how do I change the username? Also, I am doing this from a terminal session on the Pi and not in any specified directory?

    #99402
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    start a brand new connection/profile in FileZilla just how you did when you connected first time

    #99403
    Profile photo of charco
    charco
    Participant

    Thanks, will try that this evening.

    #99405
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    your welcome, if you still have trouble just say and i’ll see if i can help more

    #99416
    Profile photo of charco
    charco
    Participant

    It worked! Thanks a million! I transferred the pcenginesupergrafx folder into /etc/emulationstation/themes/simple with no issues. Now I will add a roms folder for this system and edit my es config similar to yours to see if I can get it on my ES menu πŸ™‚

    #99417
    Profile photo of charco
    charco
    Participant

    Now I do not have permission to transfer my es_systems.cfg

    KILL ME!!!

    #99418
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    ok, goto

    /home/pi

    now make a new folder named

    .emulationstation

    now in that folder drop es_systems.cfg

    and restart

    #99420
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    in that folder

    .emulationstation

    you can make another called

    themes

    this is where to put custom themes!

    #99431
    Profile photo of charco
    charco
    Participant

    ok, goto

    /home/pi

    now make a new folder named

    .emulationstation

    now in that folder drop es_systems.cfg

    and restart

    Yeah, that folder is already there. The issue is I cannot move, edit, or copy my es_systems.cfg file that is located in /etc/emulationstation

    EDIT: I added the Themes folder from /etc/emulationstation to /home/pi/.emulationstation

    #99434
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    can you drag it from your pi to your pc, then from your pc to your .emulstionstation folder.
    if not, try copying via the root profile you used earlier

    #99438
    Profile photo of charco
    charco
    Participant

    Na I just cannot get this to work. It is saying I have an invalid config and won’t boot emulation station now. I have reverted to my previous config. Below is how I edited the config file. I edited it just like yours, or so I thought!

    <system>
    <fullname>PC Engine SuperGrafx</fullname>
    <name>pcengine</name>
    <path>~/RetroPie/roms/pcenginesupergrafx</path>
    <extension>.pce .PCE .zip .ZIP</extension>
    <command>/opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ pcengine %ROM%</command>
    <platform>pcenginesupergrafx</platform>
    <theme>pcenginesupergrafx</theme>
    </system>

    #99441
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    try it again but make sure the permissions are read/write

    #99445
    Profile photo of charco
    charco
    Participant

    I changed the permissions on the file, tried the file in both folders. Same error.

    #99448
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    ok can you attach your full es_systems.cfg and I’ll take a look

    #99449
    Profile photo of charco
    charco
    Participant

    Here it is, thanks for taking a look.

    Attachments:
    1. es_config.txt
    #99452
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    try this, just replace txt with cfg

    Attachments:
    1. es_systems.txt
    #99455
    Profile photo of charco
    charco
    Participant

    Success! Thanks so much. What kind of wizardry did you do? Where had I made the mistake?

    #99456
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    awesome!, your very welcome!
    you had this, twice

    <system>

    i’ve also spaced out the systems so as when editing it’ll make things easier to view as i’m sure your thinking of adding more custom elements

    #99458
    Profile photo of charco
    charco
    Participant

    D’oh! Thanks again, I will try to add PC Engine CD tomorrow evening πŸ™‚

    #99461
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    no worries, make sure your bio’s for pc engine cd, are named SYSCARD3.PCE and syscard3.pce, just duplicate and rename to whichever you don’t already have, and place them in your BIOS folder

    #99462
    Profile photo of charco
    charco
    Participant

    Added Turbografx 16 CD simple theme and it worked first time thanks to your guidance πŸ™‚

    Time for some Castlevania.

    #99636
    Profile photo of charco
    charco
    Participant

    Damn, the Supergrafx appears on the menu with the roms listed, but it doesn’t launch the games.

    EDIT: I checked the runcommand.log in the /tmp folder and found that it failed to extract the rom from the .zip file. I extracted the SuperGrafx roms and re-added them as raw .pce files and it now works. At least I am figuring stuff out on my own without annoying people on the forums πŸ˜›

Viewing 32 posts - 1 through 32 (of 32 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar