Shader hotkeys not working Retroarch

Home Forums RetroPie Project Everything else related to the RetroPie Project Shader hotkeys not working Retroarch

Tagged: 

This topic contains 6 replies, has 4 voices, and was last updated by Profile photo of mikecoscia mikecoscia 1 year, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #115576
    Profile photo of smartroad
    smartroad
    Participant

    I wanted to play about with the shaders in RetroArch and find one I like for my screen. I saw a youtube video where the guy pressed M and N to go forward and backwards. However that doesn’t seem to work for me, even if I press the control key as well.

    Tried a few searches but I don’t think I was asking the right question as I only ever got back about the shaders and what they do, not how to change them using the keyboard.

    Any suggestions would be gratefully received!

    #116898
    Profile photo of mikecoscia
    mikecoscia
    Participant

    I am having the same problem. I altered the retroarch.cfg file… video_smooth to false
    and video_shader_enable to true. I also removed the # to ensure they were loading. I also made sure hot keys were enabled. I know they work because start+select on the controller exits the game. I even remapped R+select and L+select to change shaders on my snes usb controller. Still nothing. Would appreciate any help.

    #116902
    Profile photo of pixelbrei
    pixelbrei
    Participant

    hey there,

    i was also struggeling today with shaders. my prob is more, that the shaders do not work the way i expect them to be, but this is another story ;). when troubleshooting this, i tried also to get the shader change when inside an emulator to work, to see the differences the shaders provide.

    in my case purely on mame4-all and fba, but i guess this is applicable for all retroarch bases emus.

    what i did was .. setting up the controller config here, to setup the general hotkey buttion and the buttons who are mapped to change the shaders when pressed in combination with the hotkey:

    – /opt/retropie/configs/all/retroarch-joypads

    in my case, i have an gpio controller in an arcade cab and therefore this file, but like before i guess this is also applicable to your joypads but with an other joypad.cfg file

    – GPIOController1.cfg (replace filename with the cfg your controller represents)

    here is a small snipped part from inside my conf …

    # define hotkey button
    input_enable_hotkey_btn = “8”
    # define hoteky combo keys
    input_exit_emulator_btn = “7”
    input_menu_toggle_btn = “2”
    input_select_btn = “6”
    input_start_btn = “7”
    input_state_slot_increase_axis = “+0”
    input_state_slot_decrease_axis = “-0”
    input_shader_next_btn = “0”
    input_shader_prev_btn = “1”

    maybe this helps with setting up your config … fingesr crossed 😉

    #116907
    Profile photo of mikecoscia
    mikecoscia
    Participant

    Yeah tried that, but can’t seem to get it to work. This is what I have…

    input_device = “USB,2-axis 8-button gamepad ”
    input_driver = “udev”
    input_r_btn = “5”
    #input_save_state_btn = “5”
    input_start_btn = “7”
    input_exit_emulator_btn = “7”
    input_l_btn = “4”
    #input_load_state_btn = “4”
    input_up_axis = “-1”
    input_a_btn = “0”
    input_b_btn = “1”
    input_reset_btn = “1”
    input_down_axis = “+1”
    input_right_axis = “+0”
    input_state_slot_increase_axis = “+0”
    input_x_btn = “2”
    input_menu_toggle_btn = “2”
    input_select_btn = “6”
    input_enable_hotkey_btn = “6”
    input_y_btn = “3”
    input_left_axis = “-0”
    input_state_slot_decrease_axis = “-0”
    input_shader_next_btn = “4”
    input_shader_prev_btn = “5”

    #116911
    Profile photo of Floob
    Floob
    Member

    Please see this thread:

    retropie 3.5 …can't enable shaders???

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #116933
    Profile photo of pixelbrei
    pixelbrei
    Participant

    i second what floob said .. forgot to mention, that i ran in the same problem and did a reconfigure in the following config file, to finally be able to browse the subfolder shaders

    – /opt/retropie/configs/all/retroarch.cfg

    in here i defined an absolut path to my testshaders and was able to browse within this subfolder

    – video_shader_dir = /opt/retropie/emulators/retroarch/shader/crt

    good luck !

    #116965
    Profile photo of mikecoscia
    mikecoscia
    Participant

    Thanks that is one thing I haven’t tried. I did set a shader manual through rGUI and it worked. However, I could only get the ones in the retropie folder to work. Not sure if that is normal or not, but at least it’s a step in the right direction.

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar