Setting up New RPi2

This topic contains 4 replies, has 3 voices, and was last updated by  ceuse 2 years, 8 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #89917


    Hello Everybody.

    I Just Got my new Rpi and went on to start over with a fresh Emulationstation Installation (2.6 iso)

    i had a RPI B running before with Emulationstation 2.3 i think and all worked fine (after quite some sweat and tears i might add).

    The main Problem im experiencing now are :

    I moved my complete snes collection to the new installation and put it in the snes directory . After snespi couldt open several i moved all my roms to the snes9x directory (which i think was used at 2.3) and i could open all my roms once again. but now i experience the issue that the snes emulator wont use the retoarch.cfg. (select should be my hotkey but it just speeds up everything, player 1 and 2 are swapped etc).

    other systems (like nes) work fine but when i exit to emulationstation by the configured hotkeys i get stuck at a back screen. only intresting message i see is : System directory is not set. assuming that its the same as the rom (which is defently wrong).

    anyone can help me out on both of those problems?

    (i will keep using this thread for further problems on my jurney :-))

    Thanks in advance



    See this video for setting up your SNES



    I don’t how yours work with zip files but none of the emulators I used would except zip files or winrar files.I had to decompress everything.I been on it for about 12 days and cant get the classic xbox,xbo360,Ps3or any aftermarket controllers to work.I can control the sega genesis and snes emulator,the ports but thats it.I have all the roms for every system installed except mame.I wanna play my nes and all the rest.
    I have used the auto config,and arch and still no luck.If you have time could you show you full settings listed in Retro arch.I have my j test working and also the Register configs but damn I still got nothing.Do I need to unplug the keyboard as well?Point me in right direction please!!! My head really hurts.I am super familiar with linux and windows but,I don’t know.



    Generally speaking the only emulators that work with zip files are mame and FBA.the rest will need to be unzipped.if you configured your controllers with the retroarch config tool in the set up script and they still aren’t working it might be good to check and make sure your the folders you placed your ROMs in are utilising retroarch cores. If they aren’t they may have their own separate configs (I.e. GBA, FBA, mame, mupen64plus, etc.) I’ve made a few videos on youtube going step by step on what I did when I set up my pi, but my controllers may be different than yours- floob has some good videos that are much more thorough than mine which may be useful to you.



    Thanks for the video. worked great for me.

    other problems i had / kinda solved :
    – using a usb snes and a usb n64 adapter wich has the same name kinda screws with emulationstation. i can just configure emulationstation to use either the snes or n64 controllers

    – gpsp uses J0 as default. i would need j2 though. started a specific topic for that HERE

    – having more then 12 system still f*$*s up emulationstation (i think i just have to accept that)

    – set up kody but struggeling to get my snes controllers (j2 & j3) working within cody. asked for a guide here HERE

    -begged zoid for a Kodi background HERE 😀

    if anyone has an idea on the first 4 problems thanks in advance 🙂

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at