Set up different controllers for different emulators?

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Set up different controllers for different emulators?


This topic contains 4 replies, has 2 voices, and was last updated by  jplaj 4 years, 6 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #2304


    I know it’s possible to override the button mapping using the individual emulators’ config files, but is it possible to use a different controller entirely?

    So far, it seems like running retroarch-joyconfig binds the system to a specific controller. Is it possible to set it up so, for example, I could use a playstation controller with PSX and an SNES controller with everything else?

    Thanks for the help!



    each controller should have an index you can switch in the configuration, I’m not an expert, but you might have to have all the controllers plugged in at the same time for it to work.



    Hi, thanks for the help. I finally got all the equipment I needed to test this. Here’s what happened.

    All equipment I’m using has been confirmed to work individually.

    One powered hub.
    Two retro-link USB SNES controllers (I’ve been using these ones for months)
    Two PS2 to USB adapters
    Two PS2 Sony-brand controllers.

    I ran the es input configuration with all four controllers running through the hub. The two SNES controllers were used for players one and two. The PS2 controllers were for players three and four. I’m assuming that means they’re indext 0, 1, 2, 3 respectively.

    Ran joyconfig once with the SNES controller, once with the PS2 controller. Neither one would work through the hub, so they were plugged in directly to the Raspberry Pi when I did that.

    I wrote down the outputs, then manually entered them in retroarch.cfg, with the SNES inputs for players one (index 0) and two (index 1) and the PS2 inputs for players three and four (2 and 3).

    I altered the retroarch.cfg file in the PSX folder to read:

    input_player1_joypad_index = 2
    input_player2_joypad_index = 3
    input_player3_joypad_index = 0
    input_player4_joypad_index = 1

    Here are my results:

    All four controllers work in emulationstation, whether running through the hub or plugged into the pi directly.

    The SNES controllers work in-game, but only if they were plugged directly into the pi when it boots up. Snes controllers have control over PSX games (which would be fine except for R2 and L2 buttons), despite the change in index. (I even tried overriding the ‘input_player1_btn’ lines to match the PS2 controls)

    The PS2 controllers don’t work in-game at all.

    [Ideally, I’d like to not have to use the hub at all. I’ll never need more than two players, so I’ll either boot up with the PS2 controllers for PSX, or the SNES controllers for everything else. However, I’m not adverse to using the hub if there are no other options]

    Thanks for your help, as always.



    I kind of have the same problem with devices in my powered hub, I’m wondering if the hub isn’t providing enough power and I need to get a better one.

    Mine is like a 3-4 year old 7 port Rosewill one from NewEgg



    The power rating could be an issue. I’ve also recently found out that with the hub plugged in, I can’t hot swap controllers. Oddly enough, the joypad index seems to be arbitrarily linked to specific ports on my hub. I did finally get everything to work, but all four controllers must be plugged in when booting, and I ran joyconfig for indexes 0 – 4, but the first time it would only register three of my controllers. I had to reboot with the fourth controller in a different port, then it worked fine.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss