Set shader settings automatically SNES

Home Forums RetroPie Project Video Output on RetroPie Set shader settings automatically SNES

This topic contains 5 replies, has 3 voices, and was last updated by Profile photo of matpie matpie 2 years, 1 month ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #97726
    Profile photo of matpie
    matpie
    Participant

    Hi guys,

    I just figured out how to automatically load a shader at snes startup. I use snes9x. My retroarch.cfg for snes looks like this

    video_shader = /opt/retropie/emulators/retroarch/shader/sabr/sabr-v3.0.glsl
    video_shader_enable = true
    

    But how can I set the “shader scale” to “1” and the “shader filter” to “nearest”. When I press F1 in retroarch menu I can set these two values. But I don’t know how to set it in the cfg. Do you know how to configure it?

    #97728
    Profile photo of patrickm
    patrickm
    Participant

    Hi guys,

    I just figured out how to automatically load a shader at snes startup. I use snes9x. My retroarch.cfg for snes looks like this

    video_shader = /opt/retropie/emulators/retroarch/shader/sabr/sabr-v3.0.glsl
    video_shader_enable = true
    

    But how can I set the “shader scale” to “1” and the “shader filter” to “nearest”. When I press F1 in retroarch menu I can set these two values. But I don’t know how to set it in the cfg. Do you know how to configure it?

    I wouldn’t recommend shaders on the pi as they tend to cause performance issues. I would instead opt for overlays – see “how to get scanlines.”

    If you insist, though:

    Main menu -> options -> video options -> shader
    There you will find “shader scale” and “shader filter.”

    #97733
    Profile photo of matpie
    matpie
    Participant

    Thanks for your answer. I know how to set it manually in the options. But I want to set these two values in the retroarch.cfg so there is nothing to do after starting snes9x. I don’t want to set it manually every time.

    #97734
    Profile photo of Floob
    Floob
    Member

    The default SNES emulator in RetroPie 3 beta 2 is lr-snes9x-next.

    Here are some examples for the retroarch.cfg that are generated (assuming 1 shader pass)

    Filter = Nearest
    Scale = Dont Care

    filter_linear0 = "false"
    wrap_mode0 = "clamp_to_border"
    mipmap_input0 = "false"
    alias0 = ""
    float_framebuffer0 = "false"
    srgb_framebuffer0 = "false"

    Filter = Linear
    Scale = 2x

    filter_linear0 = "true"
    wrap_mode0 = "clamp_to_border"
    mipmap_input0 = "false"
    alias0 = ""
    float_framebuffer0 = "false"
    srgb_framebuffer0 = "false"
    scale_type_x0 = "source"
    scale_x0 = "2.000000"
    scale_type_y0 = "source"
    scale_y0 = "2.000000"

    Filter = Dont Care
    Scale = 3x

    wrap_mode0 = "clamp_to_border"
    mipmap_input0 = "false"
    alias0 = ""
    float_framebuffer0 = "false"
    srgb_framebuffer0 = "false"
    scale_type_x0 = "source"
    scale_x0 = "3.000000"
    scale_type_y0 = "source"
    scale_y0 = "3.000000"

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #97735
    Profile photo of Floob
    Floob
    Member

    Although I think these need to be called in, so you call your shader “snescustom.glslp” (put it wherever – probably in shader dir is best) or similar, then its contents would be

    shaders = "1"
    shader0 = "/opt/retropie/emulators/retroarch/shader/scanline.glsl"
    filter_linear0 = "false"
    wrap_mode0 = "clamp_to_border"
    mipmap_input0 = "false"
    alias0 = ""
    float_framebuffer0 = "false"
    srgb_framebuffer0 = "false"
    scale_type_x0 = "source"
    scale_x0 = "1.000000"
    scale_type_y0 = "source"
    scale_y0 = "1.000000"

    Some shader settings info here:
    https://github.com/libretro/RetroArch/wiki/RGUI

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #97741
    Profile photo of matpie
    matpie
    Participant

    Hi Floob,

    thank you, the second method with the custom shader worked for me :).

    BTW: Your videos are great and also helped me to solve other problems. Thanks a lot 🙂 !

    Have a nice evening!

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar