Segmentation fault error with N64

This topic contains 7 replies, has 2 voices, and was last updated by  herbfargus 2 years, 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #111769


    Hey folks, I’m not too experienced with Linux or RetroPie.

    I had a version of RetroPie up and running and working pretty well. You can see my PiTendo build in an original NES case on the “people’s projects” section. I had gotten the N64 emulator going and playing some Conker’s Bad Fur Day with a PS3 controller and life was good. That was on version 3.0 beta 3. Then I decide to do some updates (apt-get upgrade -y git and then apt-get install -y git dialog) and it hosed me up somehow and then nothing would work. I don’t think I’ll do that again 🙂

    Well, I was trying to get everything perfect so I could image that set-up and make several others to give to some of my buds for xmas… so I’m bummed. Me and the boys used to play multi-player on Conker’s all the time so I really wanted to get the N64 emulator working before presenting them, if I can.

    So, today I’ve been trying to do a completely fresh build up using the 3.2.1 image. I thought it would be better to get a stable version. Things are going pretty well mostly. I’ve got my controllers working and NES/SEGA is running fine. When I try to run N64 now though, I get an error.

    Sorry, I’m being long winded.

    I’m using a Raspberry Pi 2 B
    3.2.1 image
    build from binary
    using iBuffalo SNES style controller and Playstation 3 dual shock connected VIA wire
    A basic generic USB keyboard
    Guides and instructions mostly from Google and YouTube (a lot of stuff from floob who I’m not surprised to see is a frequent poster here).
    Very little done at this point other than getting the controllers set up and adding some roms.

    When attempting to run an N64 game I get a few lines of text telling me where errors are logged then it dumps be back to EmulationStation. In the log it tells me:
    /opt/retropie/supplementary/runcommand/ line 704: 2492 Segmentation fault /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/$

    I have attempted to solve the problem by using the setup script to re-install the mupen64 and libreto mupen64 emulators VIA binary but that didn’t seem to do much.

    Again, I’m a bit of a newb to linux but I’m actually a technical lead by profession so not a total idiot (just mostly LOL). I have started doing this stuff to try to get beyond the basics in Linux.

    Here’s what happens if I try to start ANY n64 ROM (all of which worked for me in the beta version I was using earlier).

    Press a key (or joypad button 0) to configure launch options for emulator/port (lr-mupen64plus). errors will be logged to [blah]
    Init new dynarec

    Then it dumps me back to EmulationStation.

    Thanks for any help!



    Check the source of your roms, did you update your setup script first before updating the n64 binaries?



    How do I check the source of my roms? What do you mean by that? I think it’s against the rules to list exactly where I got them but it’s the same site I got all my NES and Sega ROMS that seem to work fine.

    The rom files also worked fine when I had the version 3 beta 3 up and running. I know that’s not a sure thing but it indicates to me the ROMS can work.

    I did NOT update the setup script before updating the n64 binaries. I’ll google instructions on how to do that, but please provide a link on how to do that if it’s not too much trouble.

    I think it’s possible to configure more than one potential N64 emulator so I’ll also see if I can figure out how to switch between them and see if one or the other works better.





    Thanks! I’ll RTFM 🙂

    IN my defense though it’s very hard to understand everything when you are starting from a high level of ignorance. If I waited until I fully understood everything before making some attempts, I’d never do anything… ever. Just a reminder that this stuff only seems obvious and complete to you because you already know what you’re doing.

    Some information has minor variations even within the official wiki and guides which can be hard when starting out. For example, one guide tells me to run:
    apt-get upgrade -y dialog

    one says just:
    apt-get upgrade

    I don’t know Linus and don’t know what the -y dialog means, and the options weren’t explained, so I’m not really sure which is right. I used the one with -y dialog.

    The recommended command I found to update the setup script:
    git clone –depth=1

    Fails, even though I’m following the script (, telling me the target directory exists and isn’t empty. So that doesn’t update the setup script.

    I used the setup script to update itself using the option “U” and that seemed to work so I assume I got the goal accomplished.

    I’m starting over with fresh re-image on my micro-SD, this time I made sure to do the updates including the setup script and the git updates/upgrades.

    Thanks for taking the time to help me and direct my efforts, I genuinely appreciate it.



    You raise some valid points. For the record though prior to a year ago I had never touched linux in my life so I was probably at the same level of ignorance (you have to start somewhere 😉 )

    So to address your points:

    Ignore all the settings on this page: That is primarily for when people set the script up manually on a prexisting linux OS like raspbian or debian

    You on the other hand are using the SD image (as you should – much easier that way) which is already prebuilt and has everything already set up on it. Using the prebuilt image is the ideal and recommended method for RetroPie, especially for beginners. It can be installed manually but typically thats for more advanced tweaking.

    This is the official guide to follow when building from an SD image:

    which is also linked on the sd image download pages.

    For Linux commands:

    apt-get upgrade -y dialog

    That basically tells your system to upgrade dialog (which is used to display the gui menu in the terminal) completely unneccesary for you to do. the -y tells it to say yes when it asks to download the updated files.

    git clone –depth=1

    again uneccessary as you are using the sd image: that basically clones the retropie setup script to your pi (which is already set up the sd card)

    apt-get upgrade

    actually installs newer versions of the packages you have: again really unecessary unless you are needing to update specific raspbian based packages- most are handled from the setup script.

    I always appreciate feedback particularly on the wiki as I’m the main maintainer of it (though it is open for anyone to edit and update) There is definitely room for improvement and I have tried to make it as clear as possible for new users.



    Thanks again.

    Is it likely that running these three items have caused damage or issues, such as the one I HAD with N64 (haven’t loaded a ROM and tested today’s attempt yet), and should I re-start from the image again and omit these:
    apt-get update
    apt-get upgrade
    apt-get install git

    Please don’t take my commentary as negative in any way, just factual at least through my lens. You’re certainly aces in my book for taking your time helping me out.

    I think what I was getting at was just like a gentle reminder that if all this stuff were clear and easy to understand the first time around and there were never issues, you’d not have much of a forum

    I am consistently amazed that within an afternoon or two I can get something like this going and I know that’s due to a staggering amount of work by a lot of other people. I’m not complaining. Actually I was looking at multiple set-up guides including on on the site for EmulationStation, github, the wiki, and the blog:

    RetroPie-Setup: An initialization script for RetroArch on the Raspberry Pi

    I think that is more the underlying issue. There was so much information out there and things are changing rather rapidly. So many things are just out of date I guess or may not agree. Or through my ignorance I’m not aware that some steps apply only to certain users and situations. I never mind being ignorant, as long as I’m not being stupid.

    This is fine though. Not being able to set up a system to play Dig Dug and Conker’s Bad Fur day without a few MINOR set-backs is like the definition of “FIRST WORLD PROBLEM”, LOL!

    Thanks again.



    Don’t worry, I don’t see most commentary as negative.

    But yeah don’t use those three lines of code they are unnecessary for the SD image.

    As far as the blog and all that is concerned disregard it, its outdated and fragmented. The only thing that is kept consistently up to date is the wiki, so go by that. (I add every new feature as soon as it is added to the source code) it can be a bit to take in all at once especially for beginners but then again the pi was designed for tinkering 😉

    Things are always improving and hopefully in the future we can address the fragmentation a little better. Things are definitely vastly improved from where they were a year ago.

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss