Sega CD Running Slow?

This topic contains 8 replies, has 5 voices, and was last updated by Profile photo of gizmo98 gizmo98 3 years, 4 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #4841
    Profile photo of danmanx
    danmanx
    Participant

    Hey guys, I checked out Raspberry Pi’s Forums and it said Sega CD (works flawlessly). However, I am seeing extremely slow video which makes the games unplayable.

    I am using stock GLSL which gives me a warning message on the command line. Any settings I must adjust for Picodrive?

    Thanks,
    Dan

    #4849
    Profile photo of whise
    whise
    Participant

    Mine runs perfect, nothing except a 950 overclock

    set video_threaded = true in retroarch.cfg maybe

    #4850
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Should video_threaded = true be a default setting set by the RetroPie-Setup Script? What do you think?

    #4854
    Profile photo of whise
    whise
    Participant

    Yes, I found that adding video_threaded=true improves performance. Also rewind_enable = false, can also improve performance, and enabling it cause some cores to segfault.

    Also setting sound rate to 44100 also improves audio performance in some cores.

    On overclocking, 950 is what I have, running smoothly all cores, except some x32 games (virtua fighter and some others).

    Also, I’ve read that using a lower ram split, leaving at least 192 mb of ram for the cpu may be better, at least that’s what the developer of muppen64plus-pi says.

    #4855
    Profile photo of karloss
    karloss
    Participant

    where are you guys putting megacd images for them to be picked up and work?

    thanks

    karl

    #4864
    Profile photo of whise
    whise
    Participant

    I think you need to include these lines in es_systems.cfg since they are not included in the original setup

    DESCNAME=Sega CD
    NAME=segacd
    PATH=/media/usb0/segacd
    EXTENSION=.smd .SMD .bin .BIN .md .MD .zip .ZIP .iso .ISO
    COMMAND=/home/pi/RetroPie/supplementary/runcommand/runcommand.sh 1 “/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/picodrive/picodrive_libretro.so –config /home/pi/RetroPie/configs/sega32x/retroarch.cfg %ROM%”
    #COMMAND=/home/pi/RetroPie/supplementary/runcommand/runcommand.sh 1 “/home/pi/RetroPie/emulators/dgen-sdl/dgen -f -r /home/pi/RetroPie/configs/all/dgenrc %ROM%”
    #COMMAND=export LD_LIBRARY_PATH=”/home/pi/RetroPie/supplementary/dispmanx/SDL12-kms-dispmanx/build/.libs”; /home/pi/RetroPie/emulators/dgen-sdl/dgen %ROM%
    PLATFORMID=21

    DESCNAME=Sega 32X
    NAME=sega32x
    PATH=/home/pi/RetroPie/roms/sega32x
    EXTENSION=.32x .32X .smd .SMD .bin .BIN .md .MD .zip .ZIP
    COMMAND=/home/pi/RetroPie/supplementary/runcommand/runcommand.sh 1 “/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/picodrive/picodrive_libretro.so –config /home/pi/RetroPie/configs/sega32x/retroarch.cfg %ROM%”
    #COMMAND=/home/pi/RetroPie/supplementary/runcommand/runcommand.sh 1 “/home/pi/RetroPie/emulators/dgen-sdl/dgen -f -r /home/pi/RetroPie/configs/all/dgenrc %ROM%”
    #COMMAND=export LD_LIBRARY_PATH=”/home/pi/RetroPie/supplementary/dispmanx/SDL12-kms-dispmanx/build/.libs”; /home/pi/RetroPie/emulators/dgen-sdl/dgen %ROM%
    PLATFORMID=33

    #4911
    Profile photo of danmanx
    danmanx
    Participant

    Thanks guys! I really appreciate the help here!
    video_threaded=true
    sound rate to 44100 did it for me!

    I also turned off vsync and I’m about to change the RAM to a more healthy split as per whise’s advice.

    I can finally play Mad Dog McCree on SegaCD!

    #4949
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Thanks for sharing – I will also add these systems to es_systems.cfg with the next update.

    #4982
    Profile photo of gizmo98
    gizmo98
    Participant

    You could also test OpenVG without threaded video driver. Threaded video driver can produce a significant input lag.

    video_driver=”vg”
    video_threaded=false

    (One warning: If you use OpenVG you can not open RGUI)

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar