Scanlines overlays and configs for a softer look

Home Forums RetroPie Project Video Output on RetroPie Scanlines overlays and configs for a softer look

This topic contains 90 replies, has 18 voices, and was last updated by Profile photo of Floob Floob 1 year, 2 months ago.

Viewing 35 posts - 36 through 70 (of 91 total)
  • Author
    Posts
  • #99272
    Profile photo of Floob
    Floob
    Member

    This should do it automatically for you if that helps:
    https://github.com/biscuits99/rp-video-manager

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #99275
    Profile photo of jamesandjome-com
    jamesandjome-com
    Participant

    Hi Floob,

    I have seen this (amazing work by the way) however I am reluctant to move from version 2.6 due to brain numbness and my understanding is that this is for version 3.2 is that right?

    Aside from this, is there another way? If I have to I will upgrade however that comes with another set of issues and I really wanna have some gametime and stop tinkering 🙂

    Edit: Also I noticed that the image in the OP has horizontal lines, however the files in post #19 give vertical lines. Is this intended?

    #99277
    Profile photo of Floob
    Floob
    Member

    Ah I see. Yes, the paths are for version 3. I havent checked if there are issues running it on 2.6 so probably best to hold off there.

    You could open the images in the 1080p_4-3 directory and see which ones have the TV border – then just manually check the reference in the retroarch.cfg file. Its only 2 images that are borderless.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #99278
    Profile photo of kitchuk
    kitchuk
    Participant

    Have you gone into the RetroArch GUI and turned on and selected the overlay?

    #99282
    Profile photo of zonitz
    zonitz
    Participant

    Try to remove everything again and then SSH to RetroPie and run: sudo chown -R pi /opt/retropie/ . Then try to install everything again, you should have the correct permissions now.

    #99330
    Profile photo of jamesandjome-com
    jamesandjome-com
    Participant

    Thank you all for your advice.

    @zonitz – Thank you for your suggestion, I deleted the file in overlays as you sugested and used, sudo chown -R pi /opt/retropie/

    After this I put the folder back and changed the path again in my retroarch.cfg for each system and it worked!

    Again, thank you all.

    #99855
    Profile photo of blockaboots
    blockaboots
    Participant

    Im not sure whats going on with the video scaling in retropie, im getting uneven scanline artifacts when using a shader like crt-easymode (which doesn’t require integra scaling to be enabled) and also on games where the screen would scroll vertically like on the intro of Space Meagforce or Super Castlevania the graphics seem to break up, i have set the video mode for the snes9x-next emulator to 1920x1080p 60hz progressive. If using retroarch on windows for example and leaving all video options to their default settings bar enabling fullscreen and setting ratio to 4:3 and loading the shader crt-easymode then i get not uneven scanline artifacts at all, so why is this happening with retropie and the snes9x-next lb core?

    EDIT: If i enable intrgra scaling then i dont get this graphical glitch when the screen is scrolling vertically, any ideas why i get this when integra scaling isnt enabled?

    #99858
    Profile photo of Floob
    Floob
    Member

    You’re probably better off opening a new thread for that, as this thread is mainly concerned with using overlays as per patl settings, as opposed to shaders.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #99864
    Profile photo of blockaboots
    blockaboots
    Participant

    Ok, have done that

    #99906
    Profile photo of dankcushions
    dankcushions
    Participant

    the 16_9.zip file link is dead in the first post 🙁

    #99915
    Profile photo of Floob
    Floob
    Member

    Try this one
    https://mega.co.nz/#!CMwlkByZ!ya7AFA62qPrA1BzAF6Xd6XazS1WeqEc7pBsV8XfRtGw

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #100939
    Profile photo of blockaboots
    blockaboots
    Participant

    Hmm, when i set the gambatte_gb_colorization option to ‘custom’ the GB screen does indeed go green but if i quit the emulator and load it back up then the gambatte_gb_colorization has reset itself back to ‘default’. Any ideas why the ‘custom’ setting isnt sticking?

    #100943
    Profile photo of Floob
    Floob
    Member

    It won’t be read on boot up. I could find that setting when I’m back at a PC, but it’s what the video manager tool should sort for you as well.
    When you save settings from RGUI they aren’t saved in a file retroarch will automatically read – for good reason. Post your saved config file and I’ll happily rip out the setting for you tomorrow.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #103164
    Profile photo of coderkind
    coderkind
    Participant

    I’ve followed the GitHub instructions to the letter (downloading the v0.4 latest release) and despite quitting and restarting EmulationStation and also doing a ‘sudo reboot’ I’m not seeing any scanlines or tv overlays in SNES or MegaDrive (the ones I’ve tried so far).

    What am I missing?

    #103181
    Profile photo of Floob
    Floob
    Member

    Are you using RetroPie 3 (any of the betas)?

    Here is a slightly updated version

    https://mega.co.nz/#!2NAUwbAL!BrgkCCWMerAxKDDE_0LYtR2qKjkDN26QZbDrIuIJ_28

    Put it in your home (/home/pi) directory and

    unzip -o rp-video-manager-11-JUL-2015.zip
    rm rp-video-manager-11-JUL-2015.zip
    cd /home/pi/rp-video-manager
    chmod 755 videomanager.sh
    ./videomanager.sh

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #103183
    Profile photo of coderkind
    coderkind
    Participant

    Yes; using the latest RC of RetroPie 3. Will download this latest version and try later, thanks a lot Floob. Was attempting to set this new version 3 up late last night and couldn’t investigate the source of the issue properly (but I’m 100% I followed the GitHub instructions to the letter).

    #103255
    Profile photo of coderkind
    coderkind
    Participant

    Floob; I think there’s errors in the v0.5 release; potentially had your text editor with the wrong type of line/carriage returns?

    When attempting to run ./videomanager.sh

    I get the following errors:

    ./videomanager.sh: line 1: $’\r’: command not found
    ./videomanager.sh: line 3: $’clear\r’: command not found
    ./videomanager.sh: line 9: $’\r’: command not found
    ./videomanager.sh: line 17: syntax error near unexpected token `$’do\r”
    ‘/videomanager.sh: line 17: ` do

    #103314
    Profile photo of Floob
    Floob
    Member

    Thanks for the feedback. I’ve just uploaded a new version.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #103422
    Profile photo of coderkind
    coderkind
    Participant

    Me again Floob (sorry). Think you named the latest release “v.06” rather than previous convention of “v0.6”. The latest version isn’t erroring for me but I’m still not seeing the overlays and I’m not sure what the difference between overlays is between the different levels of config options in the tool.

    I think I probably need to properly read through this thread and potentially install the latest RetroPie RC again from scratch.

    #103448
    Profile photo of Floob
    Floob
    Member

    Which system are you trying.
    To check it has applied, read the retroarch.cfg file in (for example)
    /opt/retropie/configs/megadrive/retroarch.cfg

    This should have all the updated code in it.

    *MAKE SURE* you run the install option in the config menu though, or it wont work.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #103932
    Profile photo of thorig
    thorig
    Participant

    @blockaboots

    gambatte_gb_colorization has reset itself back to ‘default’

    just had the same problem and found out that the core options are not saved in the retroarch.cfg file.

    instead I just added

    core_options_path = /opt/retropie/configs/gb/retroarch-core-options.cfg

    to my Gameboy retroarch.cfg file, which then will look for the ‘correct’ file, provided by patl

    #105145
    Profile photo of jaymzwise
    jaymzwise
    Participant

    Hi !

    Is it possible to brighten the PSX shader ?

    #105216
    Profile photo of coderkind
    coderkind
    Participant

    Thanks @floob; the install option sorted the scanlines for me but still didn’t see the tv background. Will have to run through it again soon.

    By the way, not sure if this has been asked elsewhere, but have you tried any scanline generators (external, like the XRGB-Mini Framemeister) with the Pi/Retropie? XRGB-Mini Framemeister link

    #105220
    Profile photo of Floob
    Floob
    Member

    Yep – I have a framemeister and an SLG3000. Although I think both are overkill for the Pi unless you are wrapping it up in a project like a PiCade or similar.
    I tend to use mine with my JPN Megadrive, really does make a great improvement.

    But I think the scanline overlays are the best bet for the Pi generally speaking.
    I’ll try and do a video guide for the overlay tool soon. Its how I run mine.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #105221
    Profile photo of coderkind
    coderkind
    Participant

    The PiCade looks similar to the iCade (which I did a Sanwa mod on a few years ago – linky). I’ve been keeping an eye on it but their blog suggested they were going to sell it with a 12” screen but haven’t yet AFAIK. I wouldn’t buy it otherwise and would probably do the parts mod once more.

    I’ve a few retro consoles in storage but the advantage of RetroPie was you didn’t have to clutter the room up and occupy all the inputs of your TV, but I’m coming to the way of thinking that it’s perhaps easier to just use the original hardware.

    The fact you’ve a Framemeister and the original consoles suggest you’re probably discerning regarding the video quality and experience too 🙂

    I do appreciate the help and effort you put towards the project and the videos, but how far off would you say scanline overlay graphics are from using original hardware and a Framemeister?

    #105306
    Profile photo of Floob
    Floob
    Member

    I’m going to try and build a PiCade over the next week or so, and I’ll see how it comes out. Yes, the current one comes with a 8″ screen in the kit form, so I guess I’ll have to see if that is big enough to try out the games properly. Although I see a 12″ is offered as a separate part.

    I’ve just bought a 5″ GPD XD, and they seem ok on that to be honest (although I need to work out how to get scanlines – and how to use Android!).

    I totally agree with you about the clutter that all the original hardware can cause, theres no way I could realistically set all the original kit up, I just have my Megadrive hooked up to a Mega Everdrive to save faffing about with the cartridges:
    http://shop.krikzz.com/Mega-EverDrive-v2-MEGAV2.htm

    The Pi is great for getting all those systems in one place, and making a very portable solution. I have to say that although I’m not the pickiest person in the world about video output, you can really tell that the framemeister is a fantastic bit of kit, and really worth it for original hardware. That said, for me, a scanline based overlay really does make a big difference for RetroArch on the Pi, and one that is certainly good enough for me, the effect is very good in my opinion. Personally I quite like the ones with the TV border on the outside, there are a couple of my YouTube vids showing that. I’ve recently added Thorigs settings to the tool above as well which are slightly different. Its worth seeing what suits you best.

    Here is a video that compares shaders (not overlays) to the framemeister, its not the best comparison in the world, as my TV and the youtube output dont neccessairly make the most accurate outputs, but it gives an idea:

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #105446
    Profile photo of jaymzwise
    jaymzwise
    Participant

    Hi !

    Is it possible to add overlay to pifba ?

    #105453
    Profile photo of Floob
    Floob
    Member

    @jaymzwise
    There is a very limited option listed here:
    http://sourceforge.net/projects/pifba/files/
    Which is to use the DisplayEffect option.

    Instead you could use the fba-libretro option which is used with RetroArch
    https://github.com/RetroPie/RetroPie-Setup/wiki/FinalBurn-Alpha

    Although it has fairly poor performance on a Pi1.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #105526
    Profile photo of coderkind
    coderkind
    Participant

    Thanks @floob.

    Looking into buying second hand Megadrives; there’s quite a bit to factor in (model version, subsequent mods, regions, etc)! I’m still tempted by the Framemeister though because I own a fair number of old consoles and it’d probably do a better job than overlaid image scanlines.

    If I used a Framemeister with the Pi then am I right in saying it’s best to edit the output settings of each emulator to match their original output resolutions (240p, etc) before letting the Framemeister do it’s upscaling and scanline job? From memory, I think each emulator outputs at an upscaled resolution to begin with?

    #105539
    Profile photo of bobchiba
    bobchiba
    Participant

    Hi,

    I’d really like to implement the original settings and overlays etc from this post, but I’m a little bit lost on the setup process. I only want to implement these settings for SNES emulation, I dont use anything else.

    Would anyone be so kind as to give me ‘pizza box’ instructions on how to get these video settings in place. I can SSH and FTP into my Pi and I know how to edit a file via ‘sudo nano’ but thats about the limit of my know-how.

    Any help on this would be much appreciated.

    #105542
    Profile photo of Floob
    Floob
    Member

    This guide may help you

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #105544
    Profile photo of bobchiba
    bobchiba
    Participant

    Ah….cool. thank you Floob!

    #109812
    Profile photo of jwh02017
    jwh02017
    Participant

    This stuff is AWESOME!!! Thank you guys so much. And thank you Floob for all your excellent youtube videos. You really go the extra mile and I know it must take a lot of time to make the videos. Just wanted to say it is very appreciated…. especially for a newbie like myself.

    Quick question… why isn’t the atari 2600 overlay supported in the tool?

    #112049
    Profile photo of LodanZark
    LodanZark
    Participant

    I cannot access to your dropbox files :\

    Overlays/Pillarboxs and other goodies for Retropie:
    https://www.dropbox.com/sh/3a7ylhwy3an2xrl/AAD-dOH-BXGuBrl6zphmJvyYa?dl=0

    #112050
    Profile photo of Floob
    Floob
    Member

    I’ve rolled most of the authors settings into this tool that includes all files
    https://github.com/biscuits99/rp-video-manager

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 35 posts - 36 through 70 (of 91 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar