save controller settings in mame4all pi in retropie 2.1 ?

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project save controller settings in mame4all pi in retropie 2.1 ?


This topic contains 12 replies, has 9 voices, and was last updated by  jhabu 2 years, 9 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #12211


    I have a problem, when I press TAB to configure the buttons on MAME4ALL, it works in the game, but if I put another game is not recorded my settings. one could change this?



    you’ve to do with root permissions…you’ve to go on terminal (press f4) and

    sudo -i
    cd /opt/retropie/emulators/mame4all  (mame4all folder i don't remember specifically folder)

    now you choose a game and inside game press tab on keyboard and you’ve to configure buttons



    or you can log into console and type :
    sudo chmod 777 /opt/retropie/emulators/mame4all/mame.cfg

    and now pi user have rights to update this file from the game menu TAB



    hi octubrq,

    definitely related to permissions within the “/opt/retropie” folder. Have a look at this location please:

    hope this helps.



    I first tried the solution of Taffazi87 , and this is the problem

    pi@raspberrypi ~ $ sudo -i
    lvl0: No systems found! Does at least one system have a game present? (check that extensions match!)
    (Also, make sure you’ve updated your es_systems.cfg for XML!)

    where is it es_systems.cfg ?

    Dem1980 the mame.cfg not is the problem , the problem is inside the game . configure all buttons inside the game



    user pi hasn’t rights to write in the mame.cfg file.
    So when you left a game and start a new game, the mame.cfg you configure in the last game had not been saved, because your user (pi) hadn’t the rights.
    To make user pi has the rights you have tu type the command :
    sudo chmod 777 -R /opt/retropie/
    for all emulators
    sudo chmod 777 /opt/retropie/emulators/mame4all/mame.cfg
    for only mame4all



    the problem is not the mame.cfg, I can edit that file with Winscp. loggin: root and password: ……. but in that file I can edit some controls but not all. only you can edit all within a game of MAME4ALL as you can see in the picture costs. I read in the forum that these controls keeps the mame inside and can not be edited. retropie in 1.9 as it was not necessary to be root, if kept, but now the problem of being tenenmos root



    (Total Noob here)

    I was mapping the controls for MAME using the keyboard and I accidentally set the “TAB” button as the Exit button. Now I can’t access the configuration page from a game using TAB because it will exit the game.

    Is there another way I can access it or possibly reset it?

    I know how to access my Raspi through the Terminal commands on my Mac if that makes a difference.

    Any help is appreciated.




    You can change the config back here:

    I imagine if you rename that file a new one would be created if you dont want to edit it.

    RetroPie help guides -->
    Please read this before asking for help -->



    You can change the config back here:

    I imagine if you rename that file a new one would be created if you dont want to edit it.

    I’m going to jump in here, because I’ve been trying to resolve the same issue (accidentally set my MAME UI Select button to NONE and then can’t use the UI). You do not need to delete the mame.cfg file. You actually need to delete or rename the default.cfg file that exists under the /cfg/ folder in mame4all then reboot and go into mame.

    cd /opt/retropie/emulators/mame4all-pi/cfg/
    mv default.cfg default_old.cfg
    sudo reboot

    (The ‘mv’ command is renaming the default.cfg file instead of deleting)




    I have the same problem that in the first post (mame4all doesn’t remember joy config).

    I chekcked the writing permissions and tried to execute mame as root but nothing works.

    Any ideas ?

    Thank you



    does anyone have a solution for this problem yet? can’t use mame without a keyboard now. which sucks.

    changing permissions, super user. owner etc… nothing seems to work.



    I solved the problem using mam4all-pi instead of mame4all

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss