Running some ROMS ..

This topic contains 10 replies, has 3 voices, and was last updated by  slighty 2 years, 3 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #107951


    1stly well done on your site… great work, love it.

    Now if you could try and help I am having some trouble getting SOME emulators to run their ROMS, I am delighted to say that MAME, ATARI, SNES and mega drive run like dreams.

    However N64 is a bit “laggy”
    Where as C64 doesn’t load (tragically) neither does Amiga nor Playstation.

    I will explain what happens to hopefully help with the solution
    C64 does the “searching” game “finds” game on the C64 blue interface and then displays “ready” and “run”.
    I dont seem to be able to exit the UI without a reset (power off!)
    Playstation I have downloaded the schp1001.bin – put it in the folder, followed the online video changed run command to 2. The ROMS appear on the Playstaion option (within RetroPi) but on loading it says <game name>.mdf file not supported – even though i have checked the extensions are declared. It reurns to the retroPi/Playstation area.
    guide followed

    Amiga – loads UAE4ALL i load the game into the disk, ensure the kickstart 1.3 is selcted (I have even pointed to it manually using the custom), I “reset” then the screen goes, white, grey, and freezes, depending on game I might see the Amiga UI for a flash, maybe some coloured lines scrolling fast (like the actual loading of a c64 game in the day).
    Guide followed:

    I feel (hope ) I am close to getting these working, as I say I have followed online vids etc and am all out of ideas…any help is welcomed.

    Spec wise the following:

    Pi Model: 2 B
    RetroPie Version Used: 3
    Built From: Image – from yourself
    USB Devices connected: none – i transfer ROMS using WinSCP
    Controller used: none .. wireless keyboard currently
    Error messages received: (as described)
    Guide used: (Mention if you followed a guide).. links given above

    Hope this helps, and I hope you can help …loving MAME and Atari but longing for them teenage / paperound money bleeding fun days of the C64 !!





    For the Amiga emulation, use the 3.1 kickstart rom, (it depends to a degree on the game you are running) – basically try the A1200 preset.

    This shows how to make sure your bios is in the right place

    The PS1 video you are following is a little dated now, as it was for the 2.6 version of RetroPie. Check out the Wiki for bios info etc..

    RetroPie help guides -->
    Please read this before asking for help -->



    Floob it’s you !!! Love your videos man.. I am a teacher and they are well understood, no “ers….” “coughing…” “bad language” or “…oh that’s strange why isn’t that working/I made a mistake” stuff that some of my vid tutorials have had ;0)

    Thanks for the reply and the feedback.

    I think you were onto something with the Amiga – I have *.Adf files (Speedball, Sensible soccer etc) and I was using a A500 set up, …I am STILL getting the white/black screen and ‘crash’ however through your video i noticed something. When you showed the kickfiles in …/uae4all/kickstarts/ and they had the blue path denoting they should also be in BIOS mine do not ONLY the red (see attached)

    Any further advice is well recieved.

    Also with the Playstation all seems OK, same my end as yours, my only difference is i am using mdf (error message) and img roms (do not show/list in EmulationStation…) I need to try some *.bin *.Arm ones as you have .. i know you cant tell me where you get yours but a hint?

    A couple of other questions (easy i hope) if i may

    A) I want to add more storage to the RetroPi would I simple by a 32/64 gb SD and copy all over (through Windows) ..or would i need to reinstall all on the new SD card?
    B) With the scrape if artwork etc doesn’t appear as part of the archive …I am thinking Mr Do, can you manually upload some and add ?

    Thank you again for your help

    1. RetroPi-isses.docx


    hmm, well if the bios files are in red, thats saying that they dont exist in the bios directory. Can you see them when you “ls /home/pi/RetroPie/BIOS” ?
    They (filename in the kickstart dir) are just symbolic links that look for the actual file in the BIOS dir.
    Well you could backup your smaller SD card with win32diskimager, then write it back to the larger card and expand the disk again to take advantage of the extra space.
    Are you using sselphs scraper?

    RetroPie help guides -->
    Please read this before asking for help -->



    Thanks for your help again so quickly.

    I know it is cryptic eh? The ROM files seem to be in the BIOS – did you manage to open the Printscreen I sent?

    The icon is red when i look at it within WinSCP and it is 1kb …when i do the ls home/pi/../BIOS etc the filenames appear as red. Strange

    I am using the standard scraper – as on the RetroPi, that is a problem I can solve later.

    I wonder do you have any ideas/videos on the getting the C64 VICE emulator working too.

    Cheers again for the help, I imagine you are busy !!



    Looking at your pic, the kickstart file (kick20.rom etc..) that are named correctly look to small at 1k. The Kick20.rom , ie capitalised wont be seen as they need to be all lower case. They dont need to be in the kickstart dir at all, just the BIOS dir.

    RetroPie help guides -->
    Please read this before asking for help -->



    I figured 1kb was too small..almost an empty folder. I renamed the others (lowercase) still no success. Same outcome, screen flash, stays black

    Is it too bold to ask you send me your .rom files? maybe as a zip, yours clearly work, I can drop them in the BIOS and see what happens.

    Just frustrating man as the Amiga and C64 was the big appeal for me on this project, yet i can get neither working.



    My kick31.rom is (on windows) 512KB. my kick13.rom is 256KB

    Once youve got these kickstart files its worth trying some other games, in case the ones you have, have an issue.

    RetroPie help guides -->
    Please read this before asking for help -->



    Working !!!!

    Wey hey… I was just about to give up.

    Sensible Soccer and Space Harrier works (or the front screen appear at least) but I can fiddle….

    As I say any advice on the whole C64 issue now ;0) .. c64 blue screen finds game..says loading and “sits there”. I have tried different games but any advice is welcomed.

    Also a …ahem erm… hint to where i might find working PSX roms,

    Cheers again man



    you can find psx roms in stores that still sell the games. if you still have your cds you can rip those as well in the bin/cue format, which is what i use, or use whatever format psx takes them in. you will also need to dig around for the bios files for that as well.

    how long have you waited for games to load on the c64 emulator?



    Ratix AND Floobs

    You wont believe it …all is running.

    I have (Some) Amiga playing ..

    I have Silent Hill and Crash team racing on PSX (img and BIN files …as per your video …my MDF do not seem to work!)

    Suddenly the c64 works as (like ratix says) I gave it time AND used *.g64 over the *.crt files as these didn’t load either!! Way of Exploding fist..Summer Games and High Noon all load …BUT I cant get them to respond via keyboard, I guess i need to config a controller?

    No problem with that.

    Thank you all again…very pleased !!


Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss