rpix86 compiling problem

This topic contains 9 replies, has 2 voices, and was last updated by Profile photo of goncalocg goncalocg 4 years, 2 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1579
    Profile photo of goncalocg
    goncalocg
    Participant

    Hello! I’m having problems installing this emulator…Through source – based  installation gives me the error that it was unable to compile PC engine source…

    How can I compile outside the retropie_setup?

    Thank you

    #1583
    Profile photo of goncalocg
    goncalocg
    Participant

    don’t know why I think I have vba-next and mednafen libretros missing from the emulatorcores…how can I implement them there?

    #1584
    Profile photo of goncalocg
    goncalocg
    Participant

    forget previous posts…everything working now…except DGEN that freezes in the beginning of each game at the screen DGEN and FBA that returns to the emulator… anyone maybe can help?

    Thank you

    #1585
    Profile photo of goncalocg
    goncalocg
    Participant

    also gngeo when launching games: appears in the terminal something like /installdir/bin/gngeo: not found….

    thank you…

    #1589
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Hello! I’m having problems installing this emulator…Through source – based installation gives me the error that it was unable to compile PC engine source…

    How can I compile outside the retropie_setup?

    Thank you

    The repository of the PC Engine libretro core (which, btw, is not an x86 but Turbo Grafx emulator) has been removed from Github for reasons that I do not know. The libretro core for PC engine can still be installed with the binaries-based installation, though. The latest version of the RetroPie Setup Script does not offer to compile the PC Engine core anymore, so that the error that you mentioned in your post is not displayed.

    #1590
    Profile photo of petrockblog
    petrockblog
    Keymaster

    don’t know why I think I have vba-next and mednafen libretros missing from the emulatorcores…how can I implement them there?

    VBA-next was rlaced by the GPSP emulator, which offers a superior performance compared to VBA next. For mednafen, see my post above.

    #1591
    Profile photo of petrockblog
    petrockblog
    Keymaster

    also gngeo when launching games: appears in the terminal something like /installdir/bin/gngeo: not found….

    thank you…

    Sounds as if there was an error during compiling gngeo. Or did you use the binaries-based installation? If not, you could try and use the source-based installation and select only GnGeo to be installed. That would download and compile only GnGeo without affecting the other components.

    #1594
    Profile photo of goncalocg
    goncalocg
    Participant

    hey petrockblog!! Thank you so much for your answer…

    I think most of my problems were provenient from the fact that I didn’t upgrate the setup script before installing…

    About gngeo… The first time I’ve installed retropie I ran source-based installation and in the end gave me the error that couldn’t compile DGEN and also  GNGEO… then I selected only dgen and gngeo, and tryed installing again;     then the error was only about gngeo that couldn’t be compiled…

    So I’ve made in the terminal:

    And I tought all went well, but I had that error when trying to run the games…then I tried again the source-based installation of only gngeo and there was no error information about the compilation…

    But when trying to play the games again that error about missing that folder…

    So what to do? and about dgen?

    Thank you for your time and patiente…i feel I’m so close to have everything working but there’s always something that doesnt work =(
    Let’s hope everything goes alright…thanks!!

    #1595
    Profile photo of goncalocg
    goncalocg
    Participant

    hey petrockblog!! Thank you so much for your answer…

    I think most of my problems were provenient from the fact that I didn’t upgrate the setup script before installing…

    About gngeo… The first time I’ve installed retropie I ran source-based installation and in the end gave me the error that couldn’t compile DGEN and also  GNGEO… then I selected only dgen and gngeo, and tryed installing again;     then the error was only about gngeo that couldn’t be compiled…

    So I’ve made in the terminal:
     wget http://gngeo.googlecode.com/files/gngeo-0.7.tar.gz
        tar xvfz gngeo-0.7.tar.gz -C $rootdir/emulators/
        ./configure –host=arm-linux –target=arm-linux –disable-i386asm –prefix=”$rootdir/emulators/gngeo-0.7/installdir”
        make clean
    make
    make install
     

    And I tought all went well, but I had that error when trying to run the games…then I tried again the source-based installation of only gngeo and there was no error information about the compilation…

    But when trying to play the games again that error about missing that folder…

    So what to do? and about dgen?

    Thank you for your time and patiente…i feel I’m so close to have everything working but there’s always something that doesnt work =(
    Let’s hope everything goes alright…thanks!!

    #1600
    Profile photo of goncalocg
    goncalocg
    Participant

    Dgen problemas are solved as I unzipped the roms….

    About GnGeo still don’t know what to do…

Viewing 10 posts - 1 through 10 (of 10 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar