Rpi2 Retropie 3.0 BETA Wifi Issues

Home Forums RetroPie Project New to RetroPie? Start Here! Rpi2 Retropie 3.0 BETA Wifi Issues

This topic contains 12 replies, has 3 voices, and was last updated by Profile photo of lunchbox lunchbox 2 years, 1 month ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #96471
    Profile photo of lunchbox
    lunchbox
    Participant

    Hey guys,
    I’ve finally gave in and decided to grab myself a pi. So I was super excited to get things going especially since people have said how easy it is. Well I’ve hit my first roadblock. Wifi doesn’t work.

    Pi Model: 2
    RetroPie Version Used: 3.0.0 Beta 2
    Built From: SD Image
    USB Devices connected: WiFi (TL-WN725N (Ver 2.1), Asus Bluetooth (which I’ll use with my DS3), and a logitech usb for my wireless keyboard and mouse.
    Error messages received: Upon sudo reboot, I get this in the terminal

    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3

    I get this when I tried to ping the static IP

    from 192.168.x.x icmp_seq=1 Destination Host Unreachable

    Guide used:
    1) Install drivers for TL-WN725N Ver2.1
    2) Set up WiFi (both DHCP and static)

    #96474
    Profile photo of herbfargus
    herbfargus
    Member
    #96535
    Profile photo of lunchbox
    lunchbox
    Participant

    Awesome, thanks a million for the link. That should be apart of anyone’s Rpi setup guides. I can confirm it works with my mobile device hotspot. However, I am still getting issues connecting it to my home WiFi. I don’t believe we have MAC filtering enabled since my friends can connect to the router. It seems to be hanging up when trying to retrieve an IP.

    Thoughts/suggestions?

    Update: Authentication issues I’m currently at that stage. Still experiencing WiFi issues. I tried a fresh install of Retropie 2.6 on my Rpi2, installed the drivers. Failed with wicd-curses. I’m open to suggestions.

    #96549
    Profile photo of herbfargus
    herbfargus
    Member

    I just added another wifi option to the source code- I’ve updated to wiki to reflect the change so the first option will walk you through it. You’ll need to update your setup script (you’ll need to be connected to the internet through Ethernet for this) if you arent comfortable with the terminal you can also access the retropie setup script from the retropie menu if you’re using retropie 3.0

    cd RetroPie-Setup
    sudo ./retropie_setup.sh
    Update setup script
    Exit setup script
    
    cd RetroPie-Setup
    sudo ./retropie_setup.sh
    Option 3 setup
    Option 323 Retropie configuration menu
    Reboot

    Then on reboot there will be a new option in the retropie menu in emulationstation called configure wifi- then you should be able to connect using the steps laid out in the updated wiki article.

    setting up wifi

    BTW with your particular WiFi dongle some of the things I’ve read have suggested that the drivers are configured by default in the latest rpi firmware so there wouldn’t be a need to compile the kernel for the driver and whatnot, but I could be wrong. The newest option I outlined above is wicd-curses and it might also solve firmware issues as well but don’t quote me on that either.

    #96639
    Profile photo of lunchbox
    lunchbox
    Participant

    Herb, I’m going to try this when I get home.
    I’ve read that version 1 of the adapter is configured automatically. Version 2 requires the drivers to be installed.

    Cheers,

    LB

    #96642
    Profile photo of herbfargus
    herbfargus
    Member

    My guess is you installed this driver?

    wget https://dl.dropboxusercontent.com/u/80256631/8188eu-v7-20150212.tar.gz
    tar xzf 8188eu-v7-20150212.tar.gz
    ./install.sh

    If so that was my last guess if this driver and wicd-curses doesn’t work.

    #96796
    Profile photo of lunchbox
    lunchbox
    Participant

    That would be the driver I did install. Also, thanks for adding the ability to configure the Wifi easily to the source code.

    I’m still having issues getting connected to my home network over WiFi. Ethernet works fine, connecting to my mobile hotspot works fine. But I keep getting stuck at “validating authentication”.

    What can I do to my router to fix this?

    Edit: I came across this I’m just not sure where to find wicd/wnettools.py so I can change the MAX_TIME settings

    #96802
    Profile photo of herbfargus
    herbfargus
    Member

    That is rather odd. You could try unplugging your router and plugging it back in or reconfigure it with wpa or remove WPA for a bit just to see if it will connect but idk I’m not a network person so I’m not entirely sure what you would do to get it to work This person had a similar issue https://forums.gentoo.org/viewtopic-t-962280-view-previous.html?sid=748ef0420b4562a0964c6711bf7c01cd

    It ended up being something in their WPA_supplicant.conf file.

    Is your router wep or WPA?

    Might also look into setting up a static IP, or just to eliminate any configuration issues you could try a fresh build and only install the driver and then try connecting through wicd-curses.

    #96804
    Profile photo of lunchbox
    lunchbox
    Participant

    WPA/WPA2 PSK

    I have tried a static IP. Still no luck.

    Unfortunately, I don’t have access to the router. I’d have to ask the landlord to restart it.

    I deleted the contents of the wpa file.
    I unfortunately deleted the wicd.log file (wanted to clear out the contents so I can look at the new logs.)

    *sigh*

    #96812
    Profile photo of herbfargus
    herbfargus
    Member

    Mine is WPA as well and it worked fine for me- if its having authentification issues might be good to double check your password. Without access to the router, Outside of a fresh install I’m not sure what to tell you :/

    #98151
    Profile photo of mikebzh44
    mikebzh44
    Participant

    Hi.

    I just start trying your distribution with my new RPi2

    I’m using latest RPI2 v3.0 beta SD card image but I don’t have WiFi menu.

    Do I need to run those commands ?

    Thanks.

    I just added another wifi option to the source code- I’ve updated to wiki to reflect the change so the first option will walk you through it. You’ll need to update your setup script (you’ll need to be connected to the internet through Ethernet for this) if you arent comfortable with the terminal you can also access the retropie setup script from the retropie menu if you’re using retropie 3.0

    cd RetroPie-Setup
    sudo ./retropie_setup.sh
    Update setup script
    Exit setup script
    
    cd RetroPie-Setup
    sudo ./retropie_setup.sh
    Option 3 setup
    Option 323 Retropie configuration menu
    Reboot

    Then on reboot there will be a new option in the retropie menu in emulationstation called configure wifi- then you should be able to connect using the steps laid out in the updated wiki article.

    http://blog.petrockblock.com/forums/topic/setting-up-wifi/

    BTW with your particular WiFi dongle some of the things I’ve read have suggested that the drivers are configured by default in the latest rpi firmware so there wouldn’t be a need to compile the kernel for the driver and whatnot, but I could be wrong. The newest option I outlined above is wicd-curses and it might also solve firmware issues as well but don’t quote me on that either.

    #98246
    Profile photo of herbfargus
    herbfargus
    Member

    Yes…

    #98251
    Profile photo of lunchbox
    lunchbox
    Participant

    Hey Mike,
    The option to set-up WiFi is in the Retropie menu. So once emulationstation loads up and you see the emulators, scroll over and select Retropie. Once you open that you should see the option to setup WiFi.

    Cheers,
    LB

    UPDATE to the threads topic:
    My Pi successfully connected to my WiFi ONCE out of probably 200 times. No clue what could be causing the issues. But there’s nothing I can do at this point to troubleshoot the problem.

    My newest problems are there’s some noticeable lag with my BT PS3 controller input (tested in SNES), and for some reason snes9x-next doesn’t pick up my joypad (BT PS3 controller). Still having fun figuring this stuff out despite it stressing me out.

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar