Rpi2 + Retropie 2.5: Random crashing; is my hardware stuffed?

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Rpi2 + Retropie 2.5: Random crashing; is my hardware stuffed?

This topic contains 3 replies, has 2 voices, and was last updated by  neighbourhoodnerd 2 years, 11 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #88037


    I’m having a bad time with my new Rpi2. Emulation runs downright perfectly with every emulator I use, which is such a joy after the lag in PSX and MAME on the Rpi1.

    My issue is that the Rpi2 freezes randomly, requiring a hard reboot (yanking out the power cable).

    Freezes have occurred when:
    -Running commands over SSH
    -Running commands in terminal locally
    -Copying files to the Pi over the network
    -(Most often) after closing an emulator

    With the 2.5 image I mainly get freezes with no error. Attached screenshot is from Buzz’s beta 2.5 image where it would display this error before freezing.

    My thoughts at this stage are:
    -The image is just not stable yet (but nobody else seems to have my problems)
    -My Pi got damaged in transit
    -Something about my SD card is no good (it’s a 32GB Class 10 SD/HC card (manufacturer: Apacer). Maybe it’s too big, or damaged, or not fully compatible with the Pi.

    Any suggestions will be very gratefully received. I’m at a stage where I have every system I want finally running at 100% – if I can fix this my project will be complete!



    Your Pi itself might have problems. I doubt your SD card hardware is causing the Pi to crash. The RetroPie images up to the current 2.6.0 have all been stable for me.

    Some things you didn’t mention:

    With all the crashes you most likely have some file corruption. I would start with erasing the SD card and reloading the current image.

    The other thing I would check is the power supply. What are you using to power your Pi? A dedicated wall wart? What’s the output amperage? It should be at least 2 – 2.5A @ 5VDC depending on what you have attached to the Pi.

    Speaking of which, what do you have attached to the Pi? 🙂 You can try disconnecting devices to see if they are causing problems.



    My wall plug should be the correct voltage, but that’s definitely worth checking. I ran my Rpi1 with a different plug. It may be worth investing in a dedicated wall plug for the Pi!

    I’ve wiped the SD card a few times so I’m confident this issue is not related to corruption.

    Currently attached to the Rpi2:
    -2x Logitech F710 wireless controller dongle
    -1x Microsoft wireless keyboard and mouse dongle
    -Ethernet, HDMI, Audio out

    Thanks heaps for your advice. I had power issues with the previous Pi at first, now that I think about it, so that could well be it!



    Confirmed – different PSU solved the issue. I am ROCKING now!

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss