[Solved][RP 3.2] 2 Axis, 8 button controller d-pad problems (iBuffalo)

Home Forums RetroPie Project Controller Configuration in RetroPie [Solved][RP 3.2] 2 Axis, 8 button controller d-pad problems (iBuffalo)

This topic contains 5 replies, has 4 voices, and was last updated by Profile photo of deftoner deftoner 1 year, 7 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #108559
    Profile photo of blackris
    blackris
    Participant

    Today I installed the new RetroPie 3.2 on my Raspberry Pi 2 and encountered a strange problem with my iBuffalo Classic USB Gamepad.

    It worked fine on all older RetroPie versions and RetroArch on my notebook. But with RP 3.2, the d-pad isn’t working anymore … kind of. Everything works fine in Emulationstation, in the ncurses menus, I even can navigate the runcommand menu. But when the game starts, the d-pad axis don’t work. To be accurate: I can switch the savestates by using the hotkey button in combination with left or right. But otherwise, I get no response. Pressing buttons in RGUI? No problem. But using the d-pad? No chance.

    I configured the gamepad via Emulationstation, tried the RetroArch Autoconfig, looked for something messed up in the retroarch.cfg, deleted the cfg for the gamepad a few times – nothing helps.

    This is a rather odd problem. My Xbox 360 gamepad works as it should (but you know, it has a veery crappy d-pad). Any help would be appreciated, thx in advance. 🙂

    #108564
    Profile photo of petrockblog
    petrockblog
    Keymaster

    There were some new config changes added, that may be the cause. Please edit

    /opt/retropie/configs/all/retroarch.cfg and remove the lines at the end

    
    input_player1_analog_dpad_mode = 1
    input_player2_analog_dpad_mode = 1
    input_player3_analog_dpad_mode = 1
    input_player4_analog_dpad_mode = 1
    input_player5_analog_dpad_mode = 1
    input_player6_analog_dpad_mode = 1
    input_player7_analog_dpad_mode = 1
    input_player8_analog_dpad_mode = 1
    

    and see if that helps.

    #108565
    Profile photo of petrockblog
    petrockblog
    Keymaster

    I can confirm the problem too – apologies. I should have checked this change before putting out 3.2.

    #108593
    Profile photo of blackris
    blackris
    Participant

    Yes, it works.

    Thanks for the awesome work, improving RP! 👍

    #108607
    Profile photo of 1nsane
    1nsane
    Participant

    Oh wow, I picked the wrong day to start again with my project. I did a full reinstall (3.2) but couldnt get my DPad on my Tomee Snes controller to work.

    This simple fix helped though!

    Thanks,

    #108769
    Profile photo of deftoner
    deftoner
    Participant

    GUI? No problem. But using the d-pad? No ch

    Man I was going crazy! I received my raspi2 2 days ago with the snes like pads. I was going crazy. The joystick worked fine on the menu but on the game the dpad doen’t work! I follow every single guide on the internet. I re writed the sd, I build from sources…

    Thanks.

    This works for me. After I deleted that lines I had to reconfigure the joystick from the emulator menu.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar