RP 3.2.1 lr-ppsspp fails to compile

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project RP 3.2.1 lr-ppsspp fails to compile

This topic contains 12 replies, has 2 voices, and was last updated by Profile photo of tekno911 tekno911 1 year, 7 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #110493
    Profile photo of tekno911
    tekno911
    Participant

    Here is a copy of the logs.

    pastebin link

    I have tried both lr-ppsspp or ppsspp and both fail. Seems headers and other stuff is missing. Build change?

    This was working a few days ago perfectly.

    #110505
    Profile photo of petrockblog
    petrockblog
    Keymaster

    did you update retropie-setup first ? is your system up to date too ? (sudo apt-get update; sudo apt-get upgrade) – have you installed any other packages recently ? (maybe you can paste via pastebin or similar your /var/log/dpkg.log)

    #110507
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Or for example have you used rpi-update to upgrade/downgrade kernel / firmware / sdk

    #110515
    Profile photo of tekno911
    tekno911
    Participant

    I installed 3.2.1 image, then I had that error on the logs. I updated the scripts, then I build from binary and it failed again. I have not done apt-get update and upgrade so I will try that and let you know how it goes. I have not installed anything besides basic image. No kernel update or downgrades.

    I will try apt-get update and upgrade now and if it fails I will post lr-ppsspp logs and /var/log/dpkg.log.

    The only thing I could think of is that I am using the image for berry boot and I am not 100% sure that it is a modified kernel because it come with iscsi so that your can scsi boot retro pie or any other os.

    I will try your suggestion and let you know.

    Thank you so much for your feedback.

    TG

    #110516
    Profile photo of tekno911
    tekno911
    Participant

    nothing to upgrade.

    pi@retropie ~/RetroPie-Setup $ sudo apt-get update
    Hit http://raspberrypi.collabora.com wheezy Release.gpg
    Hit http://archive.raspberrypi.org wheezy Release.gpg
    Get:1 http://mirrordirector.raspbian.org wheezy Release.gpg [490 B]
    Hit http://raspberrypi.collabora.com wheezy Release
    Get:2 http://mirrordirector.raspbian.org wheezy Release [14.4 kB]
    Hit http://archive.raspberrypi.org wheezy Release
    Hit http://raspberrypi.collabora.com wheezy/rpi armhf Packages
    Hit http://archive.raspberrypi.org wheezy/main armhf Packages
    Get:3 http://mirrordirector.raspbian.org wheezy/main armhf Packages [6,908 kB]
    Ign http://archive.raspberrypi.org wheezy/main Translation-en_GB
    Ign http://raspberrypi.collabora.com wheezy/rpi Translation-en_GB
    Ign http://archive.raspberrypi.org wheezy/main Translation-en
    Ign http://raspberrypi.collabora.com wheezy/rpi Translation-en
    Get:4 http://mirrordirector.raspbian.org wheezy/contrib armhf Packages [23.6 kB]
    Get:5 http://mirrordirector.raspbian.org wheezy/non-free armhf Packages [49.3 kB]
    Get:6 http://mirrordirector.raspbian.org wheezy/rpi armhf Packages [592 B]
    Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en_GB
    Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en
    Ign http://mirrordirector.raspbian.org wheezy/main Translation-en_GB
    Ign http://mirrordirector.raspbian.org wheezy/main Translation-en
    Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en_GB
    Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en
    Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en_GB
    Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en
    Fetched 6,996 kB in 19s (358 kB/s)
    Reading package lists… Done
    pi@retropie ~/RetroPie-Setup $ sudo apt-get upgrade
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    pi@retropie ~/RetroPie-Setup $

    #110517
    Profile photo of petrockblog
    petrockblog
    Keymaster

    I have seen the build problems you are having before – I think due to an older VC sdk – but could be caused by other conflicting packages/includes hence I wanted to see dpkg.log which will tell me what has been installed etc

    #110519
    Profile photo of tekno911
    tekno911
    Participant

    Here is the dpkg logs.

    pastbin link bellow.

    http://pastebin.com/RLjtRkk7

    #110520
    Profile photo of tekno911
    tekno911
    Participant

    Ohh and I forgot, I did installed ps3 controller drivers and configure them.
    Sorry about forgetting that little detail. Every bit of information helps.

    #110531
    Profile photo of petrockblog
    petrockblog
    Keymaster

    What is the output of git log -1 from within the RetroPie-Setup folder (just to make sure we are def up to date with the script).

    #110536
    Profile photo of petrockblog
    petrockblog
    Keymaster

    I downloaded the latest berryboot for the rpi2 (berryboot-20150916-pi2-only.zip), and tested with the 3.2.1 RetroPie berryboot image (after updating the RetroPie-Setup script), and it all built fine. Are you using the latest berryboot (in case it is related to the way berryboot overlays the filesystem over its base structure with kernel etc).

    #110539
    Profile photo of tekno911
    tekno911
    Participant

    pi@retropie ~/RetroPie-Setup $ git log -1
    commit 4142169a45e1b52920c673d6307e78c8e1e18e23
    Merge: fc955ac 630d079
    Author: Jools Wills <buzz@exotica.org.uk>
    Date: Sun Nov 22 13:07:30 2015 +0000

    Merge pull request #1093 from gizmo98/mupeninputscript

    inputconfig: add mupen64plus script
    pi@retropie ~/RetroPie-Setup $

    Honestly, I am at a loss. Maybe the image was corrupted somehow since I did not do a hash check on in after I downloaded it. I will start from scratch, download a fresh copy, check checksum, place berryboot-20150916-pi2-only.zip on my sd card, bind my iscsi lun, install retrotpie 3.2.1, update the script and try to install lr-ppsspp. Hopefully this time it will work. I will keep you posted and by the way… Thank you so much for your help. You are a real trooper for helping out and this is what makes this community so great. Thanks a million once more.

    I will post tonight the results so that if anyone runs into this issue, they will find a resolution to this problem as uncommon as it is.

    TY Buzz..

    TG..

    #110545
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Cheers.

    The only other thing I can think of is something is wrong with the includes and sudo apt-get remove --purge libraspberrypi-dev; sudo apt-get install libraspberrypi-dev might help.

    #110714
    Profile photo of tekno911
    tekno911
    Participant

    Buzz,

    I tried sudo apt-get remove –purge libraspberrypi-dev; sudo apt-get install libraspberrypi-dev and this allowed me to compile the lr-ppsspp. However, i noticed other issues and I am pretty sure my download image was somewhat corrupted. So I followed your advice and I did step by step with a fresh downloaded copy, checksum matched and I did not had any of these issues. Basically the most fundamental practice of a download which is to do a checksum on a download is what failed on me. Sometimes the most simple things are the ones that bite us. This proves the point, avoid headaches and checksum your files. We could of been chasing ghost for a while.

    Buzz.. Once more thanks.

    For anyone reading this, checksum your files..

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar