ROM question

This topic contains 10 replies, has 6 voices, and was last updated by  tommelom 2 years, 5 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #103650

    k-bert
    Participant

    So I’m new at this, but I’m already up and running with a Raspberry Pi 2 model B. I’m using the latest retropie, which I beleive is version 3. I have a PS3 controller working as a wired controller.

    Naturally feeling nostalgic I loaded up one of my favourite games from my youth into mame4all. It was Bubble Bobble. I have four different ROMs for this game and put them all on with the idea that I would find out which one works and remove the others. Every one of them worked, so I removed three and went back to try and play. I received an error message that the game was missing files and couldn’t be played. I had the same problem with all the other ROMs. The only worked if all the ROMs were there.

    Is there a way to combine the ROMs or to hide them in emulation station so only one shows up on screen? I tried to search this problem, but couldnt find anything.

    Thanks in advance and for all the info here.

    Cheers,
    K-bert

    #103657

    herbfargus
    Member

    The easiest way I’ve found is just to build a merged set with clrmamepro pro- it puts all the parents and their respective clones into one folder. Alternatively you can extract all 4 zip files and then zip the files all into one zip named the same zip name as the parent. On the ROM compatibility lists it shows which ROMs are clones/which parents they need.

    https://github.com/RetroPie/RetroPie-Setup/wiki/Managing-ROMs

    #103678

    k-bert
    Participant

    Thank you for the reply! I will try this as soon as I’m reunited with the computer with the roms Monday.

    Cheers,
    K-bert

    #103689

    gutossn
    Participant

    If you want I can send the rom pack with 746 working roms for Mame4all.

    Raspberry Pi B+ - Mini Bartop Arcade - Retropie 2.6!

    Raspberry Pi 2 + PS3 Controller Wireless - Retropie 2.6!

    #103764

    mayki
    Participant

    Pokud chcete, můžu poslat rom balíček s 746 pracovními ROMy pro Mame4all.

    Yes, that would be great… 🙂

    #103770

    k-bert
    Participant

    I would appreciate it.

    I’m still going to try the methods that herbfargus described, I feel I need to understand…

    Cheers,
    K-bert

    #103771

    herbfargus
    Member

    If you’re looking at mame4all ROMs this is the .DAT set you’ll want to use:
    https://drive.google.com/file/d/0B2TMeZ6iEFvHNDNHcl8tcUNIcDA/view?usp=sharing
    You can follow this video to create the set with the above .DAT file (make sure you create a merged set)

    #103772

    k-bert
    Participant

    …and as an update: I couldn’t get it done in clrmamepro (first time I tried to use the program and I’m positive that the fault is mine as I don’t know my way around the program), but extracting the files and doing it myself as described above worked perfectly.

    Thank you very much!

    Cheers,
    K-bert

    Edit: You must have posted the video while I was typing my reply. I will watch it and try it out. Thanks again!

    #103801

    rudyb
    Participant

    Hi.
    I myself am trying to get roms to work on retropie image as well.
    With no luck. Event tryed multiple times your .dat file and youtube instruction.

    I have a working rom set on MAME 164b for windows. All roms are working.
    Trying to convert them to mame4all on retropie.
    Retropie is used stable 2.6 and rc1 3.0 together with your dat file and also with the dat file retrieved as mentioned in your video. cmp4021a_64 used for conversion. After the conversion an trying to play the roms i get on all roms missing files. (while they ARE in the zip, i checked). What can be wrong, where can i start looking for solutions?

    What IS strange: in your video you can put roms in MAME4ALL and mameadv. I only have MAME and mameadv. No MAME4ALL folder. Even after running the latest install scripts.

    please can anyone help?

    #103872

    rudyb
    Participant

    Hi again, i found the solutions myself already. All the needed roms are working on retropie.

    #104103

    tommelom
    Participant

    I too have this problems with roms and clrmamepro. I rebuild and it copies all the roms that I have (not many at the moment). In retropie under “mame” I then have multiple Bubble Bobble, Gauntlet, Golden Axe etc. But none works. Anyone have a clue? Using 3.0 beta. Had the same problem with 2.6.
    I have all the files in mame4all.

    What was your solution, rudyb?

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss