RGUI Not available in Current Installation? How do I get it?

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project RGUI Not available in Current Installation? How do I get it?

This topic contains 9 replies, has 4 voices, and was last updated by  Cael 3 years, 10 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #5164


    I had trouble opening up RGUI in order to change PS discs. I started this thread: http://blog.petrockblock.com/forums/topic/cant-open-rgui/
    back in September, but then thought I solved the problem.

    I had to update my card recently. I have the newest version of the setup script. I’ve tried the “fix” I found before, re-installing RetroArch, but I still can’t get anything to open.

    Does anyone know why RGUI doesn’t exist on certain installations, and what do I need to do to get it? PSX is pretty much useless without it, but I know it must work somehow.

    Any help and/or information would be appreciated.



    Please post your retroarch.cfg



    I’ve attached both the main config and the one I use for PSX (note: the difference in file name is only so I could copy them into the same directory. They both have the same name on the SD card), in case that makes any difference. It’s worth noting, though, that RGUI won’t open in any of the RetroArch emulators.

    I’m not sure it’s a config issue, though. The menu_toggle and disc_eject/next functions, I added myself. There was no information about RGUI at all in the original file. It did work briefly (as mentioned in the other post) when I updated Retroarch in September, but now there’s nothing.



    I modified some lines.

    1. retroarch11.txt


    Tried the new file. No changes at all.

    I’m pretty sure my config file is solid, and the problem is somewhere in the installation. Keyboard commands won’t bring up the RGUI menu either. I think it’s simply not part of the program.



    try the latest RetroPie image 1.9.1 it definitely works on that. Maybe somethings gone wrong with your installation via the setup script

    If you have found the solution to your problem please mark the topic as resolved.



    You can use the hotkey button only as input_player_1. There is a difference between your files. Only Joypad 1 (PSX) or Joypad 3 can open RGUI.

    Your retroarchpsx.txt

    input_player1_joypad_index = 1
    input_player2_joypad_index = 0
    input_player3_joypad_index = 3
    input_player4_joypad_index = 2


    input_player1_joypad_index = 3
    input_player2_joypad_index = 2
    input_player3_joypad_index = 1
    input_player4_joypad_index = 0


    trimmtrabb: This should be the newest version. I ran the upgrade/update on it last night.

    gizmo98: I’ve set up the bypass configuration file for PSX so I can use Playstation controllers while still using SNES controllers for everything else. My issue isn’t which controller I’m using (I’ve tested the other three, just to be sure). In fact, every other hotkey function works fine on controller 1 while I’m in Playstation. It’s only the menu_toggle and the disc change functions that get no reaction.



    well by defauly it works in the 1.9.1 SD Image but Breaks in updating the Raspberry pi’s fw i think its something about the new experimental 2D video acceleration now in the fw After 1.9.1’s SD image was released

    i think we all gotta wait till somethings fixed on the matter (i had iy before updating now its gone .)

    and mself w/o RGUI to map nxengine’s controlls to my xbox controller, playing by the Handheld wireless keyboard/mouse combo unit. is a major PITA



    *bump* well i found that the configs looking for it to be an enabled hotkey + entered as “f1″ not f1 (w/o the ” s)

Viewing 10 posts - 1 through 10 (of 10 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss