Retropie / RetrOSMC ALSA Sound Issues

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! Retropie / RetrOSMC ALSA Sound Issues

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of somedude somedude 1 year, 6 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #111253
    Profile photo of somedude
    somedude
    Participant

    Hello guys,
    I’ve been at this problem for a few nights now, so any help would be worthy of a bronze statue in your likeness.

    I’m running RetrOSMC, which is a RetroPie installation built into OSMC. I’m using a Raspi 2, everything is up to date. Sound works fine in OSMC, but I get no sound in RetroOSMC. I’ve re-flashed / re-installed a couple of times, same results.
    I’ve tried setting options in /boot/config.txt such as hdmi_drive=2, but I’m confident that this isn’t the problem. When I run any emulators, it runs without sound and I get stuff like this in the log:

    
    PPU.RenderSub = 0
    PPU.FullClipping = 1
    Settings.Transparency = 1
    Settings.SpeedhackGameID = 7
    PPU.SFXSpeedupHack = 0
    coldata_update_screen = 0
    ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
    ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
    ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
    ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
    ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
    ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
    ALSA lib conf.c:4720:(snd_config_expand) Evaluate error: No such file or directory
    ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM default
    

    I’ve tried using sdl instead of alsa, same result.
    When I run cat /proc/asound/cards , I get
    cat /proc/asound/cards .
    It looks like alsa isn’t recognizing my sound hardware?
    I generated a log of my alsa settings:
    ALSA Log

    That’s all the information that I know how to collect, but I’ll share any logs or configs that might be relevant. I’d greatly appreciate any help that you guys can offer.

    #111316
    Profile photo of somedude
    somedude
    Participant

    Somebody elsewhere helped me resolve this.
    If sound driver issues (ALSA / SDL won’t run) try adding dtparam=audio=on to /boot/config.txt (config.txt for RetroPie, not the base OSMC installation).

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar