Retropie Resolution

This topic contains 6 replies, has 3 voices, and was last updated by Profile photo of randjo79 randjo79 3 years, 2 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #5783
    Profile photo of randjo79
    randjo79
    Participant

    I hope this has not been asked before and I missed it, but I was wondering if anyone was using a 50 inch 1080p tv when using retro pie and if so, what do you have the resolution set for in retropie. Seems like when I play the video is stretch a little and possibly not as clear as it should be. Thanks in advance.

    #5793
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Hi, I have a 42″ tv and run at 720p. See here for configuring the resolution of Emulation Station: https://github.com/Aloshi/EmulationStation/issues/55

    See here for configuring the video output of the Pi to match via /boot/config.txt: http://elinux.org/RPiconfig#Video

    I think when you say video is ‘stretched’ you mean the aspect ratio is not correct? You could stop the runcommand script from changing the resolution down to VGA when emulators are started by editing es_systems.cfg:

    nano /home/pi/.emulationstation/es_systems.cfg

    Locate the emulator you wish to modify and change the runcommand.sh start type from 1 to 2. For example, in the Playstation section you need to change this line:

    /home/pi/RetroPie/supplementary/runcommand/runcommand.sh 1

    This will keep the aspect ratio equivalent to the display resolution. There may be a slight performance hit by running at a higher resolution. I have tried emulators at VGA and 720p and haven’t noticed any difference myself.

    If you have found the solution to your problem please mark the topic as resolved.

    #5805
    Profile photo of toddforester
    toddforester
    Participant

    I’m not sure if this is a related issue but I am using a 7″ monitor and the console text and xgui are every small, almost unreadable. I have tried changing some things in the boot config but when I get the text readable emulation station won’t start. any help is appreciated.

    #5816
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    7″ dvi/hdmi? or composite?

    If you have found the solution to your problem please mark the topic as resolved.

    #5823
    Profile photo of toddforester
    toddforester
    Participant

    it is hdmi. it is this screen actually (pretty good deal a year ago when i bought it for $100) http://www.amazon.com/Lilliput-monitor-interface-dedicated-high-definition/dp/B0041I8UAO

    #5858
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    that’s a nice little screen 🙂 what settings are you adjusting to change the resolution in config.txt? Have you tried adjusting the ES resolution as well? https://github.com/Aloshi/EmulationStation/issues/55

    If you have found the solution to your problem please mark the topic as resolved.

    #5936
    Profile photo of randjo79
    randjo79
    Participant

    trimmtrabb, you were right on. This made a huge difference. Thanks a million.

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar