Retropie installation problems.

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! Retropie installation problems.

This topic contains 12 replies, has 3 voices, and was last updated by  jimbles 2 years, 4 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #104827


    Hi all,

    Took the plunge. Bought a model b rev.2.

    Followed the instructions with the sd card image.

    Incorrectly installed pi2 image, realised, formatted sd card with sd format tool.

    Installed pi1 image ver 3.

    After splash screen it goes to the command prompt. It displays the “illegal instruction 2xxx es_bin”

    I ran the update and upgrade commands. No luck.

    So I formatted the sd and tried again following all guidance, updating etc.

    It keeps giving me the illegal instruction.

    I found some people with similar issues, but they don’t seem to say if they fixed it, how..

    Can anyone shed some light on this?

    Eager to get into those emulators.



    When it boots does it show 4 raspberries or 1 raspberry?

    4 raspberries means you need the SD image for the RPI 2

    1 raspberry means the SD image for the RPI 1



    Definitely only one raspberry.



    That is odd. Its possible it corrupted on downloading/ the SD card might have issues. Try reinstalling with a fresh SD image again because it should just boot into emulationstation.



    Despite you saying you downloaded the rpi1 image, it still sounds like you are running the rpi2 image.

    You would be better off with purchasing a rpi2 for retropie – but it wont matter too much if you only want to emulator older systems.



    It’s definitely the rpi1 image I have. I’ve downloaded about 5 times. Formatted the sd card multiple times.

    I am planning on getting a rpi2, was trying to ease myself in first.



    The only other thing I could think of is trying another SD card but other than that I have no idea.

    But yeah I definitely recommend an rpi2



    please exit to a terminal or ssh in, and type

    md5sum /opt/retropie/supplementary/emulationstation/emulationstation

    and paste the output.



    ac7c2fd31f07030e285e2a83c77bcf0c /opt/retropie/supplementary/emulationstation/emulationstation



    That doesn’t match up the ES binary from either rpi1 / rpi2 retropie 3.0 images. So either it is somehow corrupt or you have downloaded another image.

    Please give me the filename / size and md5sum of the image you are writing (and the url where you downloaded it from)



    I got the download from:

    I used the magnet link to download as a torrent.

    Which gave me
    Size: 721 MB (757,067,539 bytes)
    Size on disk 722 MB (757,071,872 bytes)
    MD5: f2a2b2e456ce210b218ffef834ef11c9
    SHA1: da9b3c6631df81ab4f055f1ce71b69370e944337

    Which I unzipped with 7zip that gave me:
    Size: 7.51 GB (8,068,792,320 bytes)
    Size on disk 7.51 GB (8,068,792,320 bytes)
    MD5: 057e84585f1aacccc7bf69349b9dca64
    SHA1: c5c171fac6e6d4cca70f8e77ad2532ff34f496fa



    The original file is correct, but the resulting image is not. It does not unpack to 7.51 GB – the unpacked size is 2200000000 bytes – something has gone wrong there.

    the md5sum of the unpacked image is b3c489015d2f37b917da8e999465144d



    Unzipped the file again. All working now.

    Feel silly I missed that file size issue. Sometimes you can’t see the wood for the trees.

    Emulator all up running now. Thanks a lot.

    Already ordered a pi2 and some further equipment.

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss