Retropie Input Lag

This topic contains 5 replies, has 3 voices, and was last updated by Profile photo of petrockblog petrockblog 1 year, 6 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #111721
    Profile photo of sjo102784
    sjo102784
    Participant

    Hi – I’m running a Raspberry Pi 2 with Retropie 3.2. Updated/upgraded all software. When playing, I’m receiving about 50-100ms of input lag, which makes NES/SNES/Genesis/etc games unplayable.

    Running on a Samsung LCDTV with “Game Mode” on – which reduces the refresh rate to ~2ms. Never had an issue with any other systems running on game mode – Xbox One, 360, Wii U. This appears to be isolated to the Retropie setup. Any tips on decreasing input lag? Using wired USB controllers.

    #111723
    Profile photo of zigurana
    zigurana
    Participant

    Just out of curiosity, how do you measure the input lag?

    #111789
    Profile photo of sjo102784
    sjo102784
    Participant

    Measurement was just a guess as to the exact amount of delay. I have an A/V receiver that can toggle A/V sync lag to sync A/V depending on source output, so I tried to use my best judgement of the input lag based on that experience.

    I actually found the solution after changing some Rpi config settings. To anyone else looking for a solution to slight input lag (was killing my ability to play emulators), with a Raspberry Pi 2 B model, I set the video_hard_sync to “true” and the frame rate delay to 10 (option right under the video_hard_sync option in retroarch.cfg, directory is /opt/retropie/configs/all if I remember correctly).

    It should be noted that this config change didn’t exactly solve my issue – with a medium overclock at 900 Mhz and with each overclock beyond, I was getting increasing input lag. At no overclock (700 Mhz) I was lag free, but performance suffered. The final solution to the input lag issue was the config changes listed above AND overclocking to 800 Mhz. Those settings combined made for a basically perfect no lag input…making platformers/etc very playable on an LCD TV.

    So it seems to come down to a combination of what type of TV you have along with overclocking and Raspberry Pi config settings as well.

    #111811
    Profile photo of petrockblog
    petrockblog
    Keymaster

    video_hard_sync is unused on the RPI.

    #111812
    Profile photo of petrockblog
    petrockblog
    Keymaster

    you might want to try changing the video_threaded setting to false which could improve input lag.

    #111815
    Profile photo of petrockblog
    petrockblog
    Keymaster

    If you are getting more lag when overclocking, you might want to check your PSU/USB Cable. Perhaps you have power supply issues causing this.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar