RetroPie 3 beta 4

This topic contains 20 replies, has 5 voices, and was last updated by Profile photo of petrockblog petrockblog 2 years ago.

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #100107
    Profile photo of dougie1970
    dougie1970
    Participant

    i have updated to RetroPie 3 beta 4 but left and right still not working on the xbox 360 controller .

    works on beta 2

    #100111
    Profile photo of herbfargus
    herbfargus
    Member

    Try starting from a fresh image and see if that fixes it. The auto configs from previous configurations had conflicts

    #100118
    Profile photo of dougie1970
    dougie1970
    Participant

    yes it was a fresh image i used .

    #100132
    Profile photo of herbfargus
    herbfargus
    Member

    Left and right on the dpad or analog or both? It may be mapping it as btn rather than axis… See this post-

    https://github.com/RetroPie/RetroPie-Setup/issues/864

    #100141
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Please post a copy of the joypad configuration after using emulationstation set up – file is in /opt/retropie/configs/all/retroarch-joypads

    then delete it, and configure retroarch joystick using the option in supplementary menu of retropie-setup (Configure input devices for RetroArch) – then post a copy of that too, and I will check the differences. you can still use this configuration to set up your joypads for retroarch as before – please let me know if this makes it work correctly too.

    #100144
    Profile photo of petrockblog
    petrockblog
    Keymaster

    oh and also a copy of /home/pi/.emulationstation/es_temporaryinput.cfg – thanks 🙂

    #100166
    Profile photo of dougie1970
    dougie1970
    Participant

    its Left and right on the dpad thats does not work .

    #100350
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Would you be able to help me with the information above ? Will help us work out what was generated incorrectly in the config. Much appreciated thanks.

    #100373
    Profile photo of dougie1970
    dougie1970
    Participant

    Would you be able to help me with the information above ? Will help us work out what was generated incorrectly in the config. Much appreciated thanks.

    been trying to get it but not sure how to do it . i have logged in with ftp and cant find the files you are talking about .

    #100375
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Assuming you are on Windows (if on Os X whatever is the equivalent software)

    please install the latest beta version onto an SD card.

    Then boot it up on the pi (with the pi connected via ethernet to your network), and configure your joypad on emulationstation. Once this is done, using Putty http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html connect to the Pi (hostname retropie), and use login: pi, password: raspberry

    once at a command prompt type

    
    cp ~/.emulationstation/es_temporaryinput.cfg /opt/retropie/configs/
    

    now go to your PC and browse the network – you should see the retropie machine on the network with some shared (roms/configs/bios). Go to configs, and copy the es_temporaryinput.cfg file to your PC.

    Then browse to configs/all/retroarch-joypads/ and copy the .cfg file in there to your PC also.

    Now go to a retroarch emulator such as lr-picodrive and confirm left/right are not working. If not go back to the PC, and browse again to configs/all/retroarch-joypads/ and remove the file.

    Now go to retropie-setup, and the supplementary menu, and choose the option to configure retroarch input devices. Choose joystick and follow the instructions. Once this is sorted, go back to the emulator, and check if controls are all working correctly – they should be.

    Now go back to the PC and browse again to configs/all/retroarch-joypads/ there should be another config in there. Please copy this to the PC also (renaming it if it has the same name as the previous config file we copied off).

    These are the 3 files I need. The es_temporaryinput.cfg file – the first joypad configuration file (which we generate), then the second joypad configuration file made using the retropie-setup retroarch input configuration option.

    Thanks.

    #100376
    Profile photo of dougie1970
    dougie1970
    Participant

    Assuming you are on Windows (if on Os X whatever is the equivalent software)

    please install the latest beta version onto an SD card.

    Then boot it up on the pi (with the pi connected via ethernet to your network), and configure your joypad on emulationstation. Once this is done, using Putty http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html connect to the Pi (hostname retropie), and use login: pi, password: raspberry

    once at a command prompt type

    
    cp ~/.emulationstation/es_temporaryinput.cfg /opt/retropie/configs/
    

    now go to your PC and browse the network – you should see the retropie machine on the network with some shared (roms/configs/bios). Go to configs, and copy the es_temporaryinput.cfg file to your PC.

    Then browse to configs/all/retroarch-joypads/ and copy the .cfg file in there to your PC also.

    Now go to a retroarch emulator such as lr-picodrive and confirm left/right are not working. If not go back to the PC, and browse again to configs/all/retroarch-joypads/ and remove the file.

    Now go to retropie-setup, and the supplementary menu, and choose the option to configure retroarch input devices. Choose joystick and follow the instructions. Once this is sorted, go back to the emulator, and check if controls are all working correctly – they should be.

    Now go back to the PC and browse again to configs/all/retroarch-joypads/ there should be another config in there. Please copy this to the PC also (renaming it if it has the same name as the previous config file we copied off).

    These are the 3 files I need. The es_temporaryinput.cfg file – the first joypad configuration file (which we generate), then the second joypad configuration file made using the retropie-setup retroarch input configuration option.

    Thanks.

    ok thanks i will give it ago and post back as soon as i have it .

    #100381
    Profile photo of dougie1970
    dougie1970
    Participant

    i could not find es_temporaryinput.cfg file as it was not there .

    ok this is the file after set up and right and left did not work .

    The first joypad configuration file (which we generate),

    input_device = “Microsoft X-Box 360 pad”
    input_driver = “udev”
    input_up = “h0up”
    input_right = “h0right”
    input_state_slot_increase = “h0right”
    input_down = “h0down”
    input_left = “h0left”
    input_state_slot_decrease = “h0left”
    input_a_btn = “0”
    input_b_btn = “1”
    input_reset_btn = “1”
    input_x_btn = “2”
    input_menu_toggle_btn = “2”
    input_y_btn = “3”
    input_r_axis = “+5”
    input_save_state_axis = “+5”
    input_r2_btn = “5”
    input_l3_btn = “9”
    input_r3_btn = “10”
    input_start_btn = “7”
    input_exit_emulator_btn = “7”
    input_select_btn = “6”
    input_enable_hotkey_btn = “6”
    input_l_x_plus_axis = “+0”
    input_l_x_minus_axis = “-0”
    input_l_y_plus_axis = “+1”
    input_l_y_minus_axis = “-1”
    input_r_x_plus_axis = “+3”
    input_r_x_minus_axis = “-3”
    input_r_y_plus_axis = “+4”
    input_r_y_minus_axis = “-4”

    This is the 2nd file and left and right works fine after removeing the 1st file and going to configure retroarch input devices .

    input_device = “Microsoft X-Box 360 pad”
    input_driver = “udev”
    input_b_btn = “1”
    input_y_btn = “3”
    input_select_btn = “6”
    input_start_btn = “7”
    input_up_btn = “h0up”
    input_down_btn = “h0down”
    input_left_btn = “h0left”
    input_right_btn = “h0right”
    input_a_btn = “0”
    input_x_btn = “2”
    input_l_btn = “4”
    input_r_btn = “5”
    input_l2_axis = “+2”
    input_r2_axis = “+5”
    input_l3_btn = “9”
    input_r3_btn = “10”
    input_l_x_plus_axis = “+0”
    input_l_x_minus_axis = “-0”
    input_l_y_plus_axis = “+1”
    input_l_y_minus_axis = “-1”
    input_r_x_plus_axis = “+3”
    input_r_x_minus_axis = “-3”
    input_r_y_plus_axis = “+4”
    input_r_y_minus_axis = “-4”
    input_enable_hotkey_btn = “6”
    input_exit_emulator_btn = “7”
    input_menu_toggle_btn = “2”
    input_load_state_btn = “4”
    input_save_state_btn = “5”
    input_reset_btn = “1”
    input_state_slot_increase_btn = “h0right”
    input_state_slot_decrease_btn = “h0left”

    All seems to be working fine again .

    #100383
    Profile photo of petrockblog
    petrockblog
    Keymaster

    ok. That’s enough information anyway. The problem you have was due to us handling hat inputs wrong. This was fixed earlier today, so if you update retropie-setup script then re-install emulationstation from binary from menu 5, it should sort it after a reboot when configuring.

    #100393
    Profile photo of dougie1970
    dougie1970
    Participant

    Thanks very much for all your help .

    #100415
    Profile photo of dougie1970
    dougie1970
    Participant

    I can now say this is working on 1st set up after updateing retropie-setup script then re-install emulationstation from binary.

    #100751
    Profile photo of looser
    looser
    Participant

    Same issue with the freeze is still existing here, reinstalling emulationstation did not help.

    What I did:

    On a Raspberry 2 with Logitech K400 keyboard and XBox 360 wireless controller

    -vanilla 3.0 beta4
    -Still under Windows: Added licenses and overscan settings to config.txt
    -Via ssh
    -Changed password
    -Enhanced filesystem via raspi-config
    -Reboot
    -Updated retropie-setup script
    -Restarted retropie-setup and installed (306) Emulationstation binary
    -Still there updated in retropie-setup (300) apt-packages
    -Reboot
    -Via Screen
    -Welcome screen of emulationstation/gamepad config
    -Configed buttons (while skipping the config for thumbs buttons).
    -Freeze in the emulationstation menu (not sure if that is the right term,
    the main manu, where the emulators can be selected)
    after around 10-15sec, via ssh the raspi is still accessible.
    -Rebooting, Welcome screen doesn’t show up any more,
    again, after 10-15sec it freezes.

    Any ideas what I could try or logs I could provide?

    Thank you!

    #100766
    Profile photo of Floob
    Floob
    Member

    What happens if you do
    -vanilla 3.0 beta4

    Then configure the controller (its normal for it to pause for about 5 secs or so as it writes files for the first time)

    See if it freezes then.
    Also, what controller are you using?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #100799
    Profile photo of looser
    looser
    Participant

    Tried that approach, it makes no difference. Also freezes in the menu. I can switch right or left only over a few emulators before it stops, sometimes even in the transition.
    It’s definitely not about saving the configuration at the welcome screen, that happens after that.

    The controller is a XBOX 360 wireless controller, just for curiosity I tried it with another vanilla 3.0 beta 4 only with configuring the keyboard (Logitech K400) instead and get the same result, goes successfully through the configuration, then freezes in the menu after a couple of seconds, around 10-15.

    #100802
    Profile photo of Floob
    Floob
    Member

    Any chance it could be a dodgy MicroSD?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #100817
    Profile photo of looser
    looser
    Participant

    I had that also in my mind, so these latest tries are done already on a brand new one, but it didn’t change anything.

    Don’t know if it’s of help, but I also gave the stable 2.6 a go,
    but anyway, I face it even with that version.

    #100818
    Profile photo of petrockblog
    petrockblog
    Keymaster

    faulty controller, faulty pi, faulty/poor psu? try ruling out somethings. changing psu/cable is a good idea perhaps. this is not a known problem and others are not reporting it.

Viewing 21 posts - 1 through 21 (of 21 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar