Retropie 3.6 – Problems with N64 and Dreamcast (Xbox 360 Controller)

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Retropie 3.6 – Problems with N64 and Dreamcast (Xbox 360 Controller)

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of pygmaee pygmaee 1 year, 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #122032
    Profile photo of ankou87
    ankou87
    Participant

    Hello,

    since I updated my RPi to RetroPie 3.6 I have some problems with the Button-Mapping on N64 and Dreamcast.
    The config Files are all fresh, I don’t take them from my old installation.

    I use a wired Xbox 360 gamepad with the userspace driver.

    N64: The mapping of the “Exit Emulator” button doesn’t work correctly. It resets to default values every time I start a game (for my configuration the default mapping means “J1B8/B9”, which means, that only the second controller can exit the game. If I play with just one controller I can not exit).

    Dreamcast: First of all I am very happy that this emulator works better after the update. I get now to the loading screen of every game (after setting date and time and choose a memory slot). Every game tells me to hit “Start” but that doesn’t work.

    I searched for both problems and found several hints but nothing worked. It seems that most informations are outdated (mostly for dreamcast the config files mentioned in nearly all help-topics I found are not in the described path or the entrys are not in them).

    Hope someone has an advise for my problem.

    Thanks,

    Ankou

    #122162
    Profile photo of pygmaee
    pygmaee
    Participant

    The problem with mupen64plus and hotkeys is, everytime you start the programm, the mupen64plus.cfg gets edited. To change that, edit the runfile for mupen64plus.

    /opt/retropie/emulators/mupen64plus/bin/mupen64plus.sh

    done
    # write hotkey to mupen64plus.cfg
    iniConfig “=” “\” $configdir/n64/mupen64plus.cfg”
    iniSet “${hotkeys_m64p[$i]} “$bind”

    comment the two last lines out, it should look like this.

    done
    # write hotkey to mupen64plus.cfg
    #iniConfig “=” “\” $configdir/n64/mupen64plus.cfg”
    #iniSet “${hotkeys_m64p[$i]} “$bind”

    However keep in mind that, your hotkey configurations from retroarch are not updated to mupen64plus anymore.

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar