Viewing 34 posts - 1 through 34 (of 34 total)
  • Author
    Posts
  • helpman
    Participant
    Post count: 37

    Hi there!
    I had shaders working fine on 3.0 but since then I’ve been unable to make them work.
    I tried starting a 3.5 setup from scratch, but still can’t make the shaders work.

    (and BTW, retropie 3.5 takes AGES to load compared to other builds… it takes a long long time to load emulation station)

    on configs/all/retroarch.cfg,

    # Smoothens picture with bilinear filtering. Should be disabled if using pixel shaders.
    video_smooth = false
    # Path to shader. Shader can be either Cg, CGP (Cg preset) or GLSL, GLSLP (GLSL preset)
    video_shader = /opt/retropie/emulators/retroarch/shader/xsal/2xsal.glslp
    # Load video_shader on startup.
    # Other shaders can still be loaded later in runtime.
    video_shader_enable = true
    # Defines a directory where shaders (Cg, CGP, GLSL) are kept for easy access.
    video_shader_dir = /opt/retropie/emulators/retroarch/shader/

    that’s all I have set for video shaders…

    on remapping files (i.e. neogeo/retroarch.cfg)

    # Settings made here will only override settings in the global retroarch.cfg if placed above the #include line
    input_player1_joypad_index = 0
    input_player1_b_btn = 0
    input_player1_a_btn = 1
    input_player1_y_btn = 2
    input_player1_x_btn = 3
    input_player1_start_btn = 7
    input_player1_select_btn = 13
    input_player2_joypad_index = 1
    input_player2_b_btn = 0
    input_player2_a_btn = 1
    input_player2_y_btn = 2
    input_player2_x_btn = 3
    input_player2_start_btn = 7
    input_player2_select_btn = 13
    input_enable_hotkey_btn = 9
    input_shader_next_btn = 6
    input_shader_prev_btn = 5
    input_remapping_directory = /opt/retropie/configs/neogeo/
    #include “/opt/retropie/configs/all/retroarch.cfg”

    as you can see I mapped some buttons to test different shaders. they won’t work. nor the default keyboard mapped keys. it just won’t work.

    On another small thing that grinds my gears, on lr-mame2010 when I press start player 1 (button 7) it shows framerate on the top right, I’m still trying to find how to disable that…

    but why are shaders not working? please help!

    helpman
    Participant
    Post count: 37

    results so far:
    lr-mame2010 … no shaders at all. no messages on screen. nothing.
    on a curious note, I don’t know why, pressing button 6 (without hotkey button pressed) shows a configuration menu like mame, but can’t enter any opcion, and pressing up/down makes it go crazy, as if I never stopped pressing the button)

    lr-imame4all … nothing.

    lr-picodrive … nothing

    lr-fba … nothing

    lr-fceumm … nothing

    lr-snes9x-next … nothing

    dankcushions
    Participant
    Post count: 432

    /opt/retropie/emulators/retroarch/shader/xsal/2xsal.glslp

    does this exist if you look via commandline/ftp?

    what happens if you open the RGUI and set up shaders from there?

    helpman
    Participant
    Post count: 37

    they are there, and they doesn’t seem to work either. anyway, as the shader previous/next bootlegs don’t work (confirmed) and I need them to change shaders on the fly I’m going to write the backup image I made when I was using 3.2 that works fine meanwhile

    dankcushions
    Participant
    Post count: 432

    I’d just try via the RGUI. that will prove that shaders work as they should. if shaders don’t work at all then the next/previous stuff is a red herring.

    patl
    Participant
    Post count: 56

    The shader files itself (all *.glsl) are working via RGUI and also via retroarch.cfg.
    But the glslp files are only working via RGUI, not via retroarch. They are just not loaded.
    If you then load manually the same glslp file via RGUI, they are working again.
    Why?… i don’t know ;-)

    rikrok
    Participant
    Post count: 4

    Gagh I wasted my entire evening yesterday trying to get shaders in 3.5 to work, I thought I was going mad. Does anyone know the last version in which they did work (any higher than 3.2)?

    helpman
    Participant
    Post count: 37

    I tried 3.4 and 3.5 both with same results… until they work I’ll use a backup image I made of 3.2 working :)

    dankcushions
    Participant
    Post count: 432

    anyone actually logged this issue with retroarch?

    https://github.com/libretro/RetroArch/issues

    helpman
    Participant
    Post count: 37

    not me, I though I was doing something wrong

    petrockblog
    Keymaster
    Post count: 1828
    petrockblog
    Keymaster
    Post count: 1828

    have you tried shader configuration from the “config editor” ? (Edit retropie/retroarch configurations on the retropie section of ES)

    helpman
    Participant
    Post count: 37

    yes, as I though maybe I needed to load one at startup before it would let me cycle them… it’s not loaded anyway

    petrockblog
    Keymaster
    Post count: 1828

    I just tested it and it works here – if you enabled a shader for a specific system config – post the config please (via pastebin.com or similar) (eg configs/nes/retroarch.cfg)

    petrockblog
    Keymaster
    Post count: 1828

    you can’t cycle through them currently unless you copy a selection of shaders from the subfolders in /opt/retropie/emulators/retroarch/shader to /opt/retropie/emulators/retroarch/shader or change the shader location and put a selection of shaders in there.

    See the retroarch ticket.

    I may add some workaround for this by symlinking a small selection of shaders to cycle through, but for now you have to use the config editor, manuall config, or copy the selection yourself.

    patl
    Participant
    Post count: 56

    Is it working there with glslp files or only with glsl files ?

    petrockblog
    Keymaster
    Post count: 1828

    glslp (the glsl are included by them afaik)

    Floob
    Member
    Post count: 1629

    @patl I imagine all the issues are as per the link posted above and its simply that there are only 3 shaders in the directory specified, and the next/previous feature doesnt traverse sub directories.

    So you could get round it by either moving some shaders around, setting your paths manually to look at a different dir or just manually setting a system specific config to load the one you want.

    Maybe I’m in a minority but I tend to find one I like and stick with it rather than scroll through loads.

    Have you tried davej shader?

    patl
    Participant
    Post count: 56

    Hi Floob,
    I also actually use only the barrel filter with CURVATURE_X.
    This problem wirh the shader subdirectories is noticed more by chance. :-)

    Floob
    Member
    Post count: 1629

    @patl Yes, thats really effective. Although I still mostly use your overlays – so thanks very much for the work you put into those. :)

    patl
    Participant
    Post count: 56

    You are welcome ;-)

    maketheworldbetter
    Participant
    Post count: 37

    I’ve had the same problem…

    It took a while, but I found out that it now is changeable
    easily from the Setup-script (presumably from ES itself,too if you have installed the RGUI-menu), menupoint ‘post-install-options’, then 304 Retroarch-options, point 1.

    I like that cause it seems to be changeable for each system – but it was hard to find that out as not even the users here had known that at that time and showed me only the old way…but I told enough now about order and sorting here :P

    helpman
    Participant
    Post count: 37

    thanks for the hint :) I have my interface set to english as I’m more used to it than spanish translations that can be misleading sometimes :)

    mydriaze
    Participant
    Post count: 28

    # Smoothens picture with bilinear filtering. Should be disabled if using pixel shaders.
    video_smooth = false
    # Path to shader. Shader can be either Cg, CGP (Cg preset) or GLSL, GLSLP (GLSL preset)
    video_shader = /opt/retropie/emulators/retroarch/shader/xsal/2xsal.glslp
    # Load video_shader on startup.
    # Other shaders can still be loaded later in runtime.
    video_shader_enable = true
    # Defines a directory where shaders (Cg, CGP, GLSL) are kept for easy access.
    video_shader_dir = /opt/retropie/emulators/retroarch/shader/

    What’s the difference between Path to shader and video_shader_dir? I don’t get it… thanks.

    dankcushions
    Participant
    Post count: 432

    i think: video_shader is the single shader you actually want applied (assuming you have video_shader_enable set)
    video_shader_dir is the root directory of all the shaders which is used by the GUI to give you a list of options in the shader menu.

    mydriaze
    Participant
    Post count: 28

    i think: video_shader is the single shader you actually want applied (assuming you have video_shader_enable set)i think: video_shader is the single shader you actually want applied (assuming you have video_shader_enable set)

    Not sure about this one, cause if I want to use a specific (single) shader, I simply have to edit the retroarch.cfg file in the specific emulator folder and add the proper line.

    Well, I don’t know, perhaps because i’m not english, but I didn’t understand the difference.

    anyway, thanks for your reply.

    Edit: any other opinion here? I still don’t understand the main difference, even with Dankcushions answer… :(

    mydriaze
    Participant
    Post count: 28

    Any update on this?

    dankcushions
    Participant
    Post count: 432

    i’m not sure what you’re asking? what are you trying to achieve here?

    video_shader_dir is where ALL the shaders are found, so when you use the retroarch GUI to choose one you can find them without having to navigate through your file system. you shouldn’t be changing this in retropie as it’s already configured.

    video_shader_path is the path to the SPECIFIC shader you want to enable in this emulator (or ALL retroarch emulators if you’re looking at all/retroarch.cfg). you also have to set video_shader_enable = true to get this shader to load on launch.

    mydriaze
    Participant
    Post count: 28

    Thanks for your reply. I’m on Retropie 3.6 at the moment.

    Edit: Ok, I understand my mistake. I was speaking about ” cycling” through the shader using M and N key, not the difference between the shader “lines” in the config file (thanks for your previous reply for this).
    I can’t find it on the forum, but i’m pretty sure there was an issue about this functuionnality previously…

    I simply want to launch a game, then press M or N and cycle through the various shader and choose de right one. But at the moment, it doesn’t work for me. And of course I’ve seen Floob videos. :)

    dankcushions
    Participant
    Post count: 432

    sounds like this issue – https://github.com/RetroPie/RetroPie-Setup/issues/1226 – sounds like it has been fixed, though?

    mydriaze
    Participant
    Post count: 28

    oh, I haven’t seen that. I will check tonight. I will reply here if i’m getting in trouble with the set up.

    Anyway, I would like to thank you for your help. I really appreciate. :)

    mydriaze
    Participant
    Post count: 28

    Ok, it’s not working properly. 15 days i’m on this issue soon, with no luck.
    To edit my files, i’m simply open it in notepad+ through my local network in windows. no Putty, no FTP, pure Windows folder.

    I have a keyboard, not set up. I just use it to edit metadata. I didn’t configure anything, but it works with the scraper. Pushing M or N doesn’t work at all.

    Here my settings:

      \\RETROPIE\configs\all\retroarch.cfg:

    # Applies next and previous shader in directory.
    input_shader_next = m
    input_shader_prev = n

    # Smoothens picture with bilinear filtering. Should be disabled if using pixel shaders.
    video_smooth = false

    # Defines a directory where shaders (Cg, CGP, GLSL) are kept for easy access.
    video_shader_dir = /opt/retropie/emulators/retroarch/shader/

    # Path to shader. Shader can be either Cg, CGP (Cg preset) or GLSL, GLSLP (GLSL preset)
    # video_shader = “/path/to/shader.{cg,cgp,glsl,glslp}”

    What I’m doing wrong? Thanks for your help guys. Im struggling…

    dankcushions
    Participant
    Post count: 432

    you have to hold your hotkey enable button to select shaders. i’m not sure what it is on keyboard, but it works for me if i press select on my joypad (hotkey_enable), and then n or m on my keyboard, it cycles shaders.

    maybe it should be mapped to some joypad buttons instead by default in retropie, as it’s not really usable like this, but i don’t know.

    mydriaze
    Participant
    Post count: 28

    For sure i’m the dumbest guy on earth. I didn’t thought for one second that I have to push my hotkey + M or N button. Will give a try tonight.

    Thanks for your help.

Viewing 34 posts - 1 through 34 (of 34 total)
  • The forum ‘Video Output on RetroPie’ is closed to new topics and replies.