[Retropie 2.X] list of issues

This topic contains 54 replies, has 28 voices, and was last updated by Profile photo of dk999 dk999 2 years, 5 months ago.

Viewing 20 posts - 36 through 55 (of 55 total)
  • Author
    Posts
  • #34392
    Profile photo of geddons
    Geddons

    Hey guys,

    I just opened the new issue on the GitHub page.

    The post contains my workaround for using NetPlay with RetroArch and being able to play multiplayer games over the Internet.

    I’m opening a separate topic to discuss it longer regarding the lag/out-of-sync issues.

    Cheers,

    Pierre.

    #44885
    Profile photo of borlandoflorida
    borlandoflorida
    Participant

    I can confirm n64 does not launch roms from within ES. Launching the emulator direct from command line does work however. I’ve poked around with how es_systems.cfg launches n64 but can’t get it to work.

    Would this have anything to do with the runcommand.sh file? Maybe an error within here (seen some posts mentioning line 23 being an issue)?

    I wouldn’t know what to look for, but thought it might be worth mentioning. Although it might be possible to launch the N64 emulator using the command line, it is not ideal as this would mean keeping a keyboard attached or having to SSH into the Pie whenever we want to play some N64 goodness…

    #44890
    Profile photo of borlandoflorida
    borlandoflorida
    Participant

    This is the command in emulation station that starts mupen64 and generates the n64 seg fault everyone is encountering.
    /opt/retropie/supplementary/runcommand/runcommand.sh 1 "cd /opt/retropie/emulators/mupen64plus-rpi/test/ && ./mupen64plus %ROM%"
    I don’t see anything immediately wrong with it (for instance, the path exists on my system and there is a file called mupen64plus there), but I’m not an expert. I do notice that none of the other commands in the es_systems.cfg file perform a cd first and THEN a separate run command. Maybe that is the source of the error?

    Has anybody managed to look into this? Apparently it is possible to launch N64 emulator using the command line option, but is not ideal. A fix so that you can launch the game through the same way in ES’ GUI would be great.

    #44917

    Haris

    +1 for this fix!

    #49475
    Profile photo of peanut
    peanut
    Participant

    I’m gonna start messing around with Retropie again. I tried getting my xin mo PCB to work but there was a mistake in the Linux kernel of retropie and I was wondering if this issue has been resolved yet so all buttons work properly

    #51714
    Profile photo of bmoc
    bmoc
    Participant

    If you are running retropie with PAL composite output, when exiting a NES game to go back to the emulation station menu the display cuts out. You can still select and load games, at which point you will get a picture again. No problem when booting up for the first time, only after exiting a game.

    This is with PAL output set by altering the config.txt in the boot directory by uncommenting the sdtv=2 line, and by changing the runcommand parameter for the NES emulator in the es_systems.cfg

    This problem doesn’t happen when running NTSC.

    #66660
    Profile photo of solodev
    solodev
    Participant

    Hi. New here, and when I ran the updated retro_setup.sh I was constantly seeing this error. This anything to worry about?

    Traceback (most recent call last):
    File “/opt/retropie/supplementary/ESConfigEdit/esconfedit.py”, line 291, in <module>
    systemlist.loadSystems(args.inputfile, args.dontstop)
    File “/opt/retropie/supplementary/ESConfigEdit/esconfedit.py”, line 73, in loadSystems
    system.find(‘platform’).text,
    AttributeError: ‘NoneType’ object has no attribute ‘text’

    Seems like it popped up every time it was installing something, an emulator, shared files, anything.

    I did update the setup script prior to this.

    #72862

    Rick Tryon

    I can’t seem to get any of my controllers to work. I used a wired Xbox 360 controller and a generic gamepad (no idea of the make or model) that I have had laying around for a few years. The controllers work in the EmuationStation menus, but when I enter an emulator (SNES, NES), they do not work.

    #81483
    Profile photo of sluysen
    sluysen
    Participant

    Hello all

    I am fairly new to linux and raspberry pi.
    I used it for XBMC in the past but that’s just straightforward, install the image and start it up.

    Now I wanna use retropie. I have downloaded the 2.3 image and it’s working. But I have a lot of questions

    1) for xbox 360 controller you need to do “sudo apt-get install xboxdrv”
    right from the start this gives an error: “install: missing destination file operand …”
    How can I fix this so I can use an xbox 360 controller (and go through the rest of the tutorial steps)

    2) what is the way to get more emulators (like nes/snes/sega) and games (really love doom and duke on it, but want more :p)

    If these are noobish questions and there’s a tutorial for it, please point me to it as I cannot find it

    #81542
    Profile photo of escher
    escher
    Participant

    I can confirm that the “input_exit_emulator_btn” isn’t working with USB controlers (I’m using a Zero Delay USB encoder for real arcade buttons).

    I tried to configure the exit button in all config files (from retroarch.cfg to the snes configs).

    It used to work on previous version of retropie (v. 1.9).

    Anything related to configuration I can assure that it’s ok (I’m a senior at *nix administration)

    Ps: Yes, I am using double quotes: input_exit_emulator_btn = “8”

    #81677
    Profile photo of levi223
    levi223
    Participant

    I am having difficulties changing the key mapping of the ps3 in gpsp. It isnt like like the other retroarch emus. And when i try to configure it manually through terminal (/home/pi/retropie/gpsp/gpsp) i don’t really know what to do to configure it. Currently im on the latest version of emulation-station and retropie.

    #81850
    Profile photo of imnew
    imnew
    Participant

    =>workaround: copy the file from /etc/emulationstation/es_systems.cfg to ~./emulationstation/es_systems.cfg

    I tried this, now I just have a black screen.

    I was originally getting this error on start up after updating the binaries :

    https://lh3.googleusercontent.com/-cLb4y5uk7cs/VEGFfvmmo2I/AAAAAAAAZoY/ADVrfHjPdoU/w1115-h837-no/20141017_220841.jpg

    Any suggestions?

    cheers

    #82041
    Profile photo of proxycell
    proxycell
    Participant

    I ran the compile from source option on Friday and it finished up last night and I got the following errors:
    Could not compile: DGEN, jzintz, mame4all-pi, PiSNES, FBA Core, PC Engine Core

    Here is the screenshot of the terminal and a link to the log file:
    http://www.iruberleet.org/files/retropiecompilationfails261014.png
    http://www.iruberleet.org/files/run_24102014_1940.log

    #82063
    Profile photo of uadrol
    uadrol
    Participant

    Hi There.
    I try to run any of my Amiga adf file but the only result is black screen. Am I doing something wrong? Is kickstart needed in roms directory?

    #82074
    Profile photo of escher
    escher
    Participant

    UPDATE: I’ve managed to make the exit btn work.
    All I had to do was put those lines in /opt/retropie/config/snes/*.cfg file.

    input_enable_hotkey_btn = “3”
    input_exit_emulator_btn = “2”

    It’s strange, but for some reason, my Zero Delay USB encoder reads from snes config file for ALL emulators.

    The only emulator that I can’t manage to work exit buttons is MAME-PI.

    #83476
    Profile photo of arcadoff
    arcadoff
    Participant

    Hello, Escher!
    facing same problem: I have every emu configured with USB logitech gamepad , but in deep troubles with my diy zeroDelay 12 buttons console.
    Could you please quote your retroarch .cfg file for zeroDelay and especially aside emulators .cfg s as well. Thank you!
    PS: did not find PM way here, sorry. However it is really interesting for everybody as zeroDelay is a good choice because of its price/

    #83498
    Profile photo of escher
    escher
    Participant

    arcadoff, actually I’ve solved this problem by inputing the config buttons in the snes config file (it’s strange, but it works)

    All I had to do was put those lines in /opt/retropie/config/snes/*.cfg file.

    input_enable_hotkey_btn = “3”
    input_exit_emulator_btn = “2”

    I’m not with my R-Pi with me now, but I promiss that later I’ll paste it’s config here.

    Good luck!

    #83541
    Profile photo of downup
    downup
    Participant

    Hope for a n64 fix soon, even if the games are slow is’t just awesome to have some game on it

    #83742
    Profile photo of pianobrad
    pianobrad
    Participant

    UPDATE: I’ve managed to make the exit btn work.
    All I had to do was put those lines in /opt/retropie/config/snes/*.cfg file.

    input_enable_hotkey_btn = “3”
    input_exit_emulator_btn = “2”

    It’s strange, but for some reason, my Zero Delay USB encoder reads from snes config file for ALL emulators.

    The only emulator that I can’t manage to work exit buttons is MAME-PI.

    escher, thank you! I’ve just set up RetroPie within the last few days and couldn’t, for the life of me, figure out how to get those hotkeys and exit buttons enabled. I had a look around in the default config and “input_enable_hotkey” as a parameter, but that wasn’t working at all. Your 2 lines did the trick.

    As you’ve indicated, most emulators control fine. The one issue I’d like to resolve seems to be with MAME. Does anyone have any experience adding controller configurations, specifically mapping an snes-style usb controller, to the MAME arcade emulator under RetroPie 2.3?

    Cheers!

    #87874
    Profile photo of dk999
    dk999
    Participant

    Can’t load any shader via retroarch, doesn’t seem to take any effect even by setting them manually through retroarch.cfg :-/

    Hardware is Pi2 with Beta 2.5

Viewing 20 posts - 36 through 55 (of 55 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar