Retropie 2.6 – Crash at Boot after update

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Retropie 2.6 – Crash at Boot after update

This topic contains 3 replies, has 3 voices, and was last updated by  Anonymous 2 years, 10 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #92251


    today i updated my PSX and N64 Emulators using ./Retropie-Setup. After this i rebooted and updated the Retropi itself with this command

    sudo apt-get update && sudo apt-get upgrade -y

    after this the boot failed.

    This error came up:

    Panic VFS :Unable to mount root fs on unknown-block

    Here is the Text from my SD-Card cmdline.txt

    dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait

    and issue.txt from SD-Card

    Raspberry Pi reference 2014-01-07 (armhf)
    Generated using spindle,, 0e00a4f, stage4-lxde-edu.qed

    Any way to help?
    Or myabe a way to get the savegames from PSX as backup when i need to reinstall the SD card?!



    Looks like you have some file system corruption. If it were mine, I would just reinstall the SD card image.

    The saves should be in with the ROMs / CD images. For PlayStation that’s /home/pi/RetroPie/roms/psx. The saves will be the same name as the ROM with a *.srm extension



    I am having the same issues. I can install the 2.6 image fine, but after i run

    sudo apt-get update && sudo apt-get upgrade -y

    or update the binaries from the retropie_setup script, the system becomes unusable. I have re-installed the image several times over the last couple of days and it works fine right up until i run either of the updates.

    Directly after the update i am unable to shut the pi down as when i issue the reboot or shutdown commands i get an error that indicates the binaries are no compatible with the system. Its like the update overwrote my system with binaries from a completely different architecture.

    I have a RPI2 and live in Australia (could be a corrupt local mirror?).



    I dont know i had to reinstall my Pi to fix the problem.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss