Retrolink Controller Issue

This topic contains 5 replies, has 2 voices, and was last updated by Profile photo of amigagamer amigagamer 2 years, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #92437
    Profile photo of damagio
    damagio
    Participant

    Hi All,

    Well…I really tried to figure this out but I am stumped…total pi noob but I am a bit familiar with Linux and very familiar with emulators.

    So…I have configured this game pad in the retropie setup and it says it is USBGamepad.cfg the file is there and appears correct…problem is that when I start emulation station go to NES and start the rom…two things happen….when I move the dpad I get this little pop up bottom left that says State Slot: 0 when I move right it goes up….left down…when I press b it does what it is supposed to but a resets the game! Almost like the gamepad is doing two things at once. I started from scratch 3 time using 3 tutorials…same result. The test shows the joystick working fine.

    Any suggestions? Thanks guys!

    #92503
    Profile photo of amigagamer
    amigagamer
    Participant

    Which retrolink controller is it? They do a bunch of different ones eg SNES style, atari style, genesis etc.

    One thing ive noticed with retrolink pads is many of them contain the same microchip, so retroarch/retropie cant identify a snes style from a genesis for instance. in all the pads ive tried this only really affects the button mappings though, not the D-pad.

    if you can exit emulationstation back to a linux terminal can you try typing “lsusb” on the command line please. This should give you a list of connected usb devices.
    look for a line similar to
    ID 0079:0011 DragonRise Inc. Gamepad
    and post teh result up please (along with which type of pad it is.)

    #92523
    Profile photo of damagio
    damagio
    Participant

    Hi amigagamer,

    Thank you for your help..

    This is the Retrolink Usb snes clone controller

    I typed in slush and got Exactly what you posted

    Bus 001 Device 004: ID 0079:0011 DragonRise Inc. Gamepad

    I suspect that RetroArch is not using the proper config file USBGamepad.cfg. How can I test this theory?

    Thanks!!

    #92524
    Profile photo of damagio
    damagio
    Participant

    I got it guys

    Had to add a line to retroarch.cfg

    input_enable_hotkey_btn = “0”

    Works perfectly now!!!!

    #92740
    Profile photo of amigagamer
    amigagamer
    Participant

    Glad you got it fixed,

    Still thats strange behaviour you were getting from your pad. It sounds almost like your SELECT button was stuck down so it was passing Hotkeys on every press maybe?

    if it happens again try running jstest /dev/input/js0 to test your pad, see if any buttons are stuck in an ON state (i think button 8 or 9 is select on that pad)

    #93091
    Profile photo of amigagamer
    amigagamer
    Participant

    Interestingly since i upgraded to a clean 3.0 beta, i ran into the same problem as you. Similar threads have appeared on the forum as well. Looks like a retropie issue with the hotkeys being set to on. Disregard my last post about jstest on your pad. sorry for bad info :p

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar