Retrolink Controller Doesn’t Work Properly in Roms

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Retrolink Controller Doesn’t Work Properly in Roms

This topic contains 6 replies, has 4 voices, and was last updated by Profile photo of ronoh55 ronoh55 2 years, 2 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #91362
    Profile photo of dracdude
    dracdude
    Participant

    Hey guys, I’ve been trying to figure this out for the last week and have still had no luck. I have a retrolink SNES usb gamepad and whenever I boot up a rom to play in retropie when I hit my A button it resets my whole game and X will bring me into this retroarch menu and whenever i hit a button it gives me yellow dialog at the bottom of the screen. I’ve tried configuring the controller in retropi and I’ve set it up in the setup menu as well and then went in and edited the config but nothing has changed. A resets the game and X will bring me into the retroarch menu. Am I missing something. I don’t know what else to try other then starting over from scratch and trying again.

    #91423
    Profile photo of Floob
    Floob
    Member

    It sounds like your hotkeys are set to on all the time.
    Try changing this in your /opt/retropie/configs/all/retroarch.cfg file

    input_enable_hotkey = nul
    to
    input_enable_hotkey = alt

    Here is a hotkey guide
    http://dai.ly/x2hxlc3

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #91563
    Profile photo of dracdude
    dracdude
    Participant

    Thank you very much for your reply Floob, that looks like it fixed the hotkeys automatically being used whenever I play again however I still can’t get my controller to exit out back to RetroPi. Everytime I hit select it just pauses the game when I hit select and start it doesn’t do anything and I mimicked your code with my controller. I tried adding the shader inputs too but whenever i typed quote ” to put a number and it put a @. So I don’t know what’s up with that. Thanks again for your help. I don’t know why my select button is acting like a start key.

    This is my code for my USB Gamepad

    input_device = “USB Gamepad ”
    input_driver = “udev”
    input_b_btn = “2”
    input_y_btn = “3”
    input_select_btn = “8”
    input_start_btn = “9”
    input_up_axis = “-1”
    input_down_axis = “+1”
    input_left_axis = “-0”
    input_right_axis = “+0”
    input_a_btn = “1”
    input_x_btn = “0”
    input_l_btn = “4”
    input_r_btn = “5”
    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”
    input_menu_toggle_btn = “0”
    input_load_state_btn = “4”
    input_save_state_btn = “5”
    input_reset_btn = “2”
    input_state_slot_increase_axis = “+0”
    input_state_slot_decrease_axis = “-0”

    #91648
    Profile photo of Floob
    Floob
    Member

    You’ve got quite a mixture of quotes in that example, some are ” , ″, “, ”

    Are the all exactly the same type when you edit the file with nano?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #93061
    Profile photo of mattrfh
    mattrfh
    Participant

    i am having the same problem with the retrolink snes controller. no matter what i do in retroarch controller configuration the buttons do not get reassigned. select acts like start. a acts like b. b acts like a and so on. I have manually edited USBGamepad.cfg as well and that didnt fix the situation. I am not sure where this controller is pulling its cfg from.

    #93062
    Profile photo of mattrfh
    mattrfh
    Participant

    just as an aside i also have an ibuffalo controller and it works flawlessly configuring through retroarch or manually using sudo nano.

    #93790
    Profile photo of ronoh55
    ronoh55
    Participant

    Registered just to add to this thread.

    I have the same SNES gamepad and have now DELETED the autoconfig file for the gamepad, with no changes to the main retroarch.cfg and the gamepad is recognized by RetroArch AND still has the wrong layout (a=b, b=a, etc.)

    It worked perfectly in 2.6.

    Edit: I’m using the raspi 2 if it makes any difference.

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar