Retroarch using wrong input device

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Retroarch using wrong input device

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of machtroid machtroid 1 year, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #112178
    Profile photo of machtroid
    machtroid
    Participant

    I just upgraded to Retropie 3.2.1 and I am experiencing an input issue. I have 2 devices connected to my Pi 2 – a wireless keyboard and a Logitech F710 joypad. After the initial input setup via Emulationstation, when I open a game on any system it will display that it detects my keyboard in port 0 and joypad in port 1. However my joypad will not work. If I go into the Retroarch menu and go to Settings > Input it shows that User 1 Device Index is set to the keyboard. I can change this to the joypad and then it will work, however I have to do this every single time I enter a game. Even if I select “User 1 Save Autoconfig” it will still default to the keyboard every time. Is there any known solution for this issue?

    #112179
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Swap the USB ports around.

    #112183
    Profile photo of herbfargus
    herbfargus
    Member

    see also:

    usbports

    #112217
    Profile photo of machtroid
    machtroid
    Participant

    Ah, that did it! I had no clue what the port assignments were. Thanks!

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar